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C H A P T E R 1
Prepare to Install

Cisco Jabber Guest can be deployed in combination with Cisco Expressway-E and Cisco Expressway-C or
in combination with Cisco VCS-E and VCS-C. To simplify the documentation, we reference only Cisco
Expressway-E and Cisco Expressway-C throughout this guide.

Themobile andweb clients use the same interfaces when interactingwith Cisco Expressway/Cisco TelePresence
Video Communication Server (VCS) and Cisco Jabber Guest. To simplify the documentation, we reference
only the web client throughout this guide.

• Server Requirements, on page 1
• License Requirements, on page 4
• Client Requirements, on page 6
• Deployment Options, on page 15
• Network Topology, on page 16
• Ports and Protocols, on page 20
• Clustering Options, on page 24
• Load Balancing Methods Available, on page 25

Server Requirements

Cisco Product Requirements
Deploy Cisco Jabber Guest with an existing Cisco Unified Communications Manager installation.

To allow Cisco Jabber Guest to access devices located inside the enterprise firewall, deploy the following:

• Cisco Unified Communications Manager 8.6.x or later

Cisco Jabber Guest requires that your Cisco Unified Communications Manager be configured to work
with Cisco Expressway.

• Cisco Jabber Guest Server

• Cisco Expressway-C X8.2 or later

• Cisco Expressway-E X8.2 or later

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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• Without Cisco Expressway-C and Cisco Expressway-E, you are limited to
testing with clients that can directly access the network on which the Cisco
Jabber Guest server is homed.

• You cannot use the same Cisco Expressway-C and Cisco Expressway-E pair
or cluster for both Cisco Jabber Guest and Expressway for Mobile and
Remote Access.

Important

For more information, download the Cisco Expressway Administrator Guide, deployment guides, and release
notes or see the online help for complete information on configuring the options available on your Cisco
Expressway.

Virtual Machine Requirements
Cisco Jabber Guest is deployed as a virtual server using the Open Virtualization Format (OVF) standard for
packaging and distributing virtual appliances that run in a virtual environment. It requires VMware vSphere
as the hypervisor. Cisco publishes the distribution as an OVF file with the file extension .OVA, which stands
for Open Virtual Appliance. This file contains the OVF template for the application. The OVF template defines
the virtual machine’s hardware and is preloaded with required software.

Hardware and System Requirements
• A server platform that meets VMware’s Compatibility Guide for VMware vSphere 5.1 or later is required.
The Cisco Jabber Guest virtual machine uses a 64-bit distribution of CentOS 6.10. Make sure that the
server platform uses CPUs that are capable of 64-bit instructions.

• Cisco Jabber Guest Server is supported on any Full UC Performance CPU, beginning with Intel Xeon
Processor 5600 with a minimum physical core speed of 2.53 GHz or higher and any Restricted UC
Performance CPU, beginning with Intel Xeon Processor E5 2609 v1with aminimum physical core speed
of 2.4 GHz or higher. For more information on Full UC performance CPUs and RestrictedUCPerformance
CPUs, see the Processors/CPUs section in UC Virtualization Supported Hardware.

• Cisco Jabber Guest is allowed on server models meeting required specifications, including Cisco Business
Edition 6000 (BE6000), Cisco Business Edition 7000 (BE7000), and UC on UCS Tested Reference
Configurationswith a Full UCPerformance CPU. BE6000M (M2)UCSC200M2TRC#1 is not supported.
For more information, see Virtualization for Cisco Jabber Guest Server. Cisco Jabber Guest Server must
follow the application co-residency and virtual-to-physical sizing rules in the Unified Communications
Virtualization Sizing Guidelines.

• Cisco Jabber Guest supports all virtualization software described in Purchasing/Sourcing Options for
Required Virtualization Software.

• If Cisco Jabber Guest Server is installed on a Cisco Business Edition 6000 server or Cisco Business
Edition 7000 server, it must follow the additional co-residency rules in the Cisco Business Edition 6000
and Cisco Business Edition 7000 Co-residency Policy Requirements.

• See the VMware developer documentation for additional configuration and hardware requirements. We
highly recommend using the Cisco Unified Computing System (CUCS) to simplify and maximize
performance.

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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Related Topics
Processors/CPUs section in UC Virtualization Supported Hardware
Virtualization for Cisco Jabber Guest Server
Unified Communications Virtualization Sizing Guidelines
Purchasing/Sourcing Options for Required Virtualization Software
Cisco Business Edition 6000 and Cisco Business Edition 7000 Co-residency Policy Requirements

Supported Storage Models

Virtual Machine Specifications

Table 1: Virtual Machine Specifications

Memory
Resource
Allocation

CPU Resource
Allocation

Operating SystemStorageCPURAM

Default (not
defined)

Default (not
defined)

CentOS 6.10 64-bit100 GB2 logical CPUs
with 1 core each

4 GB

VMware vSphere Feature Support
The following VMware vSphere features are supported:

• VM OVA template deployment (using the Cisco-provided Cisco Jabber Guest OVA)

• VMware vMotion

• VMware vSphere Distributed Switch (vDS)

• VMware Dynamic Resource Scheduler (DRS)

• VMware Storage vMotion (Storage DRS)

• VMware Virtual Machine Snapshots

You can restart Cisco Jabber Guest on a different VMware ESXi host and create or revert VMware Snapshots
as long as the application was shut down without any issues before moving or taking a snapshot.

The following VMware vSphere features have not been tested with Cisco Jabber Guest:

• VMware Site Recovery Manager (SRM)

• VMware Consolidated Backup (VCB)

• VMware Data Recovery (VDR)

• VMware Dynamic Power Management (Cisco Jabber Guest must be configured to run 24/7)

• Long Distance vMotion (vMotion over a WAN)

• VMware Fault Tolerance (FT)

The following VMware vSphere and third-party features are not supported with Cisco Jabber Guest:

• VMware Hot Add
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• Copying a Cisco Jabber Guest virtual machine (must use OVA to deploy new server)

• Configuring Cisco Jabber Guest with multiple virtual network interface controllers (vNICs)

• Third-party Virtual to Physical (V2P) migration tools

• Third-party deployment tools

Reverse Proxy Server Requirements
The Cisco Expressway-E and Cisco Expressway-C can be used to tunnel HTTP from the Cisco Jabber Guest
client to the Cisco Jabber Guest server. If a third-party reverse proxy is used in front of the Cisco Expressway-E,
configure it to proxy only the following URL types:

• /call

• /jabberc (used for HTTP/call control)

Configure the reverse proxy to redirect any HTTP requests to HTTPS.

License Requirements
Cisco Jabber Guest is licensed and obtained through User Connect Licensing (UCL), Cisco UnifiedWorkspace
Licensing (CUWL), and other ordering mechanisms. Contact a sales representative from a Cisco partner or
from Cisco for ordering details. No license keys are provided or required for the Cisco Jabber Guest software.

The following table describes the license requirements for using Cisco Expressway with Cisco Jabber Guest.

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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Table 2: License Requirements for Using Cisco Expressway with Cisco Jabber Guest

NoteRequirementLicense

• For Cisco Expressway X8.7.3
or earlier, 2 Rich Media
Session licenses are required
per Cisco Jabber Guest
session:

• 1 Rich Media Session
license on the Cisco
Expressway-E for each
Cisco Jabber Guest
session

• 1 Rich Media Session
license on the Cisco
Expressway-C for each
Cisco Jabber Guest
session

• For Cisco Expressway X8.8
or later, 1 RichMedia Session
license on the Cisco
Expressway-E is required for
each Cisco Jabber Guest
session

Rich Media Session
licenses

When you order Cisco Expressway, a TURN
relay license is included.

TURN licensed on Cisco
Expressway

TURN relay license

When you order Cisco Expressway, an AN
license is included.

If Cisco Jabber Guest is installed
in a dual-NIC deployment, an AN
license is required on Cisco
Expressway.

Advanced Networking
(AN) license

The following table describes the license requirements for using Cisco TelePresence Video Communication
Server (VCS) with Cisco Jabber Guest.

Table 3: License Requirements for Using Cisco VCS with Cisco Jabber Guest

NoteRequirementLicense

2 traversal call licenses are required
per Cisco Jabber Guest session:

• 1 traversal call license on the
VCS-E for each Cisco Jabber
Guest session

• 1 traversal call license on the
VCS-C for each Cisco Jabber
Guest session

Traversal call licenses

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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NoteRequirementLicense

When you order Cisco VCS, a TURN relay
license is included.

TURN licensed on Cisco VCSTURN relay license

When you order Cisco VCS, a DI license is not
included. Specifically select this license.

If Cisco Jabber Guest is installed
in a dual-NIC deployment, a DI
license is required on Cisco VCS.

Dual Network
Interface (DI) license

Client Requirements

Client Hardware and System Requirements
Users require a multimedia-capable computer with a camera and microphone that support the following
software and hardware requirements:

Table 4: Client Requirements

Mac RequirementsWindows Requirements

macOS 10.13 to 10.15Microsoft Windows 7 or laterOperating system

Intel x86 processor

Encoding at 720p 30 fps requires Intel
Core2Duo @ 1.2 GHz or better. For
optimal experience, Core2Duo @ 2
GHz with 2 MB L2 cache per core is
recommended.

GPU capable of OpenGL 1.2 or later

Minimum CPU supporting SSE2
(Pentium IV or newer)

Encoding at 720p 30 fps requires Intel
Core2Duo @ 1.2 GHz or better

Encoding at VGA 30 fps can be done
on as low-end CPUs as the Intel Atom
@ 1.6 GHz

Hardware

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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Mac RequirementsWindows Requirements

Safari 7 to 11

Mozilla Firefox 10 or later2

Google Chrome 18 or later

Safari requires you to
manually restart the
browser in order for the
Jabber Guest plugin to take
effect.

Note

Mozilla Firefox 10 or later

Google Chrome 18 or later

Microsoft Internet Explorer 8 or later
(32-bit, or 64-bit running 32-bit tabs
only. 64-bit browsers running 64-bit
tabs are not supported.)

Note 1. OnWindows 8 or later,
only the desktop
version is supported.
The Metro version
won't work.

2. Microsoft Internet
Explorer 8 exhibits
some minor layout
differences because of
certain browser
limitations.

3. You may encounter
video frame layout
issues in Windows 7
and Windows 8, if the
screen display scaling
is not set at 100%. This
is due to an OS
limitation and does not
occur in Windows 8.1
or later.

1

Browsers

1 To configure Internet Explorer on Windows 8 or later to open the desktop version by default, do the
following:

1. Open Microsoft Internet Explorer.
2. From the Tools menu, click Internet options.
3. Click the Programs tab.
4. Under Opening Internet Explorer, choose Always in Internet Explorer on the desktop.

2 Currently, a known issue with Firefox on Mac OS X prevents full-screen video. This option is not
offered for this combination of browser and operating system.

Cisco Jabber Guest Plug-in Requirement
The Cisco Jabber Guest solution includes a browser plug-in that is downloaded and installed by the caller on
the local machine. For Google Chrome and Firefox (50 and later), the web page prompts the user to install

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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the Chrome/Firefox Extension and the Cisco Jabber Guest Add-on. For all other browsers, the Cisco Jabber
Guest web page prompts the caller to download and install the plug-in the first time the service is used.

New plug-ins are periodically made available with fixes and new functionality. The caller is prompted to
download and install the new plug-in the next time an attempt is made to place a call.

Supported Mobile Devices

Android Supported Devices

We support Cisco Jabber Guest for Android on audio and video for the followingAndroid devices and operating
systems:

Table 5:

LimitationsMinimum Android OSModelMake

Blackberry Priv device
limitation: If Jabber is
removed from the recently
viewed apps list, and the
device is kept idle for
some time, then Jabber
becomes inactive.

5.1PrivBlackBerry

6.0.1Arrows M357Fujitsu

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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LimitationsMinimum Android OSModelMake

5.1.14Google Nexus

55

65X

5.0.26

If you have a Google
Nexus 6P device with
Android OS version 6.x
or 7.0, then contact your
administrator to set your
Jabber phone service as a
secure phone service.
Otherwise, your device
might not respond.
However, if your Android
OS version is 7.1 or later,
no action is required.

66P

57

5.0.29

510

7Pixel

6Pixel C

7Pixel XL

During a Jabber call if the
user switches audio from
mobile device to a
headset, then there might
be some issues with the
auido for few seconds.

8Pixel 2

During a Jabber call if the
user switches audio from
mobile device to a
headset, then there might
be some issues with the
auido for few seconds.

8Pixel 2 XL

If you use the attached
headset with the phone,
then there might be some
issues with the audio for
few seconds.

8Pixel 3

8Pixel 3 XL

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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LimitationsMinimum Android OSModelMake

If you use the attached
headset with the phone,
then there might be some
issues with the audio for
few seconds.

7.1.1CT40Honeywell Dolphin

5CT50

610HTC

6A9

5.0.2E9 PLUS

5M7

5M8

5M9

5One Max

6X9

5Honor 7Huawei

5M2

5Mate 7

6Mate 8

6Mate 9

7Nova

8Mate 10

8Mate 10 Pro

5P8

6P9

7P10

7P10 Plus

8P20

8P20 Pro

8Mate20

8Mate20 Pro

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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LimitationsMinimum Android OSModelMake

5G2LG

5G3

5.1G4

6G5

7G6

5V10

8V30

Cisco Jabber supports
only audio mode with
MC40 device. Cisco
Jabber does not support
launching Webex
Meetings from MC40
device.

5MC40Motorola

5Moto G

5Moto X

6Moto Z Droid

5OneOnePlus

85

85T

96

96T

Contact your
administrator to set your
Jabber phone service to be
secure. Jabber plays
ringback tone and busy
tone at 24kHz.

5Toughpad FZ-X1Panasonic

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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LimitationsMinimum Android OSModelMake

· In the Samsung devices
with Android OS 5.x or
later, the auto-run option
for Jabber must be
enabled.

5AllSamsung

For Android OS 5.x, you
can find the auto-run
option under Settings and
Device Manager.

For Android OS 6.x and
later, you can find the
auto-run option under
App Smart Manager.

· Jabber delays the
incoming call notification
pop-up on Samsung
Galaxy Tab Pro
8.4(Model
T320UEU1AOC1) for
Canada.

· Jabber delays
reconnecting to the
network on a Samsung
Xcover 3 when it loses
Wi-Fi connectivity.

6.0.1M1LSmartisan

7.1.1XP8Sonim

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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LimitationsMinimum Android OSModelMake

5M2Sony Xperia

7XZ

8XZ1

8XZ2

9XZ3

5Z1

5Z2

5Z2 tablet

Sony Xperia Z3 (Model
SO-01G) with Android
OS 5.0.2 has poor audio
on Jabber calls.

5Z3

5Z3 Tablet Compact

Video call is unstable on
Sony Z3+/Z4, you can
disable your self-video for
a video call or make a
voice call only.

5.0.2Z3+/Z4

5Z4 TAB

5.0.2Z5 Premium and Z5

There is a limitation that
Sony devices with
Android OS 6.0 cannot
play voicemail in Jabber.

5ZR/A

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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LimitationsMinimum Android OSModelMake

5.14CXiaomi

5.1MAX

5Mi 4

6Mi 5

7Mi 5s

7Mi 6

8Mi 8

8Pocophone

5Mi Note

7Mi Note 2

5.1Mi Pad 2

8Mi MIX 2

8Mi A1

5.1Redmi 3

5.1Redmi Note 3

6.0.1Redmi Note 4X

8Redmi Note 5

6TC51Zebra

TC70 devices might
sometimes have issues
connecting to Wi-Fi
network configured over
DHCP.

5TC70

In TC70, the default value
of Keep wifi on during
sleep is Off, you must set
it to Always On to use
Jabber.

6TC75X

We support Cisco Jabber Guest for Android with tested Android devices. Although other devices are not
officially supported, you may be able to use Cisco Jabber Guest for Android with other devices.

iOS Supported Devices

Cisco Jabber Guest is supported on iOS 12or later.

The following table lists the iOS mobile devices that Cisco Jabber Guest supports:

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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iPadiPhone

Pad AiriPhone 5S

iPad Air 2iPhone 6

iPad Air (2019)iPhone 6 Plus

iPad (2017)iPhone 6S

iPad (2018)iPhone 6S Plus

iPad Mini 2iPhone SE

iPad Mini 3iPhone 7

iPad Mini 4iPhone 7 Plus

iPad Mini (5th generation)iPhone 8

iPad Pro (9.7-inch)iPhone 8 Plus

iPad Pro (10.5-inch)iPhone X

iPad Pro (11-inch)iPhone XS

iPad Pro (12.9-inch 1st generation)iPhone XS Max

iPad Pro (12.9-inch 2nd generation)iPhone XR

iPad Pro (12.9-inch 3rd generation)

Deployment Options
Cisco Jabber Guest supports two deployments:

• Cisco Expressway-E with a single NIC—SIP traffic goes to the Cisco Expressway-C and media flows
over a port range between the Cisco Expressway-E and the Cisco Expressway-C.

• Cisco Expressway-Ewith dual NIC—SIP traffic goes to the Cisco Expressway-E andmedia flows through
the traversal zone between the Cisco Expressway-E and the Cisco Expressway-C.

Only the Cisco Expressway-Ewith dual NIC deployment supports NAT/PAT between the Cisco Expressway-E
and the Cisco Expressway-C.

Important

Lab Deployment

Cisco Jabber Guest can be pointed directly to Cisco Unified Communications Manager for lab deployments
only; configure a SIP trunk on Cisco Unified Communications Manager for this deployment. This option is
best suited to a lab deployment in which the goal is to familiarize yourself with Cisco Jabber Guest without
the additional overhead of configuring Expressway. However, without configuring Expressway, Cisco Jabber
Guest is not supported in a production environment.

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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Network Topology
Overview of Cisco Expressway-E with Single NIC Deployment

• SIP traffic is sent to the Cisco Expressway-C.

• Cisco Expressway-E is single NIC only.

• Cisco Expressway-E in static NAT mode is optional and requires additional configuration on the Cisco
Jabber Guest server.

• Cisco Expressway-E is used for TURN services and reverse proxy, not call control.

• Media flows between the Cisco Expressway-E and the Cisco Expressway-C over port range, not a traversal
zone.

Overview of Cisco Expressway-E with Dual NIC Deployment

• SIP traffic is sent to the Cisco Expressway-E.

• Cisco Expressway-E is dual NIC only.

• Cisco Expressway-E in static NAT mode is optional and requires additional configuration on the Cisco
Jabber Guest server.

• Cisco Expressway-E is used for TURN services, reverse proxy, and call control.

• Media flows between the Cisco Expressway-E and the Cisco Expressway-C through a traversal zone.

In a production environment, Cisco Jabber Guest requires that your Cisco Unified Communications Manager
be configured to work with Cisco Expressway.

If Cisco Expressway-E is used for reverse proxy functionality, the Cisco Jabber Guest URL looks like
https://expressway-e.example.com/call where expressway-e.example.com is the FQDN of
Cisco Expressway-E.

Note

Call Control Flow
The following are examples of call control flow for the two supported deployments of Cisco Jabber Guest
Server.

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
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Figure 1: Cisco Jabber Guest Call Control: Cisco Expressway-E with Single NIC Deployment

Figure 2: Cisco Jabber Guest Call Control: Cisco Expressway-E with Dual NIC Deployment

Cisco Expressway-E with Dual NIC Deployment

SIP flows between the Cisco Jabber Guest server and the Cisco Expressway-E. This requires bi-directional
TCP traffic between the two servers over 5060 (SIP over TCP) or 5061 (SIP over TLS). The SIP traffic then
goes over the traversal zone to the Cisco Expressway-C.

We recommend that you disable SIP and H.323 application-level gateways on routers/firewalls carrying
network traffic to or from a Cisco Expressway-E.

Because media hairpins between the two Cisco Expressway-E NICs, the TURN traffic and SIP traffic must
reside on the same Cisco Expressway-E server. You must configure the static NAT address, DMZ external
address, and DMZ internal address of the Cisco Expressway-E on the Cisco Jabber Guest server.

Important
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Media Flow
The web client uses TURN relays allocated on the Cisco Expressway-E to tunnel media into the enterprise.
Media is sent and received in STUN encapsulated packets to the TURN server through UDP port 3478.

TURN relay credentials are acquired and used as follows:

• The Cisco Jabber Guest client allocates a call resource through HTTP to the Cisco Jabber Guest server.

• The Cisco Jabber Guest server requests short-term TURN credentials from the Cisco Expressway-C
through a secure HTTP request. Administrator credentials are used for authentication. The configured
domain must be on the Cisco Expressway-C with Jabber Guest service enabled.

• The Cisco Expressway-C creates the TURN credential and passes it to the Cisco Jabber Guest server.

• The Cisco Expressway-C propagates the TURN credential to the Cisco Expressway-E through the SSH
tunnel (port 2222).

• The Cisco Jabber Guest server responds to the Cisco Jabber Guest client with the TURN credential and
TURN server (Cisco Expressway-E) address (DNS or IP).

• The Cisco Jabber Guestclient uses the TURN credential to allocate the TURN relay on the TURN server.

Media Flow: Cisco Expressway-E with Single NIC Deployment
The following diagram is an example of the media flow for a Cisco Expressway-E with single NIC deployment
of Cisco Jabber Guest.
Figure 3: Cisco Jabber Guest Media Flow: Cisco Expressway-E with Single NIC Deployment

Cisco Jabber Guest media does not go through the traversal link between Cisco Expressway-E and Cisco
Expressway-C.
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If the Cisco Expressway-E is behind a NAT, additional configuration is required on the Cisco Jabber Guest
server to avoid the media flowing to the static NAT address. Turn on Static NAT mode and configure the
static NAT address and DMZ external address of the Cisco Expressway-E on the Cisco Jabber Guest server.
This allows media to be sent to the DMZ external address of the Cisco Expressway-E, avoiding NAT reflection
on the outside firewall.

Important

Media Flow: Cisco Expressway-E with Dual NIC Deployment
The following diagram is an example of the media flow for a Cisco Expressway-E with dual NIC deployment
of Cisco Jabber Guest.
Figure 4: Cisco Jabber Guest Media Flow: Cisco Expressway-E with Dual NIC Deployment

Media flows through the traversal zone between the Cisco Expressway-C and the internal NIC of the Cisco
Expressway-E. It hairpins on the Cisco Expressway-E to the external NIC of the Cisco Expressway-E, and
then is STUN/TURN wrapped before being sent to the client browser.

If the Cisco Expressway-E is behind a NAT, additional configuration is required on the Cisco Jabber Guest
server to avoid the media flowing to the static NAT address. Turn on Static NAT mode and configure the
static NAT address, DMZ external address, and DMZ internal address of the Cisco Expressway-E on the
Cisco Jabber Guest server. This allowsmedia to be sent to the DMZ external address of the Cisco Expressway-E,
avoiding NAT reflection on the outside firewall.

Important
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Ports and Protocols

• HTTP and HTTPS traffic from Cisco Jabber Guest clients in the Internet is sent to ports 80 and 443 TCP
respectively. Therefore the firewall between the Cisco Expressway-E and the public Internet must translate
destination port 80 to 9980 and destination port 443 to 9443 for all TCP traffic that targets the Cisco
Expressway-E address.

• The Cisco Expressway-E redirects HTTP requests on port 9980 to HTTPS on 9443.

• 80/443 TCP are the standard HTTP/S administration interfaces on the Expressway. If the Cisco
Expressway-E is administered from systems located in the Internet, then the firewall translation must
also distinguish by source address and must not translate the destination port of traffic arriving from
those management systems.

• You also need to ensure that appropriate DNS records exist so that the Cisco Jabber Guest client can
reach the Cisco Expressway-E. The FQDN of the Cisco Expressway-E in DNS must include the Cisco
Jabber Guest domain. The Cisco Jabber Guest domain is the domain that is configured on the Cisco
Expressway-C.

• For more information on port usage for Firewall Traversal, refer to the Cisco Expressway IP Port Usage
for Firewall Traversal Guide.

Important

Ports and Protocols: Cisco Expressway-E with Single NIC Deployment
Table 6: Inbound from Public Internet to Cisco Expressway-E (DMZ)

Cisco Expressway-E
(Listening)

Internet Endpoint (Source)ProtocolPurpose

9980 (read the following
Important note)

TCP source portTCPHTTP

9443 (read the following
Important note)

TCP source portTLSHTTPS proxy

34783

3478–3483
4

UDP source portUDPTURN Server (control
and media relays)

3 For small and medium Cisco Expressway-E deployments
4 For large Cisco Expressway-E deployments
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• The Cisco Expressway-E administrator currently uses port 80 and therefore, incoming requests from the
Cisco Jabber Guest client to Cisco Expressway-E on port 80 must be remapped to port 9980 using a
firewall (or similar) in front of Cisco Expressway-E. For the mobile client, using 9980 in call links is
not supported; you must use port remapping on your firewall to remap port 80 to port 9980.

• The Cisco Expressway-E administrator currently uses port 443 and therefore, incoming requests from
the Cisco Jabber Guest client to Cisco Expressway-E on port 443 must be remapped to port 9443 using
a firewall (or similar) in front of Cisco Expressway-E. For the mobile client, using 9443 in call links is
not supported; you must use port remapping on your firewall to remap port 443 to port 9443.

Important

Set Domain Used for Links, on page 47

Table 7: Outbound from Cisco Expressway-C (Private) to Cisco Expressway-E (DMZ)

Cisco Expressway-E
(Destination)

Cisco Expressway-C
(Source)

ProtocolPurpose

2222 (not configurable)Ephemeral portTCPSSH (HTTP/S tunnels)

700125000–29999TLSTraversal zone SIP
signaling

24000–2999936000–59999UDPMedia5

5 By default, media is sent to the NAT interface unless the Cisco Jabber Guest server is configured for
static NAT mode.

Table 8: Inbound from Cisco Expressway-E (DMZ) to Cisco Expressway-C (Private)

Cisco Expressway-C
(Destination)

Cisco Expressway-E
(Source)

ProtocolPurpose

36000–5999924000–29999UDPMedia

• Inbound firewall rules are required to allow media to flow from the Cisco Expressway-E to Cisco
Expressway-C.

• You may find that two-way media can still be established even if the inbound from Cisco Expressway-E
(DMZ) to Cisco Expressway-C (private) firewall rules are not applied. This is because the outbound
media creates a pinhole in the firewall; however, these rules are required to support uni-directional media
(that is, only from outside to inside).

Important

Table 9: From Cisco Expressway-C to Cisco Jabber Guest

Cisco Jabber Guest
(Destination)

Cisco Expressway-C
(Source)

ProtocolPurpose

80Ephemeral portTCPHTTP
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Cisco Jabber Guest
(Destination)

Cisco Expressway-C
(Source)

ProtocolPurpose

443Ephemeral portTLSHTTPS

5060 (SIP over TCP)

5061 (SIP over TLS)

Ephemeral portTCP/TLSSIP

Table 10: From Cisco Jabber Guest to Cisco Expressway-C

Cisco Expressway-C
(Destination)

Cisco Jabber Guest
(Source)

ProtocolPurpose

443Ephemeral portTLSHTTPS

5060 (SIP over TCP)

5061 (SIP over TLS)

Ephemeral portTCP/TLSSIP

Ports and Protocols: Cisco Expressway-E with Dual NIC Deployment
Table 11: Inbound from Public Internet to Cisco Expressway-E (DMZ)

Cisco Expressway-E (Listening)Internet Endpoint (Source)ProtocolPurpose

9980 (read the following
Important note)

TCP source portTCPHTTP

9443 (read the following
Important note)

TCP source portTLSHTTPS proxy

34786

3478–3483 7

UDP source portUDPTURN Server (control and
media relays)

6 For small and medium Cisco Expressway-E deployments
7 For large Cisco Expressway-E deployments

• The Cisco Expressway-E administrator currently uses port 80 and therefore, incoming requests from the
Cisco Jabber Guest client to Cisco Expressway-E on port 80 must be remapped to port 9980 using a
firewall (or similar) in front of Cisco Expressway-E. For the mobile client, using 9980 in call links is
not supported; you must use port remapping on your firewall to remap port 80 to port 9980.

• The Cisco Expressway-E administrator currently uses port 443 and therefore, incoming requests from
the Cisco Jabber Guest client to Cisco Expressway-E on port 443 must be remapped to port 9443 using
a firewall (or similar) in front of Cisco Expressway-E. For the mobile client, using 9443 in call links is
not supported; you must use port remapping on your firewall to remap port 443 to port 9443.

Important

Set Domain Used for Links, on page 47
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Table 12: Outbound from Cisco Expressway-C (Private) to Cisco Expressway-E (DMZ)

Cisco Expressway-E
(Destination)

Cisco Expressway-C (Source)ProtocolPurpose

2222 (not configurable)Ephemeral portTCPSSH (HTTP/S tunnels)

700125000–29999TLSTraversal zone SIP signaling

36000–360018

36000–360119
36002–59999UDPMedia

If the internal >
DMZ firewall rules
allow outgoing
traffic, no rules are
needed for media.

Note

8 For small and medium Cisco Expressway-E deployments
9 For large Cisco Expressway-E deployments

Table 13: Outbound from Cisco Jabber Guest (Private) to Cisco Expressway-E (DMZ)

Cisco Expressway-E
(Destination)

Cisco Jabber Guest (Source)ProtocolPurpose

5060 (SIP over TCP)

5061 (SIP over TLS)

Ephemeral portTCP/TLSSIP

Table 14: Inbound from Cisco Expressway-E (DMZ) to Cisco Jabber Guest (Private)

Cisco Jabber Guest
(Destination)

Cisco Expressway-E (Source)ProtocolPurpose

5060 (SIP over TCP)

5061 (SIP over TLS)

Ephemeral portTCP/TLSSIP

Table 15: From Cisco Expressway-C to Cisco Jabber Guest

Cisco Jabber Guest
(Destination)

Cisco Expressway-C (Source)ProtocolPurpose

80Ephemeral portTCPHTTP

443Ephemeral portTLSHTTPS
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Table 16: From Cisco Jabber Guest to Cisco Expressway-C

Cisco Expressway-C
(Destination)

Cisco Jabber Guest (Source)ProtocolPurpose

443Ephemeral portTLSHTTPS

Clustering Options
Cisco Jabber Guest only supports a three-server cluster. Three operational servers are required for full
redundancy.

Recommended Deployment

Configure the reverse proxy to send requests to only one server in the cluster at a time. You set the order in
which requests are sent on Cisco Expressway-C, from the Priority field in Configuration > Unified
Communications >Configuration >Configure Jabber Guest servers. Give each Cisco Jabber Guest server
a different priority. Requests are sent to a different server only if a server becomes unresponsive.

Cisco Jabber Guest can be administered from any server in the cluster. To simplify troubleshooting, we
recommend that you use one server in the cluster for administration purposes.

Data Replication

The following table describes which data replicates in a cluster.

Table 17: Cluster Data Replication

Data That Does Not ReplicateData That Replicates

Settings > Local SSL CertificateUsers

Settings > Call Control and Media (Local)Links

LogsServices > Passwords

Settings > Links

Settings > Mobile

Settings > Secure SIP Trust Certificate

Settings > Call Control and Media

Cluster Latency

The upper latency limit is 15 milliseconds.
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Load Balancing Methods Available
You can balance the load on your Cisco Expressway-C, Cisco Expressway-E, and Cisco Jabber Guest server
clusters.

The following table describes the methods of load balancing that are available to distribute different types of
traffic across the network.

Table 18: Load Balancing Methods

Method of Load Balancing AvailableNetwork Traffic

• Round-robin DNS

• Round-robin comma-separated values
(CSV)

• HTTP

Send SIP to the Cisco
Expressway-C server
cluster

SIP for call control

Send SIP to the Cisco Expressway-E server that
provided TURN service

For a clustered Cisco Expressway-E
with dual NIC deployment. youmust
send SIP to the Cisco Expressway-E
server that provided TURN service.

Important

Send SIP to the Cisco
Expressway-E server
cluster

• Round-robin DNS

• Round-robin CSV

• HTTP

TURN credential provisioning requests to the Cisco
Expressway-C server cluster

Round-robin DNSHTTPS from the Cisco Jabber Guest client to the Cisco
Expressway-E server cluster

• Round-robin DNS for the Cisco
Expressway-E server IP address and port
range for round-robin TURN port range

• Round-robin CSV for the Cisco
Expressway-E server IP address and port
range for round-robin TURN port range

TURN port ranges are only
supported when you use the large
Cisco Expressway-E virtual
machine.

Important

TURN for media between the Cisco Jabber Guest client and
the Cisco Expressway-E server cluster

Configure Cisco Jabber Guest server priorities
on the Cisco Expressway-C server.

HTTP between the Cisco Expressway-E and Cisco Jabber
Guest server clusters
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C H A P T E R 2
Install Cisco Jabber Guest Server

• Overview, on page 27
• Install Server, on page 27
• Sign In to Cisco Jabber Guest Administration, on page 29
• Install Certificate, on page 30
• Sign In to Cisco Jabber Guest Server CLI, on page 35
• Change Time Zone on Server, on page 36

Overview
Cisco Jabber Guest is deployed as a virtual server and requires a VMware server to act its host. The server
operating system is CentOS. Cisco Jabber Guest is an on-premises deployment: all services are set up, managed,
and maintained on your corporate network.

Cisco Jabber Guest is delivered as an OVA image and deployed manually.

For a summary of the Cisco Unified Communications Manager to Cisco Expressway configuration, see the
Cisco Unified Communications Manager/Cisco Expressway Configuration Checklist.

Install Server
Do one of the following:

• Install Server to vCenter Server, on page 27
• Install Server to ESXi, UC Virtualization Foundation, or UC Virtualization Hypervisor, on page 29

Install Server to vCenter Server

Procedure

Step 1 Download JabberGuest-11.x.x.x-New-Install.iso or access the file from the physical media
you receive.

Step 2 Extract the contents from the ISO file.
Step 3 Copy the .OVA to a location on your drive that is accessible to vSphere.
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Step 4 Open the vSphere Client.
Step 5 Choose File > Deploy OVF Template.
Step 6 In the Source screen, browse to location of the OVA package, and then click Next.

You can enter the URL if you know it.

Step 7 Verify the details in the OVF Template Details screen, and then click Next.
Step 8 In the Name and Location screen, enter a name for the virtual machine, select its location, and then click

Next.
Step 9 In the Host / Cluster screen, select the virtual machine deployment cluster, and then click Next.
Step 10 In the Storage screen, select the virtual machine storage usage, and then click Next.
Step 11 In theDisk Format screen, select a Virtual Machine Disk (VMDK) provisioning format, and then clickNext.
Step 12 In the Networking Mapping screen, select the appropriate Destination Networks for OVA deployment, and

then click Next.
Step 13 In the Properties screen, enter the network settings, and then click Next.

The virtual machine is set up with DHCP by default. Provide the following to configure the virtual machine
with a static IP address:

• IP address

• Network mask

• Hostname

• Gateway IP address

• At least one DNS server IP address

Do not add leading zeros to the IP addresses. The addresses won't resolve as intended.Important

Step 14 Click Finish.

What to do next

To turn on the virtual machine after it has been created, in the console window select Power On.

Configure the appropriate SIP trunk in Cisco Unified CommunicationsManager or zones in Cisco TelePresence
Video Communication Server depending on the type of server deployed in your network.

If the virtual machine cannot acquire the IP address of your VLAN, it shows a bootup failure related to network
eth0.

Note
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Install Server to ESXi, UC Virtualization Foundation, or UC Virtualization
Hypervisor

Procedure

Step 1 Download JabberGuest-11.x.x.x-New-Install.iso or access the file from the physical media
you receive.

Step 2 Extract the contents from the ISO file.
Step 3 Copy the .OVA to a location on your drive that is accessible to vSphere.
Step 4 Open the vSphere Client.
Step 5 Choose File > Deploy OVF Template.
Step 6 In the Source screen, browse to location of the OVA package, and then click Next.

You can enter the URL if you know it.

Step 7 Verify the details in the OVF Template Details screen, and then click Next.
Step 8 In the Name and Location screen, enter a name for the virtual machine, select its location, and then click

Next.
Step 9 In theDisk Format screen, select a Virtual Machine Disk (VMDK) provisioning format, and then clickNext.
Step 10 Click Finish.

What to do next

To turn on the virtual machine after it has been created, in the console window, select Power On.

The virtual machine is set up with DHCP by default. If you want to configure the virtual machine with a static
IP address, edit the following properties in network configuration file: IP address, network mask, hostname,
gateway IP address, and at least one DNS server IP address. ESXi 6.5 provides properties screen to set up
static IP address directly, and it might not work with the current release.

Note

Configure the appropriate SIP trunk in Cisco Unified CommunicationsManager or zones in Cisco TelePresence
Video Communication Server depending on the type of server deployed in your network.

If the virtual machine cannot acquire the IP address of your VLAN, it shows a boot up failure related to
network eth0.

Note

Sign In to Cisco Jabber Guest Administration
The Cisco Jabber Guest server is set up with default credentials.
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Before you begin

You can access Cisco Jabber Guest Administration on Windows with:

• Google Chrome 18 or later

• Microsoft Internet Explorer 8 or later (32-bit, or 64-bit running 32-bit tabs only)

• Mozilla Firefox 10 or later

You can access Cisco Jabber Guest Administration on Mac with:

• Safari 7 to 11

• Google Chrome 18 or later

• Mozilla Firefox 10 or later

Your session times out after 30 minutes of inactivity.

Procedure

Step 1 From a compatible browser, navigate to the IP address or host name of your Cisco Jabber Guest server and
append /admin/ to the URL.

Step 2 For Alias, enter admin.
Step 3 For Password, enter jabbercserver.

The first time that you sign in you must change your password.
Step 4 Enter a new password.

Install Certificate
When you install Cisco Jabber Guest, a self-signed certificate is installed by default. If you want, you can:

• Install a certificate that is signed by a third party (a trusted certificate authority).

• Install a certificate with additional distinguished name information.

• Install a certificate that includes the intermediate certificate or the entire certificate trust chain.

Cisco Jabber Guest supports installing DER encoded certificates and PEM encoded certificates.

The certificate signing request must be generated on the server on which you install the certificate. For this
reason, we recommend that you obtain a new CA-signed certificate for your new install of Cisco Jabber Guest
or use a self-signed certificate.

Important

If you choose to use the certificate that is installed by default, you must generate a new self-signed certificate
if the hostname of the server changes.
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Install Certificate Signed by a Certificate Authority
The following procedure creates a certificate signing request in which the DistinguishedName (DN) information
is composed of Common Name=<ip address> only. If your organization requires you to include additional
DN information in your request, follow the instructions in the procedure, Install Certificate with Additional
Distinguished Name Information.

If you have deployed a Cisco Jabber Guest cluster, you must install a certificate on each server in the cluster.

When you create the new certificate signing request, the current certificate becomes invalid.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Local SSL Certificate.
Step 3 Under Certificate Signing Request Options, click Create a New Certificate Signing Request.
Step 4 Click Download a certificate signing request.

A 4096-bit certificate signing request named csr.pem downloads.
Step 5 Send the certificate signing request to a trusted certificate authority.
Step 6 After you receive the signed certificate from the certificate authority:

a) Click Choose File.
b) Open the signed certificate.
c) Click Install a Certificate Authority Signed Certificate.
Under Certificate Status, the following message appears:

This system has a certificate authority signed certificate

Step 7 Restart the virtual machine:
a) Open vSphere Client.
b) In the virtual machines and templates inventory tree, right-click the virtual machine.
c) Choose Power > Restart Guest.

Install Certificate with Additional Distinguished Name Information
If you use Cisco Jabber Guest Administration to create a certificate signing request, the Distinguished Name
(DN) information in the request is composed only of Common Name=<ip address>. If your organization
requires you to include additional DN information, such as organization name and locality name, use the
following procedure.

If you have deployed a Cisco Jabber Guest cluster, you must install a certificate on each server in the cluster.

When you create the new certificate signing request, the current certificate becomes invalid.

Procedure

Step 1 Sign in to the server as root.
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Step 2 Change directory to /opt/cisco/webcommon/scripts:
/opt/cisco/webcommon/scripts

Step 3 Execute the createcsr script:
./createcsr.sh

Step 4 Follow the instructions on the screen to enter additional DN information, including country name, state or
province name, locality name, organization name, organizational unit name, and common name.
After you enter the information, the csr file is saved in a location from which you download it in Step 7.

Step 5 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 6 Click Settings, and then click Local SSL Certificate.
Step 7 Under Certificate Signing Request Options, click Download a certificate signing request.

A 4096-bit certificate signing request named csr.pem downloads.
Step 8 Send the certificate signing request to a trusted certificate authority.
Step 9 After you receive the signed certificate from the certificate authority:

a) Click Choose File.
b) Open the signed certificate.
c) Click Install a Certificate Authority Signed Certificate.
Under Certificate Status, the following message appears:

This system has a certificate authority signed certificate

Step 10 Restart the virtual machine:
a) Open vSphere Client.
b) In the virtual machines and templates inventory tree, right-click the virtual machine.
c) Choose Power > Restart Guest.

Install Certificate That Includes the Intermediate Certificate or the Entire
Certificate Trust Chain

You can upload a combined certificate file that includes the Cisco Jabber Guest server certificate and your
intermediate certificate or that includes the Cisco Jabber Guest server certificate, your intermediate certificate,
and your root certificate.

If you have deployed a Cisco Jabber Guest cluster, you must install a certificate on each server in the cluster.

When you create the new certificate signing request, the current certificate becomes invalid.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Local SSL Certificate.
Step 3 Under Certificate Signing Request Options, click Create a New Certificate Signing Request.
Step 4 Click Download a certificate signing request.

A 4096-bit certificate signing request named csr.pem downloads.
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Step 5 Send the certificate signing request to a trusted certificate authority.
Step 6 After you receive the signed certificate from the certificate authority, open it in a text editor, such as Notepad.
Step 7 Download your intermediate certificate.
Step 8 In the Cisco Jabber Guest certificate, after -----END CERTIFICATE-----, paste the entire body of your

intermediate certificate.

Make sure that you include the beginning and end tags of both certificates. The result should look
like this:
----BEGIN CERTIFICATE-----
(Cisco Jabber Guest certificate)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your intermediate certificate)
-----END CERTIFICATE-----

Note

Step 9 (Optional) If you want to include the root certificate in the combined certificate file:
a) Download your root certificate.
b) In the Cisco Jabber Guest certificate, after -----END CERTIFICATE----- for the intermediate file, paste

the entire body of your root certificate.

Make sure that you include the beginning and end tags of all three certificates. The result should
look like this:
----BEGIN CERTIFICATE-----
(Cisco Jabber Guest certificate)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your intermediate certificate)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your root certificate)
-----END CERTIFICATE-----

Note

Step 10 Make sure that there is no additional formatting in the file.
Step 11 Save the combined certificate file.
Step 12 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 13 Click Settings, and then click Local SSL Certificate.
Step 14 Click Choose File, open the combined certificate file, and click Install a Certificate Authority Signed

Certificate.
Under Certificate Status, the following message appears:

This system has a certificate authority signed certificate

Step 15 Restart the virtual machine:
a) Open vSphere Client.
b) In the virtual machines and templates inventory tree, right-click the virtual machine.
c) Choose Power > Restart Guest.
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Edit the Certificate Trust Chain
If you make a mistake adding the certificate trust chain, use the following procedure to replace the existing
certificate.

Procedure

Step 1 Sign in to Cisco Jabber Guest Server command-line interface.
Step 2 Change directory to /etc/opt/cisco/webcommon/security/ssl:

/etc/opt/cisco/webcommon/security/ssl

Step 3 Create an empty file named server.csr:
touch server.csr

Step 4 Change directory to /etc/opt/cisco/webcommon/.security/ssl:
/etc/opt/cisco/webcommon/.security/ssl

Step 5 Copy server.pem and rename new_server.pem:
cp server.pem new_server.pem

Step 6 In the Cisco Jabber Guest certificate, after -----END CERTIFICATE-----, paste the entire body of your
intermediate certificate.

Make sure that you include the beginning and end tags of both certificates. The result should look
like this:
----BEGIN CERTIFICATE-----
(Cisco Jabber Guest certificate)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your intermediate certificate)
-----END CERTIFICATE-----

Note

Step 7 (Optional) If you want to include the root certificate in the combined certificate file:
a) Download your root certificate.
b) In the Cisco Jabber Guest certificate, after -----END CERTIFICATE----- for the intermediate file, paste

the entire body of your root certificate.

Make sure that you include the beginning and end tags of all three certificates. The result should
look like this:
----BEGIN CERTIFICATE-----
(Cisco Jabber Guest certificate)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your intermediate certificate)
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
(Your root certificate)
-----END CERTIFICATE-----

Note

Step 8 Make sure that there is no additional formatting in the file.
Step 9 Save the combined certificate file.
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Step 10 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 11 Click Settings, and then click Local SSL Certificate.
Step 12 Click Choose File, open the combined certificate file, and click Install a Certificate Authority Signed

Certificate.
Under Certificate Status, the following message appears:

This system has a certificate authority signed certificate

Step 13 Restart the virtual machine:
a) Open vSphere Client.
b) In the virtual machines and templates inventory tree, right-click the virtual machine.
c) Choose Power > Restart Guest.

Generate New Self-Signed Certificate
If you are using the self-signed certificate that is installed by default and the hostname of the server changes,
you must generate a new self-signed certificate.

When you generate a new self-signed certificate, the current certificate becomes invalid.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Local SSL Certificate.
Step 3 Click Generate a New Self-Signed Certificate.

The message Update successful appears.
Step 4 Restart the virtual machine:

a) Open vSphere Client.
b) In the virtual machines and templates inventory tree, right-click the virtual machine.
c) Choose Power > Restart Guest.

Sign In to Cisco Jabber Guest Server CLI
The Cisco Jabber Guest server command-line interface (CLI) is set up with default credentials.

Procedure

Step 1 For the user ID, enter root.
Step 2 For the password enter jabbercserver. The first time that you sign in, you must change the password.
Step 3 Enter a new password.

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
35

Install Cisco Jabber Guest Server
Generate New Self-Signed Certificate



Change Time Zone on Server
By default, the server time zone is set to Coordinated Universal Time (UTC). To change the time zone, use
the following procedure.

The time zone change takes effect immediately.

Procedure

Step 1 Sign in to the server as root.
Step 2 Check the current time zone by executing the command: date.

The date and time appear in the format: ddd mmm dd hh:mm:ss UTC yyyy. For example: Fri Dec
20 16:57:18 UTC 2013.

Step 3 Change directory to /opt/cisco/webcommon/scripts:
cd /opt/cisco/webcommon/scripts

Step 4 Execute the timezone script:
./timezone

Step 5 Follow the on-screen instructions.
Step 6 At the confirmation message, type 1 for Yes.
Step 7 Verify that the server is set to your time zone by executing the command: date.
Step 8 Restart Tomcat:

service tomcat-as-standalone.sh restart
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C H A P T E R 3
Perform Initial Setup

• Configure Cisco Expressway-E and Cisco Expressway-C, on page 37
• Change MTU Size, on page 42
• Configure Signaling and Media, on page 42
• Configure Static NAT Mode on Cisco Expressway-E, on page 45
• Configure TURN Credential Provisioning, on page 46
• Set Up TURN Server Information, on page 46
• Set FQDN of Cisco Jabber Guest Server, on page 47
• Set Domain Used for Links, on page 47
• Customize Cisco Jabber Guest Clients, on page 48

Configure Cisco Expressway-E and Cisco Expressway-C
Do one of the following:

• Configure Cisco Expressway-E and Cisco Expressway-C: Cisco Expressway-E with Single NIC
Deployment, on page 37

• Configure Cisco Expressway-E and Cisco Expressway-C: Cisco Expressway-E with Dual NIC
Deployment, on page 40

Configure Cisco Expressway-E and Cisco Expressway-C: Cisco Expressway-E
with Single NIC Deployment

Cisco Expressway-E and Cisco Expressway-C provide the following functionality:

• Both provide reverse proxy for HTTPS traffic.

• Cisco Expressway-E provides TURN relays.

• Cisco Expressway-C routes calls to Cisco Unified Communications Manager through a SIP trunk.
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Before you begin

Follow the instructions in the Cisco Expressway documentation to set up Cisco Expressway security certificates
and a Unified Communications traversal zone. Configure the traversal zone type between the Cisco
Expressway-C and Cisco Expressway-E as Unified Communications traversal.

Procedure

Step 1 On the Cisco Expressway-E, enable Cisco Jabber Guest support:
a) Choose Configuration > Unified Communications > Configuration.
b) From the Unified Communications mode drop-down list, select Jabber Guest services.
c) Click Save.

Step 2 On the Cisco Expressway-E, enable TURN service:
a) Choose Configuration > Traversal > TURN.
b) From the TURN services drop-down list, select On.
c) Click Save.

Step 3 On the Cisco Expressway-C, enable Cisco Jabber Guest support:
a) Choose Configuration > Unified Communications > Configuration.
b) From the Unified Communications mode drop-down list, select Jabber Guest services.
c) Click Save.

Step 4 On the Cisco Expressway-C, configure the domain for which HTTP traffic will be routed to the Cisco Jabber
Guest server:
This domain is the outward-facing domain that is used to route the call on the Internet when users click a link.
a) Choose Configuration > Domains.
b) Create a new domain if none exist or, in the row of the target domain, click View/Edit.
c) From the Jabber Guest drop-down list, select On.
d) Click Save.
e) Repeat Step 5.a. through Step 5.d. for each domain.

Step 5 Make sure that the domain has an associated DNS record that resolves to the Cisco Expressway-E. The domain
information is propagated from the Cisco Expressway-C to the Cisco Expressway-E through the SSH tunnel
(port 2222). It is used by the Cisco Expressway-E to validate incoming HTTP requests for the Cisco Jabber
Guest service.

Step 6 On the Cisco Expressway-C, associate the Cisco Jabber Guest servers with the domain:
This allows the Cisco Expressway-C to route HTTP requests with this domain to the appropriate Cisco Jabber
Guest server.
a) Choose Configuration > Unified Communications > Configuration.
b) In the Advanced section, click Configure Jabber Guest servers.
c) Click New.
d) For Server hostname, enter the FQDN of the Cisco Jabber Guest server.
e) For Priority, enter the priority of the Cisco Jabber Guest server. Lower numbers have higher priority.

Make sure that all Cisco Jabber Guest servers have a different priority so that calls are only sent to one
Cisco Jabber Guest server in the deployment at a time.

f) From the Domain drop-down list, select the Cisco Jabber Guest HTTP domain.
g) Click Create entry.
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h) Repeat Step 6.c. through Step 6.g. for each Cisco Jabber Guest server in the cluster.

Step 7 Verify that the SSH tunnel is active:
a) On either the Cisco Expressway-C or the Cisco Expressway-E, choose Status >UnifiedCommunications.
b) Click View ssh tunnel status.
c) Make sure that the Cisco Jabber Guest domain is listed and that the SSH tunnel is active.

Step 8 On the Cisco Expressway-C, create a neighbor zone for each Cisco Jabber Guest server:
a) Choose Configuration > Zones > Zones.
b) Click New.
c) Enter the details. From the Type drop-down list, select Neighbor.
d) In the H.323 section, from theMode drop-down list, select Off
e) In the SIP section, from theMode drop-down list, select On.
f) For Port, enter 5061.
g) From the Transport drop-down list, select TLS.

To enable TLS, you must also upload the Cisco Expressway-C certificate to Cisco Jabber Guest
Administration. For more information, see Configure Signaling andMedia: Cisco Expressway-E
with Single NIC Deployment, on page 43.

Note

h) From theMedia encryption mode drop-down list, select Best effort.

Selecting Best effort forces media from the Cisco Expressway-E to terminate on the Cisco
Expressway-C.

Important

i) From the ICE support drop-down list, select Off.
j) In the Location section, for Peer 1 address, enter the IP address or FQDN of the Cisco Jabber Guest

server.
k) In the Advanced section, from the Zone profile drop-down list, select Default.
l) Click Create zone.
m) Repeat Step 7.b. through 7.l. for each Cisco Jabber Guest server in a Cisco Jabber Guest cluster.

Do not configure any search rules for these neighbor zones. These zones are used to receive traffic only.

Step 9 Set up a connection between the Cisco Expressway-C and Cisco Unified Communications Manager:
a) On Cisco Unified Communications Manager, set up a non-secure or secure SIP trunk and point it to the

Cisco Expressway-C.
b) On Cisco Expressway-C, set up a neighbor zone and point it to Cisco Unified Communications Manager.

Follow the steps in theCiscoUnified CommunicationsManager with Cisco Expressway (SIP Trunk) Deployment
Guide.

Step 10 Create a search rule on Cisco Expressway-C to route calls to Cisco Unified Communications Manager.
Step 11 Force the protocol between the Cisco Jabber Guest server and the Cisco Expressway-C to be http:

a) Sign in to the Cisco Expressway-C command-line interface as an administrator. In a clustered Cisco
Expressway-C deployment, sign in to the master Cisco Expressway-C.

b) Enter the following command:
xconf CollaborationEdge JabbercProxyProtocol: http

HTTP request goes from the Cisco Expressway-E to the Cisco Expressway-C to the Cisco Jabber Guest server.
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Configure Cisco Expressway-E and Cisco Expressway-C: Cisco Expressway-E
with Dual NIC Deployment

Cisco Expressway-E and Cisco Expressway-C provide the following functionality:

• Both provide reverse proxy for HTTPS traffic.

• Cisco Expressway-E provides TURN relays.

• Cisco Expressway-C routes calls to Cisco Unified Communications Manager through a SIP trunk.

Before you begin

Follow the instructions in the Cisco Expressway documentation to set up Cisco Expressway security certificates
and a Unified Communications traversal zone. Configure the traversal zone type between the Cisco
Expressway-C and Cisco Expressway-E as Unified Communications traversal.

Procedure

Step 1 On the Cisco Expressway-E, enable Cisco Jabber Guest support:
a) Choose Configuration > Unified Communications > Configuration.
b) From the Unified Communications mode drop-down list, select Jabber Guest services.
c) Click Save.

Step 2 On the Cisco Expressway-E, enable TURN service:
a) Choose Configuration > Traversal > TURN.
b) From the TURN services drop-down list, select On.
c) Click Save.

Step 3 On the Cisco Expressway-C, enable Cisco Jabber Guest support:
a) Choose Configuration > Unified Communications > Configuration.
b) From the Unified Communications mode drop-down list, select Jabber Guest services.
c) Click Save.

Step 4 On the Cisco Expressway-C, configure the domain for which HTTP traffic routes to the Cisco Jabber Guest
server:
This domain is the outward-facing domain that is used to route the call on the Internet when users click a link.
a) Choose Configuration > Domains.
b) Create a new domain if none exist or, in the row of the target domain, click View/Edit.
c) From the Jabber Guest drop-down list, select On.
d) Click Save.
e) Repeat Step 5.a. through Step 5.d. for each domain.

Step 5 Make sure that the domain has an associated DNS record that resolves to the Cisco Expressway-E. The domain
information is propagated from the Cisco Expressway-C to the Cisco Expressway-E through the SSH tunnel
(port 2222). The information is used by the Cisco Expressway-E to validate incoming HTTP requests for the
Cisco Jabber Guest service.

Step 6 On the Cisco Expressway-C, associate the Cisco Jabber Guest servers with the domain:
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This allows the Cisco Expressway-C to route HTTP requests with this domain to the appropriate Cisco Jabber
Guest server.
a) Choose Configuration > Unified Communications > Configuration.
b) In the Advanced section, click Configure Jabber Guest servers.
c) Click New.
d) For Server hostname, enter the FQDN of the Cisco Jabber Guest server.
e) For Priority, enter the priority of the Cisco Jabber Guest server. Lower numbers have higher priority.

Give each Cisco Jabber Guest server a different priority so that calls are only sent to one Cisco Jabber
Guest server in the deployment at a time.

f) From the Domain drop-down list, select the Cisco Jabber Guest HTTP domain.
g) Click Create entry.
h) Repeat Step 6.c. through Step 6.g. for each Cisco Jabber Guest server in the cluster.

Step 7 Verify that the SSH tunnel is active:
a) On either the Cisco Expressway-C or the Cisco Expressway-E, choose Status >UnifiedCommunications.
b) Click View ssh tunnel status.
c) Make sure that the Cisco Jabber Guest domain is listed and that the SSH tunnel is active.

Step 8 On the Cisco Expressway-E, create a neighbor zone for each Cisco Jabber Guest server so that you can verify
that the zone between the Cisco Expressway-E and the Cisco Jabber Guest server is active:
a) Choose Configuration > Zones > Zones.
b) Click New.
c) Enter the details. From the Type drop-down list, select Neighbor.
d) In the H.323 section, from theMode drop-down list, select Off
e) In the SIP section, from theMode drop-down list, select On.
f) For Port, enter 5061.
g) From the Transport drop-down list, select TLS.

To enable TLS, you must also upload the Cisco Expressway-E certificate to Cisco Jabber Guest
Administration. For more information, see Configure Signaling andMedia: Cisco Expressway-E
with Dual NIC Deployment, on page 44.

Note

h) From theMedia encryption mode drop-down list, select Best effort.
i) From the ICE support drop-down list, select Off.
j) In the Location section, for Peer 1 address, enter the IP address or FQDN of the Cisco Jabber Guest

server.
k) In the Advanced section, from the Zone profile drop-down list, select Default.
l) Click Create zone.
m) Repeat Step 7.b. through 7.l. for each Cisco Jabber Guest server in a Cisco Jabber Guest cluster.

Do not configure any search rules for these neighbor zones. These zones are used to receive traffic only.

Step 9 Create a search rule for the traversal zone between the Cisco Expressway-E and the Cisco Expressway-C
servers.

For proper call routing, the SIP domain that you specify (click Settings, click Call Control and
Media) and the domain that you optionally specify for Destination when you create a link (click
Links, clickNew) must be configured on the Cisco Expressway-E search rule to point to the traversal
zone.

Important
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Step 10 Set up a connection between the Cisco Expressway-C and Cisco Unified Communications Manager:
a) On Cisco Unified Communications Manager, set up a non-secure or secure SIP trunk and point it to the

Cisco Expressway-C.
b) On Cisco Expressway-C, set up a neighbor zone and point it to Cisco Unified Communications Manager.

Follow the steps in theCiscoUnified CommunicationsManager with Cisco Expressway (SIP Trunk) Deployment
Guide.

Step 11 Create a search rule on Cisco Expressway-C to route calls to Cisco Unified Communications Manager.
Step 12 Force the protocol between the Cisco Jabber Guest server and the Cisco Expressway-C to be http:

a) Sign in to the Cisco Expressway-C command-line interface as an administrator. In a clustered Cisco
Expressway-C deployment, you must sign in to the master Cisco Expressway-C.

b) Enter the following command:
xconf CollaborationEdge JabbercProxyProtocol: http

HTTP request goes from the Cisco Expressway-E to the Cisco Expressway-C to the Cisco Jabber Guest server.

Change MTU Size
In some call scenarios, such as when using VPN, the default Maximum Transmission Unit (MTU) on Cisco
Expressway-E is too high and can cause packet loss. The default MTU is 1500 bytes. We recommend that
you lower the MTU to 1400 bytes. If you do not, callers may experience problems, such as one-way video.

Procedure

Step 1 On Cisco Expressway-E, do one of the following:

• If you have Cisco Expressway-E X8.2, choose System > IP.
• If you have Cisco Expressway-E X8.5 or later, choose System > Network Interfaces > IP.

Step 2 In the LAN 1 section, for Maximum transmission unit (MTU), enter 1400.
Step 3 Click Save.

Configure Signaling and Media
Do one of the following:

• Configure Signaling and Media: Cisco Expressway-E with Single NIC Deployment, on page 43

• Configure Signaling and Media: Cisco Expressway-E with Dual NIC Deployment, on page 44
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Configure Signaling and Media: Cisco Expressway-E with Single NIC
Deployment

We recommend enabling Session Initiation Protocol (SIP) over Transport Layer Security (TLS) for call control
signaling and enabling Secure Real-Time Transfer Protocol (SRTP) for secure media. Secure media requires
secure signaling.

Before you begin

On Cisco Expressway-C, make sure that you have created a neighbor zone for each Cisco Jabber Guest server.
For more information, see Configure Cisco Expressway-E and Cisco Expressway-C: Cisco Expressway-E
with Single NIC Deployment, on page 37.

Procedure

Step 1 To enable SIP over TLS, obtain the Cisco Expressway-C server certificate or the Cisco Expressway-C certificate
authority certificate:

• If you have a single Cisco Expressway-C, obtain the Cisco Expressway-C server certificate.
• If Cisco Expressway-C is a cluster of servers, obtain the Cisco Expressway-C certificate authority
certificate. This certificate must be uploaded to the Cisco Jabber Guest server so that Cisco Jabber Guest
can communicate with all nodes in the Cisco Expressway-C cluster.

Step 2 Upload the certificate to Cisco Jabber Guest Administration:
a) Sign in to Cisco Jabber Guest Administration as an administrator.
b) Click Settings, and then click Secure SIP Trust Certificate.
c) Under Secure SIP Trust Certificate, click Choose File.
d) Select the certificate that you obtained, and then click Upload.

Step 3 Configure the Call Control and Media settings in Cisco Jabber Guest Administration:
a) Click Call Control and Media.
b) Select Route calls using Cisco Expressway.
c) Check Enable SIP over TLS.
d) Check Enable SRTP.
e) For SIP port, enter 5061.
f) For SIP domain, enter the SIP domain. This setting is used if the Cisco Jabber Guest link does not contain

a SIP domain. In most cases, this is the enterprise SIP domain as configured in Cisco Unified
Communications Manager.

g) For SIP server, enter the IP address or FQDN of the Cisco Expressway-C.
h) Specify whether SIP is sent to the Cisco Expressway-C that originated the HTTP call control or to the

server entered above.

Step 4 Click Update.
The message Update successful appears.

Step 5 Restart Tomcat:
service tomcat-as-standalone.sh restart

Step 6 On the Cisco Expressway-C, verify that the neighbor zones for each Cisco Jabber Guest server are active:
a) Choose Configuration > Zones > Zones.
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b) View the SIP status column.

ConfigureSignalingandMedia:CiscoExpressway-EwithDualNICDeployment
We recommend enabling Session Initiation Protocol (SIP) over Transport Layer Security (TLS) for call control
signaling and enabling Secure Real-Time Transfer Protocol (SRTP) for secure media. Secure media requires
secure signaling.

Before you begin

On Cisco Expressway-E, make sure that you have created a neighbor zone for each Cisco Jabber Guest server.
For more information, see Configure Cisco Expressway-E and Cisco Expressway-C: Cisco Expressway-E
with Dual NIC Deployment, on page 40.

Procedure

Step 1 To enable SIP over TLS, obtain the Cisco Expressway-E server certificate or the Cisco Expressway-E certificate
authority certificate:

• If you have a single Cisco Expressway-E, obtain the Cisco Expressway-E server certificate.
• If Cisco Expressway-E is a cluster of servers, obtain the Cisco Expressway-E certificate authority
certificate. This certificate must be uploaded to the Cisco Jabber Guest server so that Cisco Jabber Guest
can communicate with all nodes in the Cisco Expressway-E cluster.

Step 2 Upload the certificate to Cisco Jabber Guest Administration:
a) Sign in to Cisco Jabber Guest Administration as an administrator.
b) Click Settings, and then click Secure SIP Trust Certificate.
c) Under Secure SIP Trust Certificate, click Choose File.
d) Select the certificate that you obtained, and then click Upload.

Step 3 Configure the Call Control and Media settings in Cisco Jabber Guest Administration:
a) Click Call Control and Media.
b) Select Route calls using Cisco Expressway.
c) Check Enable SIP over TLS.
d) Check Enable SRTP.
e) For SIP port, enter 5061.
f) For SIP domain, enter the SIP domain. This setting is used if the Cisco Jabber Guest link does not contain

a SIP domain. In most cases, this is the enterprise SIP domain as configured in Cisco Unified
Communications Manager.

For proper call routing, the SIP domain must be configured on the Cisco Expressway-E search
rule to point to the traversal zone.

Important

g) For a single Cisco Expressway-E server, for SIP server, enter the IP address or FQDN of Cisco
Expressway-E's internal NIC.

h) Select where to send SIP traffic:

• For a single Cisco Expressway-E server, select SIP server specified above.
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• For cluster of Cisco Expressway-E servers:

1. Select Expressway-E server that provided TURN service.

The TURN relay and SIP signaling must reside on the same server.Important

2. Under Cisco Expressway-ENetworkAddressMap, enter the external IP addresses and internal
IP addresses of each of the Cisco Expressway-E servers in the cluster. Mapping allows the Cisco
Jabber Guest server to send the SIP to the same Cisco Expressway-E servers as the TURN relay.

If static NAT mode is enabled on Cisco Expressway-E with either single NIC deployment or
dual NIC deployment, the Cisco Jabber Guest server must be configured for static NAT mode
as well.

Step 4 Click Update.
The message Update successful appears.

Step 5 Restart Tomcat:
service tomcat-as-standalone.sh restart

Step 6 On the Cisco Expressway-E, verify that the neighbor zones for each Cisco Jabber Guest server are active:
a) Choose Configuration > Zones > Zones.
b) View the SIP status column.

Configure Static NAT Mode on Cisco Expressway-E
If static NAT mode is enabled on Cisco Expressway-E with either single NIC deployment or dual NIC
deployment, the Cisco Jabber Guest server must be configured for static NAT mode as well. This allows the
media to flow within the DMZ, avoiding NAT reflection (sending media to the NATed address).

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration.
Step 2 Click Settings, and then click Call Control and Media.
Step 3 Under Cisco Expressway-E Network Address Map, check Static NAT mode.

This check box appears only when the option,Route calls using Cisco Expressway, is selected.

Step 4 Under Public IP (Static NAT), enter the static NAT IP address of the Cisco Expressway-E server.
Step 5 Under External IP (DMZ), enter the external IP address of the Cisco Expressway-E server.
Step 6 Repeat Steps 4 and 5 for each of the Cisco Expressway-E servers in the cluster.
Step 7 Click Update.
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Configure TURN Credential Provisioning
The Cisco Jabber Guest client needs TURN credentials to allocate TURN relays on the Cisco Expressway-E.
The Cisco Jabber Guest server provisions these credentials on the Cisco Expressway-Cwhen the Cisco Jabber
Guest client connects.

The Cisco Jabber Guest server uses an HTTP-based XML API to communicate with Cisco Expressway-C.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Call Control and Media.
Step 3 Under Cisco Expressway-C, for Expressway-C (IP address or DNS name), enter the Cisco Expressway-C

IP address or DNS name.
Step 4 Specify whether short-term TURN credentials are requested from the Cisco Expressway-C that proxied the

HTTP request from the Cisco Jabber Guest client or from the server entered in Step 3.
Step 5 For HTTPS port, specify the port.
Step 6 For Domain, enter the domain on Cisco Expressway-C that has Jabber Guest services enabled.
Step 7 For Username and Password, enter the username and password of the administrator account on Cisco

Expressway-C that has read, write, and API access.
Step 8 Click Update.

Set Up TURN Server Information
The Cisco Jabber Guest client needs to know which Cisco Expressway-E to use for TURN relays.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Call Control and Media.
Step 3 Under Cisco Expressway-E, for Expressway-E TURN server (IP address or DNS name), enter the Cisco

Expressway-E TURN server outside IP address or DNS name.

If you have a cluster of Cisco Expressway-E servers, see Configure Round-Robin DNS Load Balancing or
Configure Round-Robin CSV Loading Balancing.

Step 4 For TURN port, enter the UDP port. The port is typically 3478 but you can enter a range of ports, such as
3478-3483. The range is necessary if the Cisco Expressway-E supports multiple TURN ports.

The port must match the port specified on the Cisco Expressway-E (under Configuration >
Traversal > TURN).

Important
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Step 5 Click Update.

Set FQDN of Cisco Jabber Guest Server
Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Call Control and Media (Local).
Step 3 Enter the FQDN of the Cisco Jabber Guest server.

The FQDN must match the value specified in the Cisco Jabber Guest Server hostname field on
the Cisco Expressway-C. Cisco Expressway-C uses the FQDN to forward the per-session HTTP
traffic to the appropriate Cisco Jabber Guest server in the cluster.

Important

Step 4 Click Update.

What to do next

Make sure that you populate the Cisco Jabber Guest local FQDN field for each node in the Cisco Jabber
Guest cluster.

Set Domain Used for Links
To create links on the Cisco Jabber Guest server, you must enter the Cisco Jabber Guest domain that is
configured on the Cisco Expressway-C or the sub-domain of the Cisco Jabber Guest domain.

You also need to ensure that the appropriate DNS records exist so that the Cisco Jabber Guest client can reach
the Cisco Expressway-E.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Links.
Step 3 ForDomain used for links, enter the Cisco Jabber Guest domain that is configured on the Cisco Expressway-C.

You can add a sub-domain for the Cisco Jabber Guest service. Make sure that the domain used for links has
an associated DNS record that resolves to the public IP address of Cisco Expressway-E.

Example:

If yourcompany.com is configured as the Cisco Jabber Guest domain on Cisco Expressway-C and
jg.yourcompany.com is configured on the Cisco Jabber Guest server, the format of the link is
https://jg.yourcompany.com/call/<directory number>. And make sure there is a DNS
record to resolve jg.yourcompany.com to the public IP address of Cisco Expressway-E.
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Step 4 Click Update.

Related Topics
Set Redirect URL for Mobile Clients

Customize Cisco Jabber Guest Clients

Do not to modify any files on the Cisco Jabber Guest server. For example, on the web client, editing the
appearance of the Cisco Jabber Guest video window, such as the Call button, is not supported.

Important

To change the appearance of the web page that contains the Cisco Jabber Guest video window, host the page
on a server other than the Cisco Jabber Guest server.

The mobile client can be fully customized.

For more information about customizing Cisco Jabber Guest clients, go to the Cisco Jabber Guest SDKDevNet
website.

Customize Long Polling and Call Session Expires
Cisco Jabber Guest client sends HTTP long polling to Cisco Jabber Guest server to communicate events and
keep alive. We provide two advanced settings, Client long-polling and Call session expires, to control the
long polling time intervals:

The Client long-polling and Call session expires field configurations are supported only in Cisco Jabber
Guest 10.6(10) and its later releases.

Note

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration.
Step 2 Click Settings, and then click Advanced Settings.
Step 3 Enter a value in the Client long-polling (seconds) field.

The permitted range of values is 5 to 60 seconds.

The default value is 20 seconds.

Step 4 Enter a value in the Call session expires (seconds) field.

The permitted range of values is 5 to 60 seconds.

The default value is 60 seconds.
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Step 5 Click Update.
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C H A P T E R 4
Upgrade Cisco Jabber Guest Server

• Upgrade Cisco Jabber Guest Server, on page 51

Upgrade Cisco Jabber Guest Server
Cisco Jabber Guest Server is upgraded through vSphere on the Microsoft Windows platform. The upgrade is
delivered as an ISO file, and requires a CD or DVD drive that can be connected to the image.

Procedure

Step 1 Download JabberGuest-11.x.x.x-Upgrade-Only.iso.
Step 2 Open vSphere.
Step 3 Browse to the virtual machine to upgrade.
Step 4 Right-click the virtual machine and select Open console.
Step 5 Connect the CD/DVD drive to the ISO image:

a) From the console of the virtual machine, click on the CD/DVD button whose icon image is a disk with a
wrench.

b) Click the CD/DVD drive 1 menu item and then select the Connect to ISO image on local disk... menu
item.

c) In the Open window, browse to the ISO image downloaded in Step 1 and double-click it.

Step 6 Click inside the virtual machine console and sign in as root.
Step 7 Under the /mnt directory, create a new directory named cdrom to use as the mount location for the CD/DVD

drive.
mkdir /mnt/cdrom

Step 8 Mount the CD/DVD drive to /mnt/cdrom:
mount /dev/cdrom /mnt/cdrom

Step 9 Change directory to /mnt/cdrom:
cd /mnt/cdrom

Step 10 Execute the upgrade script:
bash upgrade
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Step 11 To ensure that the latest version of Cisco Jabber Guest Administration is loaded in your browser, refresh any
browser instances that are signed in to Cisco Jabber Guest Administration or that have the Cisco Jabber Guest
Administration sign-in page loaded.
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C H A P T E R 5
Configure High Availability and Scalability

• Cluster, on page 53
• Configure Load Balancing, on page 59

Cluster

Create Cluster
In this procedure, we refer to the primary server as primary and to the two secondary servers as node A and
node B.

Before you begin

When a secondary server joins a cluster, all of the data on the secondary server is discarded. If you need to
retain the data for future use, back up the secondary server before joining it to the cluster.

Procedure

Step 1 Deploy the .OVA to all three servers.
Step 2 For all three Cisco Jabber Guest servers, make sure that you set the FQDN. For more information, see Set

FQDN of Cisco Jabber Guest Server, on page 47.
Step 3 Sign in to each server as root.
Step 4 To establish the primary, on one of the three servers:

a) Type cluster initiate, and follow the on-screen prompts.
It takes a minute or two for the database to stabilize in its new configuration.

b) Verify that the database has stabilized by typing cluster status.
When the database has stabilized, the status shows: ---> <IP address/hostname of primary> PRIMARY.
The symbol ---> indicates the current server.

c) Restart Tomcat: service tomcat-as-standalone.sh restart.

Step 5 To join node A to the cluster, on one of the remaining servers:
a) Type cluster join <IP address/hostname of primary>, and follow the on-screen prompts.

It takes a minute or two for the database to stabilize in its new configuration.
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b) Verify that the database has stabilized by typing cluster status.
When the database has stabilized, the status shows: ---> <IP address/hostname of node A> SECONDARY.

c) Restart Tomcat: service tomcat-as-standalone.sh restart.

Step 6 To join node B to the cluster, on the remaining server:
a) Type cluster join <IP address/hostname of primary>, and follow the on-screen prompts.

It takes a minute or two for the database to stabilize in its new configuration.
b) Verify that the database has stabilized by typing cluster status.

When the database has stabilized, the status shows as: ---> <IP address/hostname of node B>

SECONDARY.
c) Restart Tomcat: service tomcat-as-standalone.sh restart.

Step 7 Allow node A to communicate with node B:
a) Type cluster allow <IP address/hostname of node B>.
b) Verify that communication is allowed by typing cluster status.

When communication is allowed, the status of node B changes from ---> <IP address/hostname of

node B> not reachable/healthy to ---> <IP address/hostname of node B> SECONDARY.

Step 8 Allow node B to communicate with node A:
a) Type cluster allow <IP address/hostname of node A>.
b) Verify that communication is allowed by typing cluster status.

When communication is allowed, the status of node A changes from ---> <IP address/hostname of

node A> not reachable/healthy to ---> <IP address/hostname of node A> SECONDARY.

What to do next

For each of the three servers in the cluster, configure the appropriate SIP trunk in CiscoUnified Communications
Manager or zones in Cisco TelePresence Video Communication Server, depending on the type of servers
deployed in your network.

Change IP Address or Hostname of Server in Cluster
You can modify the IP address or hostname of a server in the cluster if it changes for any reason.

In this procedure, we refer to the server that we change the IP address or hostname of as the target server.

Procedure

Step 1 Make a note of the current IP address or hostname of the target server. You need to enter it during Step 4.b.
Step 2 (Optional) If you are changing the IP address or hostname of the primary server, demote the primary server

to a secondary server, otherwise proceed to Step 3:
a) On the primary server, type cluster stepdown.
b) Verify that the target server has been demoted from the primary server to a secondary server by typing

cluster status.
c) Make a note of which server is now the primary server.

Step 3 Change the IP address or hostname of the target server.
Step 4 In the cluster, change the IP address or hostname of the target server:
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a) Sign in to the primary server as root.
b) Type cluster move <old IP address/hostname of target server> <new IP address/hostname

of target server>.
c) Verify that the IP address or hostname of the target server has changed by typing cluster status.

Step 5 On the other secondary server (node B), block communication from the old IP address or hostname of the
target server and allow communication with the new IP address or hostname of the target server:
a) Sign in to node B as root.
b) On node B, block communication from the old IP address or hostname of the target server by typing

cluster disallow <old IP address/hostname of target server>.
c) On node B, allow communication with the new IP address or hostname of the target server by typing

cluster allow <new IP/hostname of target server>.

Step 6 Make sure that each server in the cluster is healthy by typing: cluster status.
Step 7 On the target server, restart Tomcat:

service tomcat-as-standalone.sh restart

Step 8 If you changed the IP address or hostname of the primary server, in Cisco Jabber Guest Administration, update
the domain used for links:
a) Sign in to Cisco Jabber Guest Administration as an administrator.
b) Click Settings, and then click Links.
c) For Domain used for Links, enter the IP address or hostname of the new primary server.
d) Click Update.

What to do next

If you are using a self-signed certificate, you must generate a new certificate after you change the IP address
or hostname of the server.

Demote Primary Server to Secondary Server
You can demote or stepdown a primary server to a secondary server. For example, if you need to domaintenance
on the primary server.

A new primary server is elected from the remaining servers in the cluster.

Procedure

Step 1 Sign in to the primary server as root.
Step 2 Type cluster stepdown.
Step 3 Verify that the server has been demoted to secondary by typing cluster status.
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Upgrade Cluster
In this procedure, we refer to the primary server as node A and to the two secondary servers as node B and
node C.

Procedure

Step 1 Make a note of which nodes are the primary and secondary servers:
a) Sign in to one of the Cisco Jabber Guest servers as root.
b) Type cluster status.

Step 2 Make sure that you have backed up each server in the cluster.
Step 3 Download JabberGuest-11.x.x.x-Upgrade-Only.iso.
Step 4 Open vSphere Client.
Step 5 If a CD/DVD drive is not connected to the virtual machine, add one:

a) In the Virtual Machine Properties window, click theHardware tab, and then click Add to bring up the
Add Hardware window.

b) In the Add Hardware window, select CD/DVD Drive as the device type, and then click Next.
c) For the CD/DVD Media type, click Use physical drive, and then click Next.
d) Accept the default CD/DVD drive when prompted to select a drive, and then click Next.
e) In the Advanced Options settings, accept the default values, and then click Next.
f) In the Ready to Complete window, click Finish.
g) In the Virtual Machine Properties window, click OK.

Step 6 On each server, connect the CD/DVD drive to the ISO image:
a) In the virtual machines and templates inventory tree, select the virtual machine.
b) Click the Connect/disconnect the CD/DVD devices of the virtual machine button. The button icon is

a disk with a wrench.
c) Point to CD/DVD drive 1, and then click Connect to ISO image on local disk.
d) In the Open window, browse to the ISO image downloaded in Step 2 and double-click it.
It takes a little while to connect to the ISO image. When connected, in the Recent Tasks list, the status of the
Connect task shows Completed.

Step 7 Prepare to upgrade node B by updating the reverse proxy so that call requests are sent to node A first, node
C second, and no call requests are sent to node B:
a) On Cisco Expressway-C, choose Configuration > Unified Communications > Configuration.
b) Under Jabber Guest, click Configure Jabber Guest servers.
c) In the row for node A, click View/Edit, change the value for Priority to 1, and click Save.
d) In the row for node B, click View/Edit, change the value for Priority to 0, and click Save.
e) In the row for node C, click View/Edit, change the value for Priority to 2, and click Save.

Step 8 Make sure that there are no calls on node B:
a) On Cisco Expressway-C, choose Configuration > Zones > Zones.
b) In the row for node B, wait until the Calls column show 0 calls.

Step 9 Upgrade node B by doing the following:
a) Sign in to the server as root.
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b) Under the /mnt directory, create a new directory named cdrom to be used as the mount location for the
CD/DVD drive:
mkdir /mnt/cdrom

c) Mount the CD/DVD drive to /mnt/cdrom:
mount /dev/cdrom /mnt/cdrom

When the CD/DVD drive is mounted, the following message appears: mount: block device
/dev/sr0 is write-protected, mounting read only.

d) Change directory to /mnt/cdrom:
cd /mnt/cdrom

e) Execute the upgrade script:
bash upgrade

When the upgrade is complete, the followingmessage appears: The log file, for this upgrade,
can be found in /var/log/webcommon/upgrade.log.

Step 10 Prepare to upgrade node C by updating the reverse proxy so that call requests are sent to node A first, node
B second, and no call requests are sent to node C:
a) On Cisco Expressway-C, choose Configuration > Unified Communications > Configuration.
b) Under Jabber Guest, click Configure Jabber Guest servers.
c) In the row for node A, leave the priority set to 1.
d) In the row for node B, click View/Edit, change the value for Priority to 2, and click Save.
e) In the row for node C, click View/Edit, change the value for Priority to 0, and click Save.

Step 11 Make sure that there are no calls on node C:
a) On Cisco Expressway-C, choose Configuration > Zones > Zones.
b) In the row for node C, wait until the Calls column show 0 calls.

Step 12 Upgrade node C by repeating Step 9.
Step 13 Verify that node B and node C are back up and running by signing in to Cisco Jabber Guest Administration

as an administrator.
a) Confirm that the Cisco Jabber Guest version number to which you upgraded appears at the bottom of the

screen.
b) Check to make sure that all users and links look correct.

Step 14 Prepare to upgrade node A by updating the reverse proxy so that call requests are sent to node C first, node
B second, and no call requests are sent to node A:
a) On Cisco Expressway-C, choose Configuration > Unified Communications > Configuration.
b) Under Jabber Guest, click Configure Jabber Guest servers.
c) In the row for node A, click View/Edit, change the value for Priority to 0, and click Save.
d) In the row for node B, leave the priority set to 2.
e) In the row for node C, click View/Edit, change the value for Priority to 1, and click Save.

Step 15 Wait until there are no calls on node A:
a) On Cisco Expressway-C, choose Configuration > Zones > Zones.
b) In the row for node C, wait until the Calls column show 0 calls.

This may take a few minutes because this server handled all of the calls while the other two servers were
upgraded.
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Step 16 Demote node A to a secondary server:
a) Type cluster stepdown.
b) Verify that either node B or node C has been promoted to primary server by typing cluster status.
Make sure that the status of either node B or node C shows: ---> <IP address/hostname of node B or

node C> PRIMARY.
Step 17 Upgrade node A by repeating Step 9.
Step 18 Verify that node A is back up and running by signing in to Cisco Jabber Guest Administration as an

administrator.
The Cisco Jabber Guest version number to which you upgraded appears at the bottom of the screen.

Step 19 Promote node A to the primary server:
a) On the server that is currently the primary, type cluster stepdown.
b) Check to see if node A was promoted to primary by typing cluster status.

If node A is the primary, the status shows: ---> <IP address/hostname of node A> PRIMARY.
c) If node A was not promoted to primary, repeat Step 12.a until node A is promoted to the primary server.

Step 20 Update the order of the reverse proxy.
Step 21 To ensure that the latest version of Cisco Jabber Guest Administration is loaded in your browser, refresh any

browser instances that are signed in to Cisco Jabber Guest Administration or that have the Cisco Jabber Guest
Administration sign-in page loaded.

Remove Server from Cluster

After a server is removed from a cluster, it cannot be run as a standalone Cisco Jabber Guest instance. To do
this, the server must be reinstalled.

Important

In this procedure, we refer to the secondary server that we want to remove as node A, and to the other secondary
server as node B

Procedure

Step 1 Sign in to each server in the cluster as root.
Step 2 On the primary server:

a) Type cluster remove <IP address/hostname of node A>, and follow the on-screen prompts.
b) Verify that node A is removed from the cluster by typing cluster status.

Node A is removed from the list of servers.

Step 3 On node A, block communication from node B by typing cluster disallow <IP address/hostname of

node B>.
Step 4 On node B, block communication with node A by typing cluster disallow <IP address/hostname of

node A>.
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Configure Load Balancing

Configure Round-Robin DNS Load Balancing
With round-robin DNS load balancing, a DNS server returns an ordered list of IP addresses associated with
a single host name. With each new query on that host name, the DNS server rotates through the list. Multiple
servers at different IP addresses take turns handling new requests to provide the same service.

For TURN traffic, an advantage of round-robin DNS load balancing is that it also provides redundancy. If a
TURN server is down or unreachable, the client tries another server.

The order of the IP address list returned for a DNS lookup is difficult to predict if the DNS server is under
any kind of load directed at the host name. The important thing to expect is that calls to the host name go to
different servers over time.

Note

Procedure

Step 1 Make sure that the DNS server has round-robin enabled.
Step 2 Make sure that the FQDNs for the Cisco Expressway-C and Cisco Expressway-E clusters are configured on

the DNS server to round-robin through the IP addresses of the server cluster.
Step 3 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 4 Click Settings, and then click Call Control and Media.
Step 5 To set up round-robin DNS for the SIP server:

a) For SIP server, enter the FQDN of the Cisco Expressway-C cluster.
b) Next to Send SIP traffic to, click SIP server specified above.

Step 6 To set up round-robin DNS to request short-term TURN credentials from Cisco Expressway-C:
a) For Expressway-C (IP address or DNS name), enter the FQDN of the Cisco Expressway-C cluster.
b) Next to Request short-term TURN credentials from, click Expressway-C server specified above.

Step 7 To set up round-robin DNS for the TURN server: For Expressway-E TURN server (IP address or DNS
name), enter the FQDN of the Cisco Expressway-E cluster.
Successive clients making TURN requests to that cluster FQDN are directed to different servers in the Cisco
Expressway-E cluster; however, whether and how a particular client uses round-robin DNS for subsequent
calls can be influenced by DNS caching.

Step 8 Click Update.

Round-robin DNS takes effect if the Cisco Jabber Guest call URL that is used by a client browser to make a
Cisco Jabber Guest call uses the FQDN for the Cisco Expressway-E cluster.
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What to do next

To ensure that the number of new call requests does not exceed the capacity of the Cisco Expressway-C, make
sure that you change the SIP call throttle limit.

Change the SIP Call Throttle Limit
To ensure that the rate of new call requests (SIP INVITES) does not exceed the capacity of the Cisco
Expressway-C, the Cisco Jabber Guest server implements a call throttling mechanism.

For a clustered Cisco Expressway-C deployment in which load balancing is achieved by round-robin DNS,
we recommend that you change the SIP call throttle limit to 10 multiplied by the number of servers in the
Cisco Expressway-C cluster to which Cisco Jabber Guest sends SIP. For example, if there are two servers in
the Cisco Expressway-C cluster, set the SIP call throttle limit to 20.

If the rate of new calls exceeds the throttle limit, Cisco Jabber Guest delays a small amount of time before
processing those calls that exceed the throttle limit. This throttling should not be noticed by users.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Advanced Settings.
Step 3 In the SIP call throttle limit (new calls/second) box, type or select the throttle limit.
Step 4 Click Update.

Configure Round-Robin CSV Loading Balancing
With round-robin CSV load balancing, a Cisco Jabber Guest server can be configured to make requests, in
round-robin order, across individually specified servers by using a CSV list. After a server is used, the next
server on the list is used, until the choice rotates to the beginning of the list and then repeats.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Call Control and Media.
Step 3 To set up a CSV list for the SIP server:

a) For SIP server, enter a list of IP addresses or FQDNs for individual Cisco Expressway-C servers. The
list of IP addresses or FQDNs must be separated by commas and must not contains spaces.

Example:

expressway-c-1.somedomain.com,expressway-c-2.somedomain.com,expressway-c-3.somedomain.com
b) Next to Send SIP traffic to, click SIP server specified above.

Step 4 To set up a CSV list to request short-term TURN credentials from Cisco Expressway-C:
a) For Expressway-C (IP address or DNS name), enter a list of IP addresses or FQDNs for individual

Cisco Expressway-C servers. The list of IP addresses or FQDNs must be separated by commas and must
not contains spaces.
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Example:

expressway-c-1.somedomain.com,expressway-c-2.somedomain.com,expressway-c-3.somedomain.com
b) Next to Request short-term TURN credentials from, click Expressway-C server specified above.

Step 5 To set up a CSV list for the TURN server: For Expressway-E TURN server (IP address or DNS name),
enter a list of FQDNs for individual Cisco Expressway-E servers. The list of FQDNs must be separated by
commas and must not contains spaces.

Example:

expressway-e-1.somedomain.com,expressway-e-2.somedomain.com,expressway-e-3.somedomain.com

Step 6 Click Update.

Configure HTTP Load Balancing
Cisco Jabber Guest server can take advantage of HTTP load balancing from the Cisco Expressway-C by
sending SIP and TURN credential requests to the Cisco Expressway-C that sent the HTTP.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Call Control and Media.
Step 3 To send SIP to the Cisco Expressway-C that sent the HTTP, next to Send SIP traffic to, click Expressway-C

server that proxied the HTTP request from Jabber Guest client.
Step 4 To send TURN credential requests to the Cisco Expressway-C that sent the HTTP, next toRequest short-term

TURN credentials from, click Expressway-C server that proxied the HTTP request from Jabber Guest
client.

Step 5 Click Update.

Configure Round-Robin TURN Port Range Load Balancing
You can configure Cisco Jabber Guest to take advantage of the load-balancing potential for TURN requests
by using different TURN ports for each successive TURN request.

On a large Cisco Expressway-E deployment, up to six TURN request ports can be specified as a range. When
used in combination with round-robin DNS or round-robin CSV for TURN servers, this multiplies the number
of TURN request ports in use.

Procedure

Step 1 Sign in to Cisco Jabber Guest Administration as an administrator.
Step 2 Click Settings, and then click Call Control and Media.
Step 3 For TURN port, enter a hyphenated range of port numbers that matches the range of TURN request ports

configured on Cisco Expressway-E (under Configuration > Traversal > TURN).
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Example:

3478-3483
Step 4 Click Update.
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C H A P T E R 6
Post-Install Configuration Changes

• Change Virtual Machine Properties of a vCenter-hosted Server, on page 63
• Change Virtual Machine Properties of a UC Virtualization Foundation, UC Virtualization Hypervisor,
or ESXi-hosted Server, on page 63

Change Virtual Machine Properties of a vCenter-hosted Server
You can change the properties of a virtual machine, such as its IP address or hostname.

Procedure

Step 1 In the Virtual Machine tab of vSphere, click the Configure virtual machine link.
Step 2 Click the Options tab.
Step 3 Under vApp Options, click Properties.
Step 4 Edit the properties, as required.
Step 5 Click OK.
Step 6 Turn on the virtual machine:

a) In the virtual machines and templates inventory tree, right-click the virtual machine.
b) Choose Power > Power On.

Change Virtual Machine Properties of a UC Virtualization
Foundation, UC Virtualization Hypervisor, or ESXi-hosted Server

You can change the properties of a virtual machine, such as its IP address or hostname.

Procedure

Step 1 Sign in to the virtual machine directly from the virtual machine console or by using a Secure Shell client such
as SSH.
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Step 2 Change directory to /etc/jabberguest:
cd /etc/jabberguest

Step 3 Copy the file network.config.sample to a file named network.config:
cp network.config.sample network.config

Step 4 Edit the properties in network.config:
vi network.config

Step 5 To configure the virtual machine with a static IP address, you must edit the hostname, IP address, gateway
IP address, network mask, and at least one DNS server IP address.

Do not include quotation marks around the domain name or hostname.Important

Step 6 Check the properties:
cd /opt/cisco/webcommon/scripts
python networking.py -dryrun

Step 7 Restart the virtual machine:
shutdown -r now
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C H A P T E R 7
Troubleshoot

• Locate chip.log File, on page 65
• Locate chip.dmp File, on page 66
• Reset Admin Password for Cisco Jabber Guest Administration, on page 66
• Reset Root Password for Cisco Jabber Guest Server, on page 66
• Audio and Video Issues, on page 68
• Call Links Redirect to Cisco Expressway-E Web Page, on page 69
• Plug-in Crashes, on page 70
• Jabber Guest Web Administrator Page Does Not Load , on page 70
• Error Messages, on page 71

Locate chip.log File
If you are asked to send the chip.log file, use the following procedure.

Procedure

Step 1 Do one of the following:

• For Windows, navigate to %HOMEPATH%\Appdata\LocalLow\Cisco\chip.

%HOMEPATH% is generally of the form 'C:\Users\username'.Note

• For Safari and Firefox (49 or below) on Mac OS X, navigate to ~/Library/"Internet
Plug-Ins"/"Cisco Jabber Guest
Plug-in.version-number.plugin"/Contents/Frameworks/Logs.

• For Chrome and Firefox (50 or later) on Mac OS X, navigate to
~/Applications/Guest/App.app/Contents/Frameworks/Logs/

Step 2 Compress the file and email it back to the requester.
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Locate chip.dmp File
If your plug-in crashes, a dump file called chip.dmp is created. Currently, this file is created only for plug-in
crashes on Microsoft Windows. If you are asked to send the chip.dmp file, follow this procedure.

Procedure

Step 1 Navigate to %HOMEPATH%\Appdata\LocalLow\Cisco\chip.

%HOMEPATH% is generally of the form 'C:\Users\username'.Note

Step 2 Compress the file and email it back to the requester.

Reset Admin Password for Cisco Jabber Guest Administration
Procedure

Step 1 Sign in to the Cisco Jabber Guest server as root.
Step 2 Change directory to /opt/cisco/webcommon/scripts:

cd /opt/cisco/webcommon/scripts

Step 3 Enter the following command:
python mongo_admin_reset.py

The password is reset to its default value: jabbercserver.

Reset Root Password for Cisco Jabber Guest Server
Procedure

Step 1 Open a console session for the Cisco Jabber Guest server and restart the server.
Step 2 Press any key to interrupt the start process.
Step 3 Press e to edit.
Step 4 From the entries, select kernel and press e to edit.

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
66

Troubleshoot
Locate chip.dmp File



Step 5 Start the server in single-user mode:
a) Add the word single to the end of the line.
b) Press the Enter key.

Step 6 Press b to start the server.
The Cisco Jabber Guest server starts in single-user mode.
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Step 7 Enter passwd root, and then enter a new password.
Step 8 Restart the server.

Audio and Video Issues

One-Way Video When Using VPN
Problem Callers experience one-way video when using Cisco Jabber Guest over VPN.

Possible Cause The default Maximum Transmission Unit (MTU) on Cisco Expressway-E is too high and
can cause packet loss.

Solution Change the MTU.

No Audio or Video on Single NIC Deployment
Problem No audio or video on single NIC deployment; media is terminating on the Cisco Expressway-E

Possible Cause On the Cisco Expressway-C, for the zone to the Cisco Jabber Guest server,Media
encryption mode is not set to Best effort.

Solution SetMedia encryption mode to Best effort. Best effort forces media from the Cisco Expressway-E
to terminate on the Cisco Expressway-C.
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Don't See Screen Share in Production Deployment
Problem Callers don't see the screen share.

Possible Cause User Datagram Protocol (UDP)/Binary Floor Control Protocol (BFCP) settings have
changed and the BFCP session may not be negotiated.

Solution On the Cisco Expressway-C, make sure that SIP UDP/BFCP filter mode is set to Off. On Cisco
Unified Communications Manager, for endpoints that support BFCP and SIP trunk to Cisco Expressway-C,
make sure that the SIP Profile is set to Allow Presentation Sharing using BFCP. For more information, see
Check BFCP Settings for Screen Sharing.

Check BFCP Settings for Screen Sharing
By default, Cisco Expressway-C passes the User Datagram Protocol (UDP)/Binary Floor Control Protocol
(BFCP) setting untouched to and from Cisco Unified CommunicationsManager. That is, the SIP UDPBFCP
filter mode setting, which determines whether INVITE requests sent to this zone filter out UDP/BFCP is set
toOff. If the setting is set toOn, UDP/BFCP settings are modified and the BFCP session may not be negotiated.

Procedure

Step 1 On the Cisco Expressway-C setting, do one of the following:

• From the administrator command-line interface, enter the following command:
xConfiguration Zones Zone <index> Neighbor SIP UDP BFCP Filter Mode: <On/Off>

Make sure that SIP UDP/BFCP filter mode is set to Off.

Off means that INVITE requests are not modified; On means that any media line referring to the
UDP/BFCP protocol is replaced with TCP/BFCP and disabled.

• From the administrator web page, "Configuration Zones Edit Zones Advanced," set the profile to
Custom and make sure that SIP UDP/BFCP filter mode is set to Off.

Step 2 On Cisco Unified Communications Manager, for endpoints that support BFCP and SIP trunk to Cisco
Expressway-C, make sure that the SIP Profile is set to Allow Presentation Sharing using BFCP.

Don't See Screen Share in Lab Deployment
Problem In a lab deployment in which Cisco Jabber Guest is pointed directly to Cisco Unified Communications
Manager, without configuring Expressway, callers see a black screen instead of the screen share.

Possible Cause The media stream is blocked by a firewall.

Solution Enable a client-side firewall rule to allow the incoming screen share.

Call Links Redirect to Cisco Expressway-E Web Page
Problem Call links redirect to the Cisco Expressway-E web page.

Possible Cause The Cisco Expressway-E administrator already uses ports 80 and 443.
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Solution Remap incoming requests from the Cisco Jabber Guest client to Cisco Expressway-E on ports 80
and 443 to ports 9980 and 9443, respectively, using a firewall or similar in front of Cisco Expressway-E.
For the mobile client, using 9980 or 9443 in call links is not supported; you must use port remapping on
your firewall to remap port 80 to port 9980 and port 443 to port 9443.

Related Topics
Set Domain Used for Links, on page 47
Set Redirect URL for Mobile Clients

Plug-in Crashes
Problem The plug-in crashes.

Possible Cause The video drivers may not be current.

Solution Make sure that the video drivers are up to date on the system.

Jabber Guest Web Administrator Page Does Not Load
Problem The Cisco Jabber Guest Web Administrator page does not load after a Cisco Jabber Guest server
restart.

Possible Cause The webcommon-ui service might not have been started properly.

Solution Restart the webcommon-ui service manually using the following procedure:

Procedure

Step 1 Sign in to the Cisco Jabber Guest server as root.
Step 2 Change directory to /etc/init.d

Step 3 Execute the following command:
service webcommon-ui restart
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Error Messages
Table 19: Error Messages

What It MeansError MessageLocation

When one of these messages appears, it may
indicate a problem with the Expressway
certificate that is uploaded to Cisco Jabber
Guest Administration.

Verify that the Expressway certificate that is
uploaded to Cisco Jabber Guest Administration
is either an Expressway certificate or the CA
certificate that signed it:

1. Check the common name (CN) of the issuer
and the subject of the certificate that is
uploaded to Expressway:

a. On the Expressway, choose
Maintenance > Security certificates >
Server certificate.

b. Click Show (decoded).

2. Check the CN of the issuer and the subject
of the certificate that is uploaded to Cisco
Jabber Guest Administration:

a. Sign in to Cisco Jabber Guest
Administration.

b. Click Settings, and then click Secure
SIP Trust Certificate.

3. Make sure that Tomcat was restarted:
service tomcat-as-standalone.sh
restart

"IOException closing sock
javax.net.ssl.SSLHandshakeException:
General SSLEngine problem"
appears In the Cisco Jabber Guest
webcommon-tomcat.log file.

Cisco Jabber Guest
webcommon logs

tvcs: Event="Outbound TLS
Negotiation Error" Service="SIP"
Src-ip="<ip address>"
Src-port="27510" Dst-ip="<ip
address>" Dst-port="5061"
Detail="No SSL error available,
probably remote disconnect"
Protocol="TLS" Level="1"
UTCTime="yyyy-mm-dd
hh:mm:ss,732"

Cisco Expressway
Event Log

SIP: Failed to connect to <IP
address>:5061 : TLS negotiation
failure

On Cisco Expressway,
status of zone for
Cisco Jabber Guest
server shows Failed
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What It MeansError MessageLocation

This message may mean that the call control
andmedia settings for Cisco Expressway-Cmay
not be configured correctly. Check the settings:

1. Sign in to Cisco Jabber Guest
Administration as an administrator.

2. Click Settings, and then clickCall Control
and Media.

3. Under Cisco Expressway-C, if Request
short-term TURN credentials from is set
to Expressway-C server specified above,
make sure that the value in the
Expressway-C (IP address orDNS name)
field is correct.

4. Check the value in the HTTP port field.
The default value is 443.

5. Check the values in the Cisco
Expressway-C administratorUsername and
Password fields:

• The administrator account is created
on the Cisco Expressway-C (Users >
Administrator accounts).

• TheCisco Expressway-C administrator
must have read-write and API access.

6. Check Cisco Expressway-C server
certificate or Cisco Expressway-C
certificate authority certificate.

It must use RSA keys greater than or equal
to 1024 bits and must not be signed with
MD5.

Failed to acquire TURN credentialsCisco Jabber Guest
client

Make sure that the link is active: Click Links,
click the link, and check the State settings to
make sure that the link has not expired.

Link Not FoundCisco Jabber Guest
client
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What It MeansError MessageLocation

This message may mean that the link that has
not yet been replicated to the Cisco Jabber
Guest server that handles the request.

When you create a click-to-call link on a Cisco
Jabber Guest server that is a member of a
cluster, you must allow a small amount of time
before that link is active on all servers in the
cluster.

If you deploy an application that creates links
dynamically by using the link API and pushes
them to the Cisco Jabber Guest client, we
recommend that you factor this replication delay
into your design.

Link not validCisco Jabber Guest
client

Thismessagemaymean that Cisco Jabber Guest
is unable to contact the TURN server. One
possible cause is that multiple network
interfaces are enabled, including SW VPN.
Another possible cause is that a firewall or NAT
blocking UDP port 3478 between the client and
the Cisco Expressway-E (publicly accessible
IP). Some home routers block all UDP.

Missing SDP. There was a
networking error between your
device and the server.

Cisco Jabber Guest
client

You may see this message because the link
between the Cisco Expressway-C and Cisco
Expressway-E is down and domain information
hasn't replicated from the Cisco Expressway-C
to Cisco Expressway-E.

OnCisco Expressway-E, when viewingUnified
Communications status (choose Status >
Unified Communications and click View ssh
tunnel status), make sure that:

• The Cisco Jabber Guest domain is listed.

• The SSH tunnel is active.

Not found on AcceleratorCisco Jabber Guest
client

Apache Tomcat may not be running, perhaps
after an upgrade or server interruption.

Restart Tomcat on the Cisco Jabber Guest
Server: service tomcat-as-standalone.sh

restart.

Server error: class
java.lang.IllegalStateException:
Error creating sipServletRequest

ROAP_EXCEPTION

Cisco Jabber Guest
client
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What It MeansError MessageLocation

You may see this message for one of the
following reasons:

• The directory number (DN) embedded in
the link or associated with the link, does
not exist on the Cisco Unified
Communications Manager or Cisco
TelePresence Video Communication
Server.

• The link contains a URI
(user@domain.com) but the CiscoUnified
Communications Manager is not
configured to route calls by URI. Use a
DN instead.

SIP Error. The destination
associated with this link is not
reachable.

Cisco Jabber Guest
client

This message indicates that the web client could
not allocate the TURN relay on the TURN
server. This could occur for one of the following
reasons:

• UDP port 3478 is blocked. Youmust allow
this port inbound from the public Internet
to the Cisco Expressway-E.

• The DNS record for the TURN server is
not resolvable (must be a DNS A-record).

• The Expressway-E TURN Server (IP
Address or DNS Name) field and Turn
Port fields are not configured correctly in
Cisco Jabber Guest Administration
(Settings > Call Control and Media).

• The Domain name (Settings > Call
Control and Media, under Cisco
Expressway-C) is not a configured
domain name on Cisco Expressway-C or
is not configured for Cisco Jabber Guest
services.

TURN Error. Your call attempt has
failed due to incompatibility with
your home or company security
infrastructure. Please contact your
network administrator or check
your home network security
settings.

Cisco Jabber Guest
client

Installation and Configuration Guide for Cisco Jabber Guest Server 11.2
74

Troubleshoot
Error Messages



C H A P T E R 8
Reference

• Cisco Unified Communications Manager, on page 75
• Cisco Unified Communications Manager/Cisco Expressway Configuration Checklist, on page 76

Cisco Unified Communications Manager
• Documentation Home

http://www.cisco.com/en/US/products/sw/voicesw/ps556/tsd_products_support_series_home.html

• Documentation Guide for Cisco Unified Communications Manager, Release 8.6(2a)

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/docguide/8_6_2/dg862a.html

• Documentation Guide for Cisco Unified Communications Manager, Release 9.1(1)

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/docguide/9_1_1/CUCM_BK_CBABE0BB_
00_cucm-documentation-guide-91.html

• Documentation Guide for Cisco Unified Communications Manager, Release 10.5(1)

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/docguide/10_5_1/CUCM_BK_C2CFB1F8_
00_cucm-documentation-guide-1051.html

• Documentation Guide for Cisco Unified Communications Manager, Release 11.0(1)

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/docguide/11_0_1/CUCM_BK_C345DB0C_
00_cucm-documentation-guide-1101.html

• Documentation Guide for Cisco Unified Communications Manager, Release 11.5(1)

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/docguide/11_5_1/cucm_b_
documentation-guide-cucm-imp-1151.html
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Cisco Unified Communications Manager/Cisco Expressway
Configuration Checklist

Prepare to Install

• Use Cisco Unified Communications Manager 8.6.x or later.

• Configure CiscoUnified CommunicationsManager to workwith Cisco Expressway or Cisco TelePresence
Video Communication Server Control (VCS).

Cisco Jabber Guest can point directly to Cisco Unified Communications Manager for lab deployments
only. Without configuring Cisco Expressway or Cisco VCS, Cisco Jabber Guest is not supported in a
production environment.

Perform Initial Setup

• On Cisco Unified Communications Manager, set up a non-secure or secure Session Initiation Protocol
(SIP) trunk and point it to the Cisco Expressway-C.

For more information, see the Cisco Unified Communications Manager with Cisco Expressway (SIP
Trunk) Deployment Guide.

• On Cisco Expressway-C, set up a neighbor zone and point it to Cisco Unified CommunicationsManager.

For more information, see the Cisco Expressway Basic Configuration Deployment Guide.

• Add a search rule on Cisco Expressway-C to route calls to Cisco Unified Communications Manager.

For more information, see the Cisco Expressway Basic Configuration Deployment Guide.

• For dual NIC deployments, also add a search rule on the Cisco Expressway-E to route call to the Cisco
Expressway-C.

• Set up a Unified Communications traversal zone between the Cisco Expressway-C and the Cisco
Expressway-E. Set the traversal zone type to Unified Communications traversal.

For more information, see the Cisco Expressway Administrator Guide.

Creating Links

• Make sure that the part of the link after /call resolves to a directory number (DN) or uniform resource
identifier (URI) that is routable on Cisco Expressway-C and Cisco Unified Communications Manager.

• For dual NIC deployments, also make sure that the part of the link after /call resolves to a DN or URI
that is routable on Cisco Expressway-E.
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