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About This Guide 

This guide describes how to install and configure Cisco Unified Attendant Console Standard. 

Who Should Read This Guide 
This guide is for deployment engineers, system administrators, and anyone else who installs or 
configures Cisco Unified Attendant Console Standard. You should have a knowledge of how to configure 
the Cisco Unified Communications Manager used by the application. 

How This Guide is Organized 
This guide contains the following sections. 

Section Contains 

Chapter 1, “Introduction to Cisco Unified 
Attendant Console Standard”

Introduction to Cisco Unified Attendant Console 
Standard 

Chapter 2, “Installing Cisco Unified Attendant 
Console Standard”

Preparing Cisco Unified Communications Manager 
and installing Cisco Unified Attendant Console 
Standard 

Chapter 3, “Starting Cisco Unified Attendant 
Console Standard”

Starting Cisco Unified Attendant Console Standard 
and configuring operator details 

Chapter 4, “Configuring Cisco Unified 
Attendant Console Standard”

Configuring Cisco Unified Attendant Console 
Standard, including managing sign in devices 

Chapter 5, “Directories” Using and controlling directories 

Chapter 6, “Keyboard Shortcuts” Setting up keyboard shortcuts 

Appendix A, “Configuring Logging” Configuring application logging 

Appendix B, “Import/Export File Formats” Formats of import and export files 

Appendix C, “Phones Supported by Cisco 
Unified Attendant Console Standard”

List of supported Cisco phones 
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Document Conventions 
The following textual and typographic conventions are used in this document: 

Note Means reader take note.

Tip Means the following information will help you solve a problem. 

Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data. 

Timesaver Means the described action saves time. You can save time by doing what is described in the paragraph. 

Warning Means reader be warned. In this situation, you might do something that could result in bodily injury.

Obtaining Documentation and Submitting Service Requests 
For information on obtaining additional documentation and submitting service requests, see the monthly 
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical 
documentation, at http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html 

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free 
service and Cisco currently supports RSS Version 2.0. 

Convention Usage 

bold font Commands, keywords and user-entered text appear in bold type.

italic font Document titles, new or emphasized terms, and arguments for which you supply values 
are in italic font.

[] Elements in square brackets are optional.

{x | y | z} Required alternative keywords are enclosed in braces and separated by vertical bars.

[x | y | z] Optional alternative keywords are enclosed in square brackets and separated by vertical 
bars.

string A non-quoted set of characters. Do not use quotation marks around the string or the 
string will include the quotation marks.

courier font Terminal sessions and information the system displays appear in courier font.

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html
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1
Introduction to Cisco Unified Attendant Console 
Standard 

Cisco Unified Attendant Console Standard is a Microsoft Windows-based operator attendant console 
application for use with Cisco Unified Communications Manager (CUCM). For details of the supported 
versions, see Cisco Unified Communications Manager Compatibility, page 2-4. Cisco Unified Attendant 
Console Standard supports up to 5000 contacts on a single instance. 

Cisco Unified Attendant Console Standard enables you to do the following: 

• Control calls on your local IP Phone, XMPP client (such as Jabber), or Cisco IP Communicator 

• Make, answer and end calls 

• Hold and resume calls 

• Blind/consult transfer calls to directory contacts or voicemail, or any other valid number 

• Direct transfers

• Join calls 

• Set Call Forward and Do Not Disturb on the operator phone 

• Park calls 

• Create and manage conference calls 

• Import custom directories of contacts not in your Cisco Unified Communications Manager directory 

• Create custom directories (directory groups) and export them to share with other operators 

• Synchronize Cisco Unified Attendant Console Standard’s corporate (main) directory with a CUCM 
or CSV file source directory 

• During synchronization with your source directory:

– Map the fields from your source directory to the ones in the corporate directory 

– Filter contacts, so that only certain ones are added to the corporate directory 

– Modify contact numbers using BLF rules 

• See the line state and presence of each contact 

• View call history 

• Specify the devices used to sign in to the application 

• Log in to a hunt group when you sign in to the application. 

Online help on the application is available. For how to display the help, see Accessing Help on the 
Application, page 1-3. 
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Chapter 1      Introduction to Cisco Unified Attendant Console Standard
Cisco Unified Attendant Console Standard User Interface

Accessibility for Users with Disabilities 
The Cisco Unified Attendant Console Standard user interface and controls are described in Cisco 
Unified Attendant Console Standard User Interface, page 1-2. 

Cisco Unified Attendant Console Standard incorporates the following features to make it easier for blind 
and visually impaired people to use it: 

• Most functions can be accessed using either the mouse or keyboard. You can define keyboard 
shortcuts for the most frequently used functions. For more information, see Chapter 6, “Keyboard 
Shortcuts”. 

• You can set the size of call and directory text in the interface. 

• A tooltip is displayed for each graphical interface control when you point to it 

For more information on the Cisco Accessibility Program visit 
http://www.cisco.com/web/about/responsibility/accessibility/contact.html. 

Cisco Unified Attendant Console Standard User Interface 
You use the Cisco Unified Attendant Console Standard interface to do all the standard operator tasks, 
including making calls, putting calls on hold, and conferencing calls. 

An example of the user interface is shown below: 

The legend is on the next page. 

http://www.cisco.com/web/about/responsibility/accessibility/contact.html
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Legend 

You control the interface using both your mouse and keyboard. Many things that you can do with the 
mouse you can also do using your keyboard, provided that the application interface is selected. 

Accessing Help on the Application 
You can display help about Cisco Unified Attendant Console Standard by doing one of the following:

• In the main menu, choose Help > Cisco Unified Attendant Console Standard Help. 

• Press F1. 

The Help contains the following to make it easy to find what you need to know: 

# Name Contains 

1 Main menu Controls for using and configuring the application. 

Many of the controls here are also available when you right-click 
specific parts of the interface. For example, controls relevant to the 
directories are displayed when you right-click in the directory pane. 

2 Current console extension The extension used to sign in to the application. Click this to display 
a menu that you use for signing out and for logging into and out of 
hunt groups.

3 Call Control pane Active call information on any line on the console phone. The calls in 
progress are displayed here, along with their status, duration, and 
controls for frequently used actions, such as transferring or ending the 
call. 

4 Parked Calls pane Active parked calls, by default displayed in the order in which they 
were parked. 

This pane shows the park extension used, the identities of both the 
caller and the DN that parked the call, and how long the call has been 
parked. 

5 Call History pane Completed calls in the current session, by default listed in reverse 
chronological order. You can change the order in which completed 
calls are listed. 

This pane is not displayed by default; use View > Show Call History 
to display it. 

6 Search box Tool in the header bar of the Directory pane for finding contacts by last 
name, first name, department and number. 

7 Set search preferences Control how searches are conducted. 

8 Add new directory group Control for creating a new directory group. 

9 Add contact Only available for directory groups. Control for adding contacts to 
directory groups. 

10 Directory pane Displays the synchronized directory, directory groups and search 
results. Includes Search box and controls for creating directory 
groups. Contact information includes line state and presence. For 
more information, see Chapter 5, “Directories”. 
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• Text search tool 

• Index 

• Contents list. 
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2
Installing Cisco Unified Attendant Console 
Standard 

To install Cisco Unified Attendant Console Standard you must do the following: 

1. Ensure that the PC running it satisfies the minimum hardware and software requirements. These are 
described below. 

2. Within Cisco Unified Communications Manager, create an Application User with associated 
phones. If you intend to use the presence facility within Cisco Unified Attendant Console Standard, 
you must also set up an End User. For instructions, see Configuring Cisco Unified Communications 
Manager, page 2-5. 

3. Install the Cisco Unified Attendant Console Standard software. For instructions, see Installing or 
Upgrading Cisco Unified Attendant Console Standard, page 2-8. 

PC Hardware and Software Requirements 
The PC running Cisco Unified Attendant Console Standard has the following minimum hardware 
requirements: 

• 2.4 GHz Core 2 Duo 

• 4 GB RAM

• 10 GB available hard drive space 

• 100 Mbps network card, connected to the same network as Cisco Unified Communications Manager 
using TCP/IP 

• Monitor with 1024x768 resolution (recommended: monitor with 1440x900 resolution, plus headset) 

• Keyboard with 10-key number pad. 
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PC Hardware and Software Requirements

Operating System Support 
Cisco Unified Attendant Console Standard is supported under the following operating systems: 

• Windows Vista Professional with SP2 (32-bit or WoW64) 

• Windows 7 (32-bit or WoW64) – integration with Cisco Unified Communications Manager versions 
7.1(5) or 8.0(x) is not supported under this operating system 

• Windows 8 (32-bit or WoW64) – you can integrate only with Cisco Unified Communications 
Manager version 10.0(1) or 10.5(1) under this operating system 

• Windows 8.1 (32-bit or WoW64) – you can integrate only with Cisco Unified Communications 
Manager version 10.5(1) under this operating system 

For a summary of the operating systems and Cisco Unified Communications Manager versions 
compatible with Cisco Unified Attendant Console Standard, see the table on page 2-4. 

Note If your machine uses a 64-bit operating system, you cannot run Cisco Unified Attendant Console 
Standard against Cisco Unified Communications Manager version 7.1(5), as this does not support the 
64-bit TSP required for the systems to be able to communicate with each other. 

Citrix Support 
Cisco Unified Attendant Console Standard is not supported within a Citrix environment. 

Jabber Support 
Both standard Jabber installations (locally installed on the operator computer) and VXME installations 
(installed in a VXME environment) are supported as operator devices and end points. 

Network Requirements 
The computer running Cisco Unified Attendant Console Standard must be able to access the Cisco 
Unified Communications Manager and the Cisco Unified Presence (CUP) Server. By default, these use 
the following two-way TCP ports: 

• Cisco Unified Communications Manager – Port 443 

• Cisco Unified Presence (CUP) Server – Port 5222 

If you have a firewall on your computer, you must configure firewall exceptions for these ports or for 
any alternatives you may use in your installation. 

Virus Scan Exclusions 
To prevent key system files from being quarantined by your anti-virus software, add the following 
folders to your virus scan exclusions: 

• \Program Files\Cisco\Cisco Unified Attendant Console Standard (under 32-bit operating systems) 
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• \Program Files (x86)\Cisco\Cisco Unified Attendant Console Standard (under 64-bit operating 
systems) 

• \Users\ windows user name \AppData\Roaming\CUACSLayout 

• \ProgramData\CUACS 

Windows Folder Permissions 
Under Microsoft Windows Vista (32/64-bit), Windows 7 (32/64-bit SP1), Windows 8 (Desktop mode) 
and Windows 8.1 (64-bit), the following folders require the specified permissions set on them: 

• \Program Files (x86)\Cisco\Cisco Unified Attendant Console Standard 
\Users\<windows_user_name>\AppData\Roaming\CUACSLayout
\Users\<windows_user_name>\AppData\Roaming\CUACSLogging 

– Modify 

– Read & execute 

– List folder contents 

– Read 

– Write (Windows 8.1 only) 

– Special permissions (Windows 8.1 only) 

• \ProgramData\CUACS 

– Modify 

– Read & execute 

– List folder contents 

– Read 

– Write 

– Special permissions 

Scalability 
Cisco Unified Attendant Console Standard supports up to 5000 contacts on a single instance 

Directory Synchronization

Although the recommended maximum Cisco Unified Attendant Console Standard directory size is 5000 
contacts, there is no theoretical limit to the number that can be stored. However, if many users (say 500) 
with large directories (say 50000 contacts) simultaneously try to synchronize with Cisco Unified 
Communications Manager it would struggle to cope.

Note Cisco Unified Communications Manager's User and CTI (TSP client) resources are perfectly adequate 
to support this many concurrent Cisco Unified Attendant Console Standard users.

If you do have many concurrent Cisco Unified Attendant Console Standard users who are synchronizing 
more than the recommended maximum number of contacts, we recommend that these users:
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• Configure Cisco Unified Attendant Console Standard to sync the directory infrequently; for 
example, once a day when they launch the application

• Stagger the times at which they synchronize or launch the application.

Presence

Cisco Unified Attendant Console Standard uses its user’s personal Jabber credentials to enable presence 
indicators in its directory. So long as hundreds of users are not sharing the same Jabber credentials, the 
load on the presence server will be distributed, and there will be no problems with presence. 

Cisco Unified Communications Manager Compatibility 
Cisco Unified Attendant Console Standard is compatible with the Cisco Unified Communications 
Manager versions shown in the table on page 2-4. 

If you are using Cisco Unified Communications Manager Release 8 or later, the TSP and New Cisco 
Media Driver are automatically installed and activated when you install Cisco Unified Attendant 
Console Standard. However, Cisco Unified Communications Manager Release 7.1.5 does not support 
this silent TSP installation, and you must manually download and install the appropriate TSP and Cisco 
TAPI Wave driver according to the instructions in Installing and Configuring the Cisco TSP for Cisco 
Unified Communications Manager 7.x, page 2-10. 

Note The following: 

• The 32-bit version of TSP is required when running Cisco Unified Attendant Console under a 32-bit 
operating system. The 64-bit version of TSP is required when running Cisco Unified Attendant 
Console under a 64-bit operating system. Consequently, 64-bit installations are supported only in 
conjunction with Cisco Unified Communications Manager versions later than 8.0(3). 

• If the installation wizard is unable to download the TSP, you can fix the problem by doing the 
following:

a. In your web browser, under Tools, choose Internet Options.

b. In the dialog box, select the Advanced tab.

c. Under Security, deselect (uncheck) Check for publisher's certificate revocation.

d. Under Security, deselect (uncheck) Check for server certificate revocation. 

e. Click OK. 

Cisco Unified Attendant Console Standard also integrates with the Cisco Unified Presence Server. 

The operating system and Cisco Unified Communications Manager (CUCM) version compatibility is 
summarized below: 

CUCM 
Version 

Windows Vista 
32-bit and Wow64

Windows 7 
32-bit and WoW64

Windows 8 
32-bit and WoW64

Windows 8.1 
32-bit and WoW64

7.1(5) 1 Supported Not supported Not supported Not supported 

8.0(1) Supported Not supported Not supported Not supported 

8.0(3) Supported Not supported Not supported Not supported 
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Configuring Cisco Unified Communications Manager 
Cisco Unified Attendant Console Standard must be able to communicate with the Cisco Unified 
Communications Manager, which it does using Cisco Unified Communications Manager TSP. 
Consequently, before you install Cisco Unified Attendant Console Standard you must first perform the 
following steps: 

1. Depending on the version of Cisco Unified Communications Manager you are using, either: 

– Creating a User Group (CUCM 7.x and 8.x), page 2-5 – instructions for users of Cisco Unified 
Communications Manager 7.x or 8.x. 

– Creating an Access Control Group (CUCM 9.x and 10.x), page 2-6 – instructions for users of 
Cisco Unified Communications Manager 9.x, 10.0(1) or 10.5(1). 

2. Assigning Roles to a User Group or Access Control Group, page 2-6

3. Creating and Assigning an Application User, page 2-7. 

4. End User Account Required For Presence, page 2-8. 

Creating a User Group (CUCM 7.x and 8.x) 
If you are using Cisco Unified Communications Manager 7.x or 8.x you must create a User Group. If 
you are using Cisco Unified Communications Manager 9.x, 10.0(1) or 10.5(1) you must create an Access 
Control Group, as described in Creating an Access Control Group (CUCM 9.x and 10.x), page 2-6. 

User groups define the roles and permissions available to the Application Users who are members of that 
group. 

To create a User Group, do the following:

Step 1 Use your internet browser to access Cisco Unified CM Administration, and then log in. 

Step 2 In the main menu, choose User Management > User Groups. 

Step 3 Click Add New to create a new User Group.

Step 4 Type a Name for the new User Group.

8.5(1) 2 Supported Supported Not supported Not supported 

8.6(1) Supported Supported Not supported Not supported 

8.6(2) Supported Supported Not supported Not supported 

9.0(1) Supported Supported Not supported Not supported 

9.1(1) Supported Supported Not supported Not supported 

9.1(2) Supported Supported Not supported Not supported 

10.0(1) Supported Supported Supported Not supported 

10.5(1) Supported Supported Supported Supported

1. CUP 7.1(5) not supported. 

2. CUCM 8.5(1) supported on SU1 and above. 

CUCM 
Version 

Windows Vista 
32-bit and Wow64

Windows 7 
32-bit and WoW64

Windows 8 
32-bit and WoW64

Windows 8.1 
32-bit and WoW64
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Step 5 Click Save to save the User Group.

Step 6 Assign roles to the user group, as described in Assigning Roles to a User Group or Access Control 
Group, page 2-6.

Creating an Access Control Group (CUCM 9.x and 10.x) 
If you are using Cisco Unified Communications Manager 9.x, 10.0(1) or 10.5(1) you must create an 
Access Control Group. If you are using Cisco Unified Communications Manager 7.x or 8.x you must 
create a User Group, as described in Creating a User Group (CUCM 7.x and 8.x), page 2-5. 

Access Control Groups define the roles and permissions available to the Application Users who are 
members of that group. 

To create an Access Control Group, do the following: 

Step 1 Use your internet browser to access Cisco Unified CM Administration, and then log in.

Step 2 In the main menu, choose User Management > User Settings > Access Control Group.

Step 3 Click Add New to create a new Access Control Group.

Step 4 Type a Name for the new Access Control Group.

Step 5 Click Save to save the Access Control Group.

Step 6 Assign roles to the user group, as described in Assigning Roles to a User Group or Access Control 
Group, page 2-6. 

Assigning Roles to a User Group or Access Control Group
Roles define what the members (Application Users) of a User Group or Access Control Group can do. 

To add the roles to a User Group or Access Control Group required to enable Cisco Unified Attendant 
Console Standard to work properly, do the following:

Step 1 On the Find and List User Groups page, Find the User Group/Access Control Group you just created. 

Step 2 In the Search Results, click Roles for the User Group/Access Control Group. 

Step 3 Click Assign Role to Group.

The roles that can be assigned are listed. 

Step 4 Select the following roles: 

• Standard AXL API Access 

• Standard CTI Allow Calling Number Modification 

• Standard CTI Allow Call Park Monitoring 

• Standard CTI Allow Control of All Devices 

• Standard CTI Allow Reception of SRTP Key Material 

• Standard CTI Enabled 
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Step 5 If you are using phone models 69xx, 7931, 7965, 89xx and 99xx, you must also select: 

• Standard CTI Allow Control of Phones supporting Connected Xfer and conf 

• Standard CTI Allow Control of Phones supporting Rollover Mode 

Step 6 Click Add Selected to assign the roles.

Step 7 Click Save. 

Creating and Assigning an Application User 
An Application User connects Cisco Unified Attendant Console Standard to the Cisco Unified 
Communications Manager using Cisco TSP and AXL. 

• One operator requires a single Application User with all required devices assigned to it. 

• Multiple operators using the same devices require a single Application User with all devices 
required by all operators assigned to it. 

• Multiple operators using different devices require multiple Application Users, each with the 
required devices assigned to it. Operators requiring identical devices can use a single Application 
User. 

To create an Application User and then assign it to the User Group (CUCM 7.x or 8.x) or Access Control 
Group (CUCM 9.x or 10.x), do the following: 

Step 1 Use your internet browser to access Cisco Unified CM Administration, and then log in. 

Step 2 In the main menu, choose User Management > Application User. 

Step 3 Click Add New.

Step 4 Enter information in the following fields:

• User ID (a name of your choice)

• Password 

• Confirm Password (this must match the Password)

Step 5 Depending on the version of Cisco Unified Communications Manager you are connecting to, do one of 
the following:

• If you are installing against Cisco Unified Communications Manager 7.x or 8.x, scroll down to the 
Permissions Information section and click Add to User Group. 

• If you are installing against Cisco Unified Communications Manager 9.x or 10.x, scroll down to the 
Permissions Information section and click Add to Access Control Group. 

Step 6 Click Save to save the Application User.

Assigning Devices to Application Users to Enable Directory BLF 
To be able to see your contacts’ line state in the directory you must assign their devices to be controlled 
by the relevant Application User. 

To assign controlled devices to an Application User, do the following: 
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Step 1 Use your internet browser to access Cisco Unified CM Administration, and then log in. 

Step 2 In the main menu, choose User Management > Application User. 

Step 3 Find and then select your Application User. 

The Application User Configuration page appears. 

Step 4 Under Device Information, select the relevant Available Devices and then add them to the Controlled 
Devices list. To add many devices you will probably find it easier to click Find more Phones, and then 
find, select and Add the devices using the dialog box displayed. 

Step 5 Click Save. 

End User Account Required For Presence 
The presence facility within Cisco Unified Attendant Console Standard requires that each Attendant has 
an End User Account with Presence enabled on the Cisco Unified Communication Manager, so that 
Cisco Unified Attendant Console Standard can communicate with the Cisco Unified Presence (CUP) 
server. The User ID defined in the CUCM End User profile is used to obtain the presence information 
for a contact. 

In most cases the Attendants will already have an End User Account on the Cisco Unified 
Communication Manager. If they do not, ask your telephony system manager to set them up for you. 

Installing or Upgrading Cisco Unified Attendant Console 
Standard 

These instructions apply to both installing Cisco Unified Attendant Console Standard from scratch and 
upgrading your installation. When you upgrade your software the installation Wizard offers you details 
of your current installation, which you can accept or change, as required. You do not need to uninstall 
the old version before installing the new software. 

Cisco Unified Attendant Console Standard requires .NET framework 4 to run. If .NET framework 4 has 
not been supplied or configured before installation, the installation wizard installs and configures it for 
you. 

Note To be able to install the software you must have administrator rights. 

To install Cisco Unified Attendant Console Standard, do the following: 

Step 1 Browse to the installation location and run CUACS_Setup.exe. 

The installation wizard appears.

Step 2 In the Welcome page, click Next. 

Step 3 In the Cisco Unified Communications Manager Connection Details page, type the following: 

• The Cisco Unified Communications Manager Host Name, Fully Qualified Domain Name 
(FQDN) or IP address 
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• The Cisco Unified Communications Manager Application User ID to use 

• The Password that corresponds with the Cisco Unified Communications Manager User ID. 

and then click Next. 

If you are upgrading your Cisco Unified Attendant Console Standard software, this page will contain 
your current details. 

Note The following: 

• Port 443 is used by default. You can change the Cisco Unified Communications Manager 
configuration after you have installed Cisco Unified Attendant Console Standard. For instructions, 
see Connecting to a Different Cisco Unified Communications Manager, page 4-4. 

• Connecting to the Cisco Unified Communications Manager also populates the Primary CTI 
Manager. If you want to use a different node as the Primary CTI Manager, you can do this through 
the Cisco TSP configuration after installing Cisco Unified Attendant Console Standard. 

Step 4 In the two Security Alert messages, click Yes. 

Note During installation the Cisco Unified Communications Manager TSP appropriate to the Cisco Unified 
Communications Manager you intend to use is downloaded. If you intend to use Cisco Unified 
Communications Manager release 8.0(1) or later, the TSP is also automatically installed. If you intend 
to use Cisco Unified Communications Manager release 7.1(5) you must manually install the compatible 
Cisco TSP, as described in Installing and Configuring the Cisco TSP for Cisco Unified Communications 
Manager 7.x, page 2-10. 

Step 5 In the Language Information page, select the language you want to use, and then click Next. 

If you are upgrading your Cisco Unified Attendant Console Standard software, this page will contain 
your current details. 

Step 6 In the Cisco Unified Presence Server Connection Information page, type the following: 

• The Server Address or URL required for hosted presence. 

• The Domain containing the server 

• The Cisco Unified Presence User Name to use 

• The Cisco Unified Presence Password appropriate to the User Name 

and then click Next. 

If you are upgrading your Cisco Unified Attendant Console Standard software, this page will contain 
your current details. 

Note Port 5222 is used by default. You can change the Presence configuration after you have installed Cisco 
Unified Attendant Console Standard. For instructions, see Connecting to a Different Presence Server, 
page 4-3. 

Step 7 In the Choose Destination Location page, either accept the default folder (recommended) or Browse to 
the folder in which to install the application, and then click Next. 

Step 8 In the Start Copying Files page, if the details are correct, click Next. If not, click Back and correct the 
information. 
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Cisco Unified Attendant Console Standard is installed. 

Step 9 In the InstallShield Wizard Complete page, select Yes, I want to restart my computer now, and then 
click Finish. 

Installing and Configuring the Cisco TSP for Cisco Unified 
Communications Manager 7.x

The Cisco TAPI (or Telephony) Service Provider (TSP) enables Cisco Unified Attendant Console 
Standard to communicate with the Cisco Unified Communications Manager CTI Manager service, which 
provides call control. 

Cisco Unified Attendant Console Standard installation also automatically installs the Cisco TSP 
appropriate to your Cisco Unified Communications Manager—unless you are using Cisco Unified 
Communications Manager Release 7.x, in which case you must manually install the Cisco TSP for that 
release. 

This appendix describes the following steps: 

1. Downloading and Installing the TSP. 

2. Configuring the TSP, page 2-11. 

3. Installing the Cisco TAPI Wave Driver, page 2-11. 

If you need to uninstall the Cisco TSP, follow the instructions in the file C:\Program 
Files\Cisco\CiscoTSP.txt, which is created when the TSP is installed. This file also includes instructions 
for installing the Cisco TAPI Wave driver. 

Downloading and Installing the TSP 
To download and install the Cisco TSP, do the following: 

Step 1 Use your internet browser to access Cisco Unified Communications Manager Administration, and then 
choose Application > Plug ins. 

Step 2 Find the Cisco Telephony Service Provider using the search field (Figure 2-1).

Figure 2-1 Find and List Plugins Search Options 

Step 3 In the Search Results, click Download on the Cisco Telephony Service Provider line.

Step 4 Save CiscoTSP.exe on your desktop.

Step 5 Double-click the CiscoTSP.exe icon on your desktop and follow the instructions. 

Step 6 During installation, you are asked if you want to install multiple instances of TSP; click No.
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Step 7 After a successful installation, restart your system for the changes to take effect. 

.

Configuring the TSP
To configure TSP, do the following: 

Step 1 Click the Start button, and then in the Start menu, choose Settings > Control Panel > Phone and 
Modem Options. 

Step 2 Select the Advanced tab.

Step 3 Select CiscoTSP001.tsp. 

Step 4 Click Configure, and then select the User tab. 

Step 5 In User Name, type the User ID of the Cisco Unified Communications Manager Application User 
created in Configuring Cisco Unified Communications Manager, page 2-5. 

Step 6 Type the Password, and then again in Verify Password. 

Step 7 Select the CTI Manager tab.

Step 8 Under Primary CTI Manager Location, select and then type either the IP Address or Host Name of 
the CTI Manager to connect to. If a second CTI Manager is available, you can optionally specify a 
Backup CTI Manager Location. 

Note The CTI Manager service runs on each CUCM node in a cluster. Your primary CTI Manager should be 
on the Cisco Unified Communications Manager publisher, and your backup CTI Manager on the 
subscriber. 

Step 9 Select the Wave tab. 

Step 10 Type the Desired number of possible Automated Voice lines. Specify sufficient to allow all your CTI 
Ports to be monitored by this TSP. You can specify a larger number to cater for future expansion. To 
change the number in the future, you will have to uninstall and reinstall the Cisco TAPI Wave driver. 

Step 11 Click OK. 

Step 12 Select the Advanced tab. 

Step 13 In Provider Open Completed Timeout (secs), type 300. 

Step 14 Click OK. 

Step 15 Reboot the machine. 

You now need to install the Cisco TAPI Wave driver. 

Installing the Cisco TAPI Wave Driver 
To install the Cisco TAPI Wave driver, do the following, or the equivalent for your operating system: 

Step 1 In Control Panel, double-click Add/Remove Hardware. 

Step 2 In the Add Hardware wizard, click Next. 
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Step 3 Select Yes, I have already connected the hardware.

Step 4 Select Add a New Hardware Device, and then click Next. 

Step 5 Select Install the hardware that I manually select from a list, and then click Next. 

Step 6 From the list of hardware types, select Sound, video and game controller, and then click Next. 

Step 7 When prompted to select the device driver, click Have Disk. 

Step 8 In the Install From Disk dialog box, Browse to C:\Program Files\Cisco Systems\Wave Drivers, select 
the file oemsetup.inf, and then click Open 

Step 9 Click OK.

Step 10 In the Select a Device Driver page, select the Cisco TAPI Wave Driver, and then click Next. 

Step 11 In the Start Hardware Installation page, click Next.

Step 12 If prompted for Digital signature Not Found, click Continue Anyway.

Step 13 If prompted The file avaudio32.dll on Windows NT Setup Disk #1 is needed, browse to C:\Program 
Files\Cisco\Wave Drivers, and then click OK. 

Step 14 Click Yes. 

Step 15 Click Finish. 

Step 16 When prompted, click Yes to restart your computer. 

Licensing Cisco Unified Attendant Console Standard 
This section describes how to license your Cisco Unified Attendant Console Standard software under 
these scenarios: 

• Installing Cisco Unified Attendant Console Standard from scratch. For more information, see 
Licensing New Installations, page 2-12. 

• Upgrading an existing Cisco Unified Attendant Console Department Edition installation to Cisco 
Unified Attendant Console Standard. For more information, see Licensing CUAC Department 
Edition Upgrades, page 2-14. 

Note You do not need to relicense Cisco Unified Attendant Console Standard version upgrades. 

This section also describes: 

• Activating Purchased or Upgraded Software, page 2-15 

• Relicensing Software, page 2-17 

Licensing New Installations 
When you install Cisco Unified Attendant Console Standard onto a new system (not an upgrade) you 
may need to use the following procedures: 

• Activating Evaluation Software 

• Activating Purchased or Upgraded Software, page 2-15 
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Activating Evaluation Software 

You can use downloaded software for 10 days before you must license it. Licensing the software enables 
you to activate the software for 60 more days of evaluation. If you do not activate the download, you will 
be unable to use it after the tenth day. 

To activate the evaluation software, do the following: 

Step 1 Sign in to each instance of Cisco Unified Attendant Console Standard that you want to license and 
activate, and then do the following:

a. Choose Help > About Cisco Unified Attendant Console Standard. 

b. In the information box, click Register. 

c. Note the Machine Code. This is the registration code for that instance. 

Tip Keep these codes safe, as you require them to activate the 60 evaluation period and to license purchased 
software. 

Step 2 Use your internet browser to go the Cisco Unified Attendant Console Downloads and Licensing website. 

Step 3 Enter your User Name and Password, and then click Log In. 

Step 4 In the navigation bar, click ACTIVATE EVALUATION SOFTWARE. 

Step 5 Select your Reseller, then select your Customer, and then select your Customer Site. 

Note If your reseller, customer or site are not available, choose the options to add them. 

Step 6 Select the Version and the Product that you have installed, and then click Next.

Step 7 Enter the Registration Codes collected in Step 1, and then click Next. 

Note Click  to create new fields for additional codes. 

Step 8 Enter any additional email addresses to receive the registration file, and then click Submit. 

If the registration codes are valid, a registration (.RGF) file is e-mailed to you. The .RGF file contains 
activation keys and serial numbers for the 60 day evaluation period. The .RGF file can hold licensing 
information for multiple instances, but each license needs to be individually applied. 

Step 9 Open the email and save the .RGF file to a location that can be browsed by Cisco Unified Attendant 
Console Standard. 

Step 10 In Cisco Unified Attendant Console Standard, do one of the following:

• In the main menu, choose Help > About Cisco Unified Attendant Console Standard. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

Step 11 In the message box, click Register. 

Step 12 In the License dialog box, either:

a. Select File Registration. 

b. Type the name of or browse to the .RGF file. 
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c. Click Validate. 

or – if you know details of the license for the specific instance you are licensing 

a. Select Key Registration. 

b. Type an activation key Serial Number, which is included with the license in the .RGF file.

c. Type the corresponding Registration Code. 

d. Click Register. 

Arc Solutions Software Procurement ADMINISTRATION web site

Licensing CUAC Department Edition Upgrades 
If you have an upgrade agreement, you can upgrade any Cisco Unified Attendant Console Department 
Edition (version 8.x or 9.x) installations to Cisco Unified Attendant Console Standard. To do so, you 
need to obtain the necessary number of Cisco Unified Communications Software Subscription (UCSS) 
licenses: one per instance. 

If you have the necessary rights, you can obtain the licenses through the S+ Admin Website, where you 
can generate licenses one at a time or in groups. 

Generating Single Licenses 

To generate a single license: 

Step 1 User your internet browser to go to the Arc Solutions Software Procurement ADMINISTRATION web site 
and choose Licenses > Generate License. 

Step 2 In Product Family, select Cisco Unified Attendant Console Standard. 

Step 3 In Product Name, select Console Selection - CUACS. 

Step 4 In Version, select 10.x. 

Step 5 In License Type, select UCSS. 

Step 6 Click Add, and then type the license order details: 

• Sale Order Number (mandatory) 

• Note 

• Ship Set 

• Line 

• Unit Number 

Step 7 Click Generate Single License. 

The License Code (LAC) is displayed. 

Step 8 Save the LAC for future use. 
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Generating Bulk Licenses 

To generate a group of licenses: 

Step 1 Use your internet browser to go to the Arc Solutions Software Procurement ADMINISTRATION web site 
and choose Licenses > Bulk Generate. 

Step 2 In Product Family, select Cisco Unified Attendant Console Standard. 

Step 3 In Product Name, select Console Selection - CUACS. 

Step 4 In Version, select 10.x. 

Step 5 In License Type, select UCSS. 

Step 6 Type the Number of License Codes to create (one per instance of Cisco Unified Attendant Console 
Standard). 

Step 7 In File Format, select Excel Workbook (.xls). 

Step 8 When prompted open or save the XLS file. 

Activating Purchased or Upgraded Software 
You can purchase the software at any time in the evaluation period, giving you unlimited use. When you 
purchase the software Cisco provides you with a 27-digit license activation code (LAC) for each instance 
of the application you have purchased. After activating the software, you cannot revert to the trial 
version. If you upgrade your software from  Cisco Unified Attendant Console Department Edition, you 
must activate it before you can use it. 

Note When you upgrade using UCSS licenses you can convert Cisco Unified Attendant Console Department 
Edition license instances into the same number of Cisco Unified Attendant Console Standard instances. 
You can upgrade either: 

• All the Cisco Unified Attendant Console Department Edition seats into Cisco Unified Attendant 
Console Standard at once. 

• Some of the Cisco Unified Attendant Console Department Edition seats and then upgrade the 
remainder later. 

For example, if you had a Cisco Unified Attendant Console Department Edition LAC with 10 seats, you 
can either activate all 10 LAC codes at once to obtain 10 Cisco Unified Attendant Console Standard 
licenses, or you can, say, obtain 5 Cisco Unified Attendant Console Standard licenses today and the 
remainder later. Once you have generated at least one license against the Cisco Unified Attendant 
Console Department Edition LAC, it becomes disabled and can't be reset. 

To activate your purchased or upgraded software, do the following: 

Step 1 Use your internet browser to go the Cisco Unified Attendant Console Downloads and Licensing website. 

Step 2 Enter your User Name and Password, and then click Log In.

Step 3 In the navigation bar, click ACTIVATE PURCHASED SOFTWARE. 
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Step 4 Select your Reseller, then select your Customer, and then select your Customer Site. 

Note If your reseller, customer or site are not available, click the control to add them. 

Step 5 Select the Version and the Product (CUAC Standard Edition) that you have installed, and then click 
Next. 

Step 6 Enter a unique Registration Code (one of the machine codes collected on page 2-13) and License 
Activation Code pair for each instance, and then click Next. 

Note Click  to create new fields for any additional pairs of codes. 

Step 7 If all the License Activation Codes are UCSS codes for Cisco Unified Attendant Console Standard, enter 
details of the previously used Cisco Unified Attendant Console Department Edition Registration Code 
and License Activation Code pairs that you wish to upgrade to Cisco Unified Attendant Console 
Standard. 

Step 8 In the License Request Confirmation page, optionally enter an additional e-mail address and click 
Submit. If you want to change the codes you entered in Step 6 before proceeding, click Back. 

A registration (.RGF) file is e-mailed to you, and license request confirmation information is displayed 
in the web page. 

Step 9 Open the email and save the registration file to a location that can be browsed by Cisco Unified Attendant 
Console Standard. 

Step 10 In Cisco Unified Attendant Console Standard, do one of the following:

• In the main menu, choose Help > About Cisco Unified Attendant Console Standard. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

Step 11 In the message box, click Register. 

Step 12 In the License dialog box, either:

a. Select File Registration. 

b. Type the name of or browse to the .RGF file. 

c. Click Validate. 

or – if you know details of the license for the specific instance you are licensing 

a. Select Key Registration. 

b. Type an activation key Serial Number, which is included with the license in the .RGF file. 

c. Type the corresponding Registration Code. 

d. Click Register. 

Resetting License Codes 
The registration codes you gather when activating software incorporate information about the system 
that will be running Cisco Unified Attendant Console Standard. If the system changes - for example, 
because it has been rebuilt - the parameters will change and the corresponding LACs will no longer work. 
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You can reset (recreate) LACs to work on new systems in the following way: 

Step 1 Use your internet browser to go to the Arc Solutions Software Procurement ADMINISTRATION web site 
and choose License Management. 

Step 2 Click Verify and Reset LAC. 

Step 3 Search for Cisco Unified Attendant Console Standard LAC details using the LAC Code, or look up the 
LAC using one of the following: 

• Cisco SO Number 

• Registration Code

• User Name 

• Email Address 

The Cisco Unified Attendant Console Standard LAC detail is displayed. 

Step 4 If the LAC has been activated (used), select it and then reset it. 

Relicensing Software 
If you do any of the following you must re-license the software with a new registration code:

• Reinstall the operating system on the same hardware 

• Install a different operating system on the same hardware 

• Add or remove certain hardware (such as an NIC card) 

• Change the machine name 

• Perform a major upgrade of the Cisco Unified Attendant Console Standard software 

And within a VM Environment: 

• Copy the VM image 

• Perform a major upgrade of the Cisco Unified Attendant Console Standard software 

All these cause the license to expire, and the System and User Configuration menus to disappear from 
Cisco Unified Attendant Admin. 

To re-license Cisco Unified Attendant Console Standard, contact Cisco TAC and request a re-host. You 
will need to provide them with either the original license activation codes or the SO number of your 
purchase. 
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Standard 

To start the Cisco Unified Attendant Console Standard client, do the following: 

Step 1 Double-click the desktop icon. 

In the Sign In screen, beneath the banner, a field contains either: 

• The extension number of the attendant phone last used to sign in 

• The text, Extension 

Step 2 To use an existing number, proceed to Step 5. 

Step 3 To use a new extension number, type the number. 

As you type, the application lists those devices available for signing in that match the number (for more 
information on defining devices, see Managing Sign In Devices, page 4-6). The more you type, the 
shorter the list becomes. The list contains the name and extension number for each matching device. 

Note If the Device List under the File > Options > Device List tab is empty, all devices associated with the 
application user are available for signing in to Cisco Unified Attendant Console Standard. For more 
information, see Assigning Devices to Application Users to Enable Directory BLF, page 2-7. 

If the Device List contains one or more devices, you can sign in using one of them. If all the devices in 
the Device List are invalid, you will be unable to sign in without the assistance of a system administrator, 
as described in Accessing Cisco Unified Attendant Console Standard When There Are No Valid Devices, 
page 3-2. 

Step 4 To select a number, highlight it in the list and either press Enter or double-click it. You can close the list 
and clear the selection by pressing Esc. 

Step 5 If the sign in extension is part of one or more hunt groups, and you want the application to log you into 
them during sign in, select Log in to hunt groups at sign in. 

Note The following: 

• If you are already logged into your hunt groups, you do not need to set Log in to hunt groups at 
sign in. 

• You cannot log in to a hunt group using an extension that is already being used by another Cisco 
Unified Attendant Console Standard user. 
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• You can also log in or out of hunt groups as described in Logging In to Hunt groups, page 3-3 and 
Logging Out of Hunt groups, page 3-3. 

Step 6 Click Sign In or press Enter. 

The number you are trying to sign in with is checked against the list of valid extensions. 

Step 7 Depending on the devices available, you may need to do one of the following

• If there are no valid devices a message is displayed requesting that you contact your system 
administrator, who will create a valid device following the procedure in Accessing Cisco Unified 
Attendant Console Standard When There Are No Valid Devices. 

• If several valid devices have the same extension number, or if one or more valid devices has multiple 
lines, a list of the devices and lines is displayed. Select the device and line to use, and then click OK. 

The main application user interface appears, ready for you to use. 

If there was no device list and you entered the extension number of a valid Cisco device, that device and 
all its lines is added to the device list. 

While the application is running, you can change the attendant console operator directory number and 
whether it is remembered. 

Accessing Cisco Unified Attendant Console Standard When 
There Are No Valid Devices 

If there are no valid devices in the Device List, the system administrator must create at least one - or 
completely clear the Device List - so that the application can be used. 

To access Cisco Unified Attendant Console Standard when no valid device is available, the system 
administrator should do the following:

Step 1 In the Sign In screen invalid extension message, click Administrative Override. 

Step 2 Do one of the following: 

• When an Options Password has not been set, the Options window appears, with the Device List tab 
displayed. 

Add one or more new devices, as described in Manually Adding Sign In Devices, page 4-7, or clear 
all the devices from the list. 

• When an Options Password has been set, the Options window appears, with the Options Password 
tab displayed. 

a. Make the Device List tab accessible as described in Making Options Tabs Accessible, page 4-2. 

b. Add one or more new devices, as described in Manually Adding Sign In Devices, page 4-7, or 
clear all the devices from the list. 

Step 3 Close the Options window.

The Sign In screen appears and the operator can use a new device to sign in. 
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Signing Out 
To sign out from your current attendant console session, do either of the following:

• In the main menu, click the extension number at the top right of the interface, and then select Sign 
out of application. 

• Use the Ctrl+S keyboard shortcut. 

The sign in screen is displayed, and the application continues to run and any synchronization currently 
in progress continues. When you sign out you are automatically logged out of any hunt groups to which 
you belong. 

To resume using the application, sign in as before. 

Logging In to Hunt groups 
A hunt group is a group of extensions configured so that an unanswered call to any extension gets 
forwarded to one of the other lines in the group. Cisco Unified Communications Manager supports hunt 
groups, and Cisco Unified Attendant Console Standard enables you to sign in using a device that is part 
of one or more hunt groups, so that calls to the groups can be received through your operator phone. 

If you are logged out from any hunt groups you will not receive any calls through the groups. 

If you are not logged in to the hunt groups of which your extension is part, you can either log in to them 
when you sign in to the application (as described on page 3-1), or you can click the extension number at 
the top right of the interface, and then select Log in to hunt groups. 

While you are logging in to the hunt group (which may take a few seconds) you will not be able to receive 
any new calls, but current calls will continue unaffected, and you will be logged in at the end of the 
current call. 

Logging Out of Hunt groups 
If you are logged in to a hunt group, to log out do either of the following: 

• Click the extension number at the top right of the interface, and then select Log out of hunt groups.

• User the Ctrl+I keyboard shortcut. 

Also, when you sign out you are automatically logged out of any hunt groups to which you belong. 

While you are logging out you cannot take calls, but current calls will continue unaffected. You will be 
logged out at the end of the current call. 

Exiting Cisco Unified Attendant Console Standard 
To exit Cisco Unified Attendant Console Standard, do one of the following: 

• In the main menu, choose File > Exit. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

• Click the window close button. 
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Configuring Cisco Unified Attendant Console 
Standard 

This chapter describes how to configure Cisco Unified Attendant Console Standard. 

All the configuration functions are contained within tabbed pages of the Options window, which you 
access by choosing File > Options. You can password-protect the following Options tabs: 

• Directory Filters 

• Directory Mappings 

• BLF Rules 

• Device List 

• Logging 

Enabling password protection is described in Preventing Access To Options Tabs, page 4-2; disabling it 
is described in Making Options Tabs Accessible, page 4-2. 

This chapter also describes the following configuration procedures: 

• “Setting Operator Details” on page 4-3 

• “Connecting to a Different Presence Server” on page 4-3 

• “Connecting to a Different Cisco Unified Communications Manager” on page 4-4 

• “Setting the Operator Voicemail Prefix” on page 4-5 

• “Configuring Alerts” on page 4-5 

• “Managing Sign In Devices” on page 4-6 

For details of configuring synchronization with Cisco Unified Communications Manager, see 
Configuring Synchronization, page 5-4. 

For details of moving, stretching and hiding parts of the interface, see the Cisco Unified Attendant 
Console Standard online Help. 
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Preventing Access To Options Tabs 
In the application’s default state, all the Options tabs are accessible by any user. You can use the Options 
Password to prevent access to the password-protected Options tabs listed on page 4-1. 

To prevent access to the password-protected Options tabs: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Step 2 Click the Options Password tab. 

Step 3 Select Password Protection. 

Step 4 Type the Application Password (the Cisco Unified Communications Manager application user 
password specified in the Configuration tab, as described in Connecting to a Different Cisco Unified 
Communications Manager, page 4-4). 

Step 5 Click Apply. 

Step 6 Click Cancel to close the Options window. 

The password-protected Options tabs are now inaccessible. 

Making Options Tabs Accessible 
You can regain access to the Options tabs listed on page 4-1 by entering the correct Options Password. 

To regain access to the password-protected Options tabs: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Step 2 Click the Options Password tab. 

Step 3 Type the Application Password (the Cisco Unified Communications Manager application user 
password specified in the Configuration tab, as described in Connecting to a Different Cisco Unified 
Communications Manager, page 4-4). 

Step 4 Click Authenticate. 

If you have entered the password incorrectly, the Application Password field is highlighted, otherwise 
the Password Protection and Application Password controls appear. 

You now have temporary access to the password-protected Options tabs, and you can make and apply 
changes to their settings. To keep the Options tabs password-protected after you finish modifying the 
settings, click Cancel to close the Options window, and then skip the rest of this procedure. 

Step 5 Clear Password Protection. 

Step 6 Type the Application Password. 

Step 7 Click Apply. 

Step 8 Click Cancel to close the Options window. 
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Password protection is disabled and all the Options tabs are now accessible. 

Note If you forget the Options Password, you can either:

• Change the password of the existing Cisco Unified Communications Manager application user

• Create a new application user with a new password

and then validate the credentials under the Configuration tab, and enter the new password under the 
Options Password tab. 

Setting Operator Details 
You set your operator details either when you start Cisco Unified Attendant Console Standard or while 
it is running. 

To set the operator details while Cisco Unified Attendant Console Standard is running, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Operator Details tab. 

Step 3 Under Operator Details, type the Extension of the attendant console operator. 

Note If a Device List is defined (see “Managing Sign In Devices” on page 4-6), the same restrictions as on the 
sign in extension apply, but the list is not displayed when you start typing. 

Step 4 Click Apply. 

Connecting to a Different Presence Server 
Once Cisco Unified Attendant Console Standard is installed, you can connect to a different Presence 
Server than the one you specified during installation. The Presence Server provides the presence status 
of directory contacts; you need to have a valid User and Password to communicate with the server. 

To connect to a different Presence Server, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 
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Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Operator Details tab. 

Step 3 Under Presence Details, edit the following as required: 

• The Presence Server Address or URL required for hosted presence. 

• The Presence Server Port number. By default, this is 5222. 

• The Domain containing the Presence Server 

• The Presence Server User name. 

• The Password that corresponds with the User name. 

Step 4 Click Apply. 

The application validates the connection. If this fails, it prompts you for the correct connection details. 

Step 5 Exit and then restart Cisco Unified Attendant Console Standard for the change to take effect. 

Connecting to a Different Cisco Unified Communications 
Manager 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

Once Cisco Unified Attendant Console Standard is installed, you can connect to a Cisco Unified 
Communications Manager different from the one you specified during installation, and so use a different 
source directory. However, the new Cisco Unified Communications Manager must be the same major 
revision as the one specified during installation; you cannot upgrade to a later revision using this method. 

To connect to a different Cisco Unified Communications Manager, do the following:

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Configuration tab. 

Step 3 Under Call Manager Detail, edit the following as required: 

• The Cisco Unified Communications Manager Server Address. 

• The Cisco Unified Communications Manager Port number. By default, this is 443. 

• The Cisco Unified Communications Manager Application Username. 

• The Application Password that corresponds with the Username. 
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Step 4 Click Apply. 

If the new CUCM version does not match the currently configured CUCM version a message appears. 

Step 5 Exit and then restart Cisco Unified Attendant Console Standard for the change to take effect. 

Setting the Operator Voicemail Prefix 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

If your operator uses a separate voicemail number, you define its prefix. 

To set the operator voicemail prefix, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Configuration tab. 

Step 3 Under Transfer to Voicemail Option, type the attendant console operator Voicemail Prefix. 

Step 4 Click Apply. 

Configuring Alerts 
Cisco Unified Attendant Console Standard alerts you when the following events occur (listed in order of 
precedence): 

1. Call is ended (not by console) 

2. Device is in service (the console device) 

3. Call is ringing at primary device 

4. Call is ringing at secondary device 

5. Device is out of service (the console device)

6. A system error has occurred 

If two or more alerts occur simultaneously, you are alerted about the one with the highest precedence. 

Cisco Unified Attendant Console Standard can produce the following visual alerts: 

• If the application is not the active window, it becomes the active window and is placed in front of 
any other open window, ready for you to interact with it. 
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• If the application is not the active window, then in the Windows taskbar the application icon flashes. 

Procedure 

To configure alerts, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Alerts tab. 

Step 3 Under Alerts Detail, for each event, do the following:

• Select the Taskbar check box if you want the application icon in the Windows taskbar to flash and 
be overlaid with an alert symbol when that event occurs. 

• Select the Pop-to-Front check box if you want the application window to be displayed in front of 
the other windows if minimized to the taskbar when the event occurs. 

Step 4 Click Apply. 

Managing Sign In Devices 
Attendants can only sign in to Cisco Unified Attendant Console Standard using a valid Cisco device, 
with a device name, extension and line number. For attendants to be able to make calls, the device must 
also be associated with the Application User/End user configured in the Cisco TSP.

System administrators define which devices are available for attendants to use; these devices constitute 
the Device List, which is accessible using File > Options > Device List. At start-up and during 
execution, the application checks whether the devices in the Device List are associated with the 
Application User/End User configured in the Cisco TSP. 

• If they are not, they are marked as invalid. These have a lighter color in the list, and attendants 
cannot make calls using them. 

• If they were previously marked as invalid, but are now associated with the Application/End user, 
they are marked as valid, and attendants can make calls using them. 

Administrators can either manually add devices to the list, or import them from CSV files. 

While importing sign in devices from a CSV file, the application checks that each device is associated 
with the Application/End User configured in the Cisco TSP. If a device is not associated, it is shown as 
invalid in the Device List. 

If additional lines are later associated with a sign in device (using Cisco Unified Communications 
Manager), they get added to the Device List. After these changes, attendants will still be able to sign in 
using the old extension. 
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Manually Adding Sign In Devices 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To manually add devices: 

Step 1 Choose File > Options > Device List. 

The Device List appears. 

Step 2 Under Device List, click Add Devices. 

Step 3 In Search Devices, type a device name. All devices matching what you type are listed; and the more 
characters you type, the shorter the list becomes. Non-Cisco devices are not listed. 

Step 4 For each device you want to add, select the Add checkbox. 

Note If there are multiple lines on the selected device, all the lines are selected and added to device list.

Step 5 Click Apply. 

The devices are added to the Device List. 

Importing Sign In Devices 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

You can import sign in devices from a CSV file with the format described in CSV Files for Importing 
Sign In Devices, page B-3. 

To import devices from a CSV file: 

Step 1 Choose File > Options > Device List. 

Step 2 Under Import From CSV, click Browse and select the file to import. 

The file name and path are displayed under File Location. 

Note If you click View Sample you can view the required format of the CSV file for importing login devices.

Step 3 Click Import Devices. 

The file format is validated, and if any devices in the file are non-Cisco, you are informed that they will 
no be imported, and then you are prompted to continue. To import the Cisco devices from the file, click 
Yes. To abort the process, click No. 



4-8
Cisco Unified Attendant Console Standard - User Guide

OL-25988-01

Chapter 4      Configuring Cisco Unified Attendant Console Standard
Managing Sign In Devices

The devices are imported and added to the Device List. As the devices are imported, they are checked 
against those already listed and any matching devices are ignored. 

Deleting Sign In Devices 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To remove devices: 

Step 1 Choose File > Options > Device List. 

In the Device List, click the corresponding X in the Delete column.

Note If a device has multiple lines, all are deleted from the list. The device remains in the database. 

Step 2 In the confirmation message, click Yes. 
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Cisco Unified Attendant Console Standard displays one or more directories of contacts. Always 
displayed is your corporate directory (shown in the interface as Directory), which is copied from one 
or more of the following sources: 

• Cisco Unified Communications Manager 

• A comma-separated-variable (CSV) file. CSV file names have the .csv extension. 

Note The CSV file can be on any shared network location to which Cisco Unified Attendant Console Standard 
has read and write access. However, it the file does not include a unique identifier (Primary Key) for each 
contact, it needs to be on the machine running Cisco Unified Attendant Console Standard. 

Cisco Unified Communications Manager is the usual source of your corporate directory. Up to date 
contact information is copied from the source into Cisco Unified Attendant Console Standard by the 
synchronization process. For a description of this, see Directory Synchronization, page 5-3. 

Directory Groups 

You can also view and connect to contacts that are not in your synchronized directory but which you 
want to be able to select quickly. These directory groups can contain any combination of the following: 

• Contacts imported (copied) from sources other than those listed above. These sources are either CSV 
files or Extensible Markup Language (XML) files. For more information, see Importing Contacts 
Into Directory Groups, page 5-12. 

• Contacts you enter yourself. For more information, see Manually Adding Contacts To Directory 
Groups, page 5-13. 

As well as importing contacts into directory groups, you can also export (copy) directory groups to CSV 
files, so that they can be used by other attendants or even in other applications. 

Note The format of CSV files imported/exported is different from that of CSV files used for synchronization.

You cannot amend contact records in the corporate directory. By contrast, directory groups are not 
updated by synchronization; and you can amend the contact details they contain. 

For more information, see “Directory Groups” on page 5-10. 
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The relationships between directories and external information is summarized below. 

Legend 

1. Cisco Unified Attendant Console Standard.

2. Corporate directory. 

3. Directory groups. 

4. Cisco Unified Communications Manager. 

5. CSV file for synchronization. For details of the format, see CSV File Formats, page B-2. 

6. CSV file for importing and exporting. For details of the format, see CSV File Formats, page B-2. 

7. XML file. 

8. Synchronize contacts. Includes applying Directory Filter, Directory Mapping Rules and BLF rules. 

9. Import contacts. 

10. Export contacts. 

11. Manually entered contact. 
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Directory Synchronization 
The process of copying contacts from your source directories into Cisco Unified Attendant Console 
Standard is known as synchronization, because the information in the source and internal directories is 
identical at the instant of copying. When synchronization occurs, the contacts from both the Cisco 
Unified Communications Manager and the CSV file (if you specify one) are copied into Cisco Unified 
Attendant Console Standard. The actual data that is displayed in your corporate directory depends not 
only on what is in your sources but also on any directory field mappings, directory filters or BLF rules 
you have configured. 

If synchronization detects that a contact it is copying is already in Cisco Unified Attendant Console 
Standard, it first validates the information (checks that it is correct) and then updates Cisco Unified 
Attendant Console Standard with any information that has changed since the last synchronization. If a 
synchronization fails mid-process – for example, because of a network failure – it starts again from the 
beginning. 

The synchronization process needs to know what contact data to copy from the source to your corporate 
directory, and it gets this information from directory field mappings; for more information, including 
how to set the mappings, see Directory Field Mappings, page 5-6. 

You can choose to copy only certain contacts to Cisco Unified Attendant Console Standard by applying 
a directory filter, this ensures that only those contacts that have the characteristics you specify in a series 
of directory rules are added to the corporate directory. For example, you can synchronize the contacts 
from only a specific department. For more information, see Directory Filtering, page 5-5. 

During synchronization you can modify the first part of your contact telephone numbers, so that the 
numbers in your corporate directory differ from those in your source directory. For example, you might 
have telephone number stored in Cisco Unified Communications Manager as 01189728567, but in the 
corporate directory you want to see it as 8567. You achieve this number conversion by creating BLF 
Rules, which are applied during synchronization. For more information, see BLF Rules, page 5-7. 

Note The following:

• The converted numbers must match the DNs monitored in TAPI, otherwise the line state will not be 
displayed in the directories. 

• These converted numbers are used by Cisco Unified Attendant Console Standard when it dials. If 
you set up BLF Rules, you also need to set up translations in Cisco Unified Communications 
Manager to convert the numbers in Cisco Unified Attendant Console Standard back to the originals, 
so that you can call those numbers. 

Directory synchronization takes place at regular intervals that you define; and you can configure Cisco 
Unified Attendant Console Standard to synchronize with the source directory when you start it (this is 
actually the default situation). For more information, see Configuring Synchronization, page 5-4. 
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Synchronizing From a CSV Source File 
When you synchronize from a CSV file, the file structure is first validated. For more information on valid 
CSV file formats, see CSV File Formats, page B-2. The first column of the CSV file must contain a 
unique identifier, known as a GUID, which identifies that contact as unique. If it does not, Cisco Unified 
Attendant Console Standard adds a first, GUID, column. 

If your CSV file does not have a GUID column, and you intend storing it in a shared location that does 
not have write access, then before you put it there, you should place it locally and provide read-write 
access so that Cisco Unified Attendant Console Standard can add the GUID column. 

Configuring Synchronization 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

When you install Cisco Unified Attendant Console Standard, a set of default synchronization parameters 
are created, which should work for your installation. However, you can change these parameters to the 
values you require. 

To configure synchronization, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Configuration tab. 

Step 3 Under Sync Detail, do the following:

a. To synchronize when the application starts, select the Auto Synch Startup check box. 

b. In Sync Interval (In Hours), type the interval in hours between automatic synchronizations. The 
default is zero. 

Step 4 If you do not want to specify a different Cisco Unified Communications Manager, skip this step. 
Otherwise, under Call Manager Detail, edit the following as required: 

• The Cisco Unified Communications Manager Server Address. 

• The Cisco Unified Communications Manager Port number. By default, this is 443. 

• The Cisco Unified Communications Manager Application Username. The application user must 
have the roles described in Assigning Roles to a User Group or Access Control Group, page 2-6. 

• The Application Password that corresponds with the Username. 

Step 5 If you do want to synchronize to a CSV file source, under CSV Detail, Browse to the File Location of 
your CSV source, and either type its name or select it, and then click OK. 

If you specify a CSV file source, the application synchronizes to both it and any specified Cisco Unified 
Communications Manager when you restart the application. 
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If you do not have a CSV source, click Clear to clear this field. 

To view a sample CSV file, click View Sample. 

Step 6 Click Apply. 

Directory Filtering 
A directory filter consists of a series of directory rules that are applied during synchronization to ensure 
that only certain contacts are copied to the corporate directory. 

Each directory rule can compare one of the following contact details to a text string:

• Department 

• Telephone 

• Location 

The rule makes the comparison according to one of the following conditions: 

• Begins with 

• Contains 

• Is exactly 

• Ends with 

So, for example, you might only want to copy contacts whose Department Is exactly Sales. This would, 
however, exclude anyone whose department is Sales America, for example. Or maybe you want to 
synchronize those contacts whose Department Ends with ing, which would copy the contacts from both 
Marketing and Engineering (and any other department ending in those letters). 

Directory filters can consist of any number of directory rules, combined using these logical operators:

• AND

• OR

So, for example, you might have a rule that synchronizes only those contacts whose Department Is 
exactly Sales AND their Location Ends with America, so that your corporate directory contains all the 
new world sales staff. When you use more than two rules, the AND operator has precedence over OR; 
so a rule with the structure X AND Y OR Z is equivalent to (X AND Y) OR Z. 

Creating Directory Filters 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To create a directory filter, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 
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Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Directory Filters tab. 

Step 3 Do the following, as many times as required until your filter is complete: 

a. If this is not the first rule in the filter, select the Link (Logical Operation) to apply between the 
previous rule and the one you are about to define. 

b. Select the contact Field to compare. 

c. Select the Condition to use in the comparison. 

d. In Value, type the text to compare with the Field. 

e. Click Add. 

Step 4 Click Apply to save the changes. 

Step 5 Restart the application to synchronize with your source. The filter is applied and only those contacts 
satisfying the filter are copied to the corporate directory. 

Directory Field Mappings 
Before you synchronize contacts into Cisco Unified Attendant Console Standard the application needs 
to know which contact data fields (source fields) to import from Cisco Unified Communications 
Manager or a CSV file, and what destination fields within the application to populate with the data. This 
is called defining the directory field mappings. 

You can specify separate directory field mappings for the data from your Cisco Unified Communications 
Manager and from a CSV file; so, for example, you could import your sales contacts from Cisco Unified 
Communications Manager, and your marketing contacts from a CSV file.

When you install Cisco Unified Attendant Console Standard default directory field mappings are defined 
for you. You can, however, change these mappings or define your own. How to do these is described in 
Setting Directory Field Mappings, page 5-7. 

Destination Fields 
Cisco Unified Attendant Console Standard supports the following contact destination fields: 

• Department 

• Directory URI 

• Email 

• First Name 

• Home Phone 

• Last Name 

• Location 

• Manager 

• Middle Name 
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• Mobile 

• Telephone (automatically mapped from source) 

• User Field 1 

• User Field 2 

Source Fields 
By default, Cisco Unified Attendant Console Standard has mappings set up for synchronizing contacts 
from Cisco Unified Communications Manager (CUCM) and CSV files. However, you may wish to 
change the default mappings, or define your own. 

Setting Directory Field Mappings 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To set the directory field mappings, do the following:

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Directory Mappings tab. 

Step 3 Select a Directory Source: CUCM or CSV. 

Step 4 Do the following, as required:

To add a mapping, select the Source Field, Destination Field, and then click Add. 

To delete a mapping, click the corresponding Delete symbol, and then in the confirmation message, click 
Yes. 

Step 5 Click Apply. 

The next time you synchronize with your source, the mappings are applied. 

BLF Rules 
BLF rules are applied during synchronization to convert directory numbers to a different format by 
searching for and replacing specific number prefixes. You can define sets of multiple rules to be applied 
one after the other during synchronization, and you can define different sets of rules for synchronizing 
from Cisco Unified Communications Manager and CSV files. 
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BLF rules are applied in the order they are listed in the BLF Rules List. For example, if the first rule 
modifies the number from 01189597895 to 8957, the next rule is applied to the modified number. By 
moving rules up or down in the list, you change the order in which they are applied.

Adding BLF Rules 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To add a BLF rule, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the BLF Rules tab. 

A list of all existing BLF rules is displayed. By default, no rules are defined. 

Step 3 Click New Rule. 

The BLF Rule Detail page appears. 

Step 4 Type a Rule Name. 

Step 5 In Begins With, type the digits to search for at the start of the number. 

Step 6 In Length, type the number of digits in the original contact number. 

Step 7 In Number of Digits to Remove, type the number of digits to remove from the start of the contact 
number. 

Step 8 In Prefix, type the string of digits to replace the ones removed. 

Step 9 If you want to remove non-digit characters (such as +) from the number, specify any not to remove by 
typing them (with no separators) in Ignorable Characters. 

Step 10 To remove non-numeric characters from the number – except any you specified in Ignorable 
Characters – select the Remove Non-digit Characters check box. 

Step 11 Select the Directory Source: CUCM or CSV. 

Step 12 You can test your rule by doing the following under Test BLF Rule: 

a. In Enter a number to test the Rule, type a number, and then click Run Test. 

b. Check that the number displayed in Test Results matches your expectations. If not revise the rule 
settings. 

Step 13 Click Apply. 
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Editing BLF Rules 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To edit an existing BLF rule, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the BLF Rules tab. 

A list of all existing BLF rules is displayed. 

Step 3 Select the rule to edit. 

Step 4 Click Edit Rule to display the BLF Rule Detail page. 

Step 5 Edit the fields, as required. These are described in Adding BLF Rules. 

Step 6 Test the rule, as required. 

Step 7 Click Apply. 

Deleting BLF Rules 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To delete a BLF rule, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the BLF Rules tab. 

A list of all existing BLF rules is displayed. 

Step 3 Select the rule to delete. 

Step 4 Click Delete Rule. 
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Step 5 Click Apply. 

Reordering BLF Rules 

Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

To change the order in which BLF rules are applied during synchronization, do the following: 

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the BLF Rules tab. 

A list of all BLF existing rules is displayed. 

Step 3 On each rule to move, do the following, as required: 

a. Select the rule. 

b. To move the rule towards the top of the list, click Move Up. 

c. To move the rule towards the bottom of the list, click Move Down. 

Step 4 Click Apply. 

Directory Groups 
Directory groups contains special contacts – including contacts not in your source directory – that you 
want to be able to select quickly. You must create your directory group before adding contacts to it. For 
details of how to do this, see Creating Directory Groups, page 5-10. 

You add contacts to directory groups by either of the following methods: 

• Importing contacts from CSV files or XML files, as described in Importing Contacts Into Directory 
Groups, page 5-12. 

• Manually creating contacts, see Manually Adding Contacts To Directory Groups, page 5-13. 

You can amend the name of a directory group, and the details of any contact in the group. You can also 
export the contacts from directory groups to CSV files, 

Creating Directory Groups 
You need to create directory groups before you can import data to them. 
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To create a directory group, do the following: 

Step 1 Do one of the following:

• Click the Add new directory group (+) control. 

• In the main menu, choose Edit > Add directory group. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

The New Directory Group dialog box appears. 

Step 2 Type a Directory Group Name, and then either click Save or press Enter. 

The directory group is added as a new tab in the directory display. 

Deleting Directory Groups 

Note You cannot delete directory groups while synchronization is in process. 

To delete a directory group, do one of the following: 

Step 1 Right-click the directory group tab. 

Step 2 Select Delete Directory Group. 

Step 3 In the confirmation message, click Yes.

or 

Step 1 Select the directory group, and then do one of the following: 

• In the main menu, choose Edit > Delete directory group. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

Renaming Directory Groups 
To rename a directory group, do the following: 

Step 1 Right-click the directory group tab. 

Step 2 Select Edit Directory Group. 

Step 3 In the dialog box, type the new group name, and then click Save. 
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or

Step 1 Do one of the following: 

• In the main menu, choose Edit > Edit directory group. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

Step 2 In the dialog box, type the new group name, and then click Save. 

Importing Contacts Into Directory Groups 
You can import contacts from the following types of file into an existing directory group.

• XML – for example, one previously exported from Cisco Attendant Console (CAC)

• CSV 

For details of the formats of these files, see Appendix B, “Import/Export File Formats”. 

Note The following points: 

• You cannot import contacts into a directory group while the application is synchronizing to the 
corporate directory. 

• When you import from these types of file, no checks are made to see if the contact information 
duplicates that in any directory group, including the one that you are importing the data into. 

At the start of the import process Cisco Unified Attendant Console Standard validates the file structure 
and format. If either is incorrect, you are alerted to the fact and the process is aborted. 

You can only import contacts into an existing directory group – either one that already contains contacts, 
or a new one created especially for the purpose. See Creating Directory Groups, page 5-10. 

To import contacts into a directory group, do one of the following: 

Step 1 Do one of the following: 

• In the main menu, choose File > Import contacts. 

or 

a. In the main menu, choose File > Options. 

b. In the Options window, click the Import/Export tab. 

or 

• Right-click in any directory group, and then select Import Contacts. 

or 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 
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Step 2 Under Import CSV/XML, do the following:

a. In File Name, click Browse and select the file to import. 

Note You cannot type a file name or edit the name of a selected file. 

b. Select the File Type. 

c. If the Directory Group to receive the contacts is not correct, select the correct one. 

d. Click Import Contacts. 

The import progress is displayed. 

Step 3 When the import is complete, close the dialog box. 

Manually Adding Contacts To Directory Groups 
You can manually add contacts to directory groups. 

Note You cannot manually add contacts to your corporate directory. 

To add a contact to the displayed directory group, do the following:

Step 1 Do one of the following: 

• Right-click the directory group contact listing, and then select Add Contact. 

• Select the directory group and do either of the following: 

– In the main menu, choose Edit > Contacts > Add contact. 

– Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

The Contact dialog box appears. 

Step 2 Type the contact information, which is described in Destination Fields, page 5-6. You can also enter a 
contact Note. 

Step 3 Click Save. 

Step 4 In the confirmation message, click OK. 

Step 5 When you have finished adding contacts, close the Contact dialog box. 

Alternatively, you can drag (copy) contacts from the corporate directory or another directory group, and 
then drop them into the target directory group. 

Note This creates a duplicate contact in the directory group. Take care not to create multiple duplicates. 

To drag contacts into a directory group: 



5-14
Cisco Unified Attendant Console Standard - User Guide

OL-25988-01

Chapter 5      Directories
Directory Groups

Step 1 Display the directory containing the contact to copy. 

Step 2 Select the contact and then, holding the mouse button, drag the contact over the appropriate directory 
group tab to list its contents.

Step 3 Drag the contact into the list, and then drop it. 

Deleting Contacts From Directory Groups 
You can delete contacts from directory groups. 

Note You cannot delete contacts from your corporate directory. 

To delete a contact from the displayed directory group, do the following: 

Step 1 Select the contact to delete. 

Step 2 Do one of the following:

• Right-click and then select Delete Contact. 

• In the main menu, choose Edit > Contacts > Delete contact. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

Step 3 In the confirmation message, click Yes. 

Editing Contacts In Directory Groups 
You can edit the information belonging to a contact in a directory group. 

Note You cannot edit contacts that have been synchronized into the corporate directory. 

To edit a contact in a directory group, do the following: 

Step 1 Open the relevant group and display the contact. 

Step 2 Do one of the following:

• Right-click the contact, and then select Edit Contact. 

• In the main menu, choose Edit > Contacts > Edit contact. 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2. 

The Contact dialog box appears. 

Step 3 Edit the contact information, which is described in Destination Fields, page 5-6. 
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Step 4 Click Save. 

Step 5 In the confirmation message, click OK. 

Exporting Contacts From Directory Groups 
You can export a directory group into a preexisting CSV file. 

To export a directory group, do the following: 

Step 1 Do one of the following: 

• In the main menu, choose File > Export contacts. 

or 

a. In the main menu, choose File > Options. 

b. In the Options window, click the Import/Export tab. 

or 

• Right-click in any directory group, and then select Export Contacts. 

or 

• Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard 
Shortcuts, page 6-2.

Step 2 Under Export CSV do the following: 

a. In File Name, click Browse and navigate to the target folder. 

b. Either type a file name (to create a new CSV file) or select an existing file to export to. If you select 
an existing file you are prompted to overwrite it; click Yes to overwrite the file. 

c. Select the Directory Group to export. 

d. Click Export Contacts. 

The export progress is displayed. 
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Viewing and Using Directories 
The bottom part of the interface consists of the directories and their associated controls. For example: 

Legend

1. Search – type details of the contact to search for. 

2. Search Preferences – define which contact information to search.

3. Directory tabs – select the directory to display. Includes both corporate directory and directory 
groups. 

4. Create a new directory group. 

5. Column headings – identify the data and enable you to change the column order and the contact sort 
order. These are described below. 

6. (Visible only when viewing a directory group) Add contacts to the group. 

7. Phone state – the state of the contact’s phone, such as Ringing, On hook, and Do not disturb.

8. Presence state – this mimics a Jabber or CUPC client, where a symbol indicates the real-time status 
of the contact, such as Available, Do not disturb, and Away. All other contacts have their 
subscriptions opened only when displayed in the Directory pane.

The following columns of information are displayed for each contact: 

• Last Name – the contact’s last name. 

• First Name – the contact’s first name. 

• Telephone – the contact’s telephone number. 

• Department – the contact’s department. 

• Notes – about the contact. 

If the contact was imported or manually entered into Cisco Unified Attendant Console Standard you can 
edit this information. 

Changing the Directory View 
You can change the order of the columns by using your mouse to select a column heading and then 
dragging it to another place in the table. 
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When the data is first displayed it appears in its default order, as copied from the Call Manager. You can 
change the alphanumeric sort order of the table rows by clicking any column heading – the table will be 
sorted according to the data in that column. The small arrowhead at the top of the cell shows the direction 
in which the column is sorted: an up-arrow for ascending (normal alphanumeric) order, a down-arrow 
for descending (reverse) order, and no arrow for default order. Repeatedly clicking the column heading 
toggles you through these sort modes. 

Searching For Contacts 
You can search for contacts in any open directory (the corporate directory and any directory groups you 
are displaying). Details of matching contacts are shown under the Search Results directory tab. 

You can search any of the following contact detail fields:

• First Name 

• Last Name 

• Directory Number 

• Department 

You can disable the ability to search any of these fields by setting the Search Preferences. These are 
described in Search Preferences, page 5-17. 

You do not need to specify which field you want to search: the string you type in the Search field is 
matched against all of them. So, for example, if you have a Sales department, and a staff member with 
the last name Saunders, searching for the characters Sa, will display all the matching last names (and 
first names) and list everyone in Sales. 

Searching begins as soon as you start typing; and the more characters you type, the fewer contacts will 
match. When the contact you require is displayed, select it and then use the controls interface to 
communicate with that contact. 

Search Preferences 
The Search Preferences enable you control what fields are searched and what contacts are displayed. 

You can restrict which contact detail fields are searched using the Searchable Fields. De-select (clear) 
any you do not want to search: 

• First Name 

• Last Name 

• Telephone 

• Department 

You can also limit which contacts are displayed in the search results using these Filters: 

• Has Telephone – Display only those contacts with a directory number (DN) assigned. All other 
contacts are filtered out (excluded) from the search results. 

• Has Emails – Display only those contacts with an email address assigned. All other contacts are 
filtered out (excluded) from the search results. 

Setting Search Preferences 

To set the search preferences, do the following;
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Step 1 Click Search Preferences. 

Step 2 In the Search Preferences dialog box, select the required check boxes. 

Step 3 Click Save. 

Step 4 In the confirmation message, click OK. 

Viewing Contact Information 
The directory display contains basic information about each contact. You can view more information 
about a selected contact by viewing their contact details. How you view contact details depends on 
whether the contact is in the corporate directory or a directory group.

To view a contact’s details, do the following: 

Step 1 Display the directory containing the contact. 

Step 2 Right-click the contact. 

Step 3 Do one of the following, as appropriate: 

• If the contact is in the corporate directory, click View. 

• If the contact is in a directory group, click Edit Contact. 

The Contact dialog box is displayed. 

If you are viewing the details of a contact in a directory group, you can also edit the details, as described 
in Editing Contacts In Directory Groups, page 5-14. 

Step 4 When you have finished viewing the information, click Cancel. 

Contact Notes 
You can add notes to any contact record in the main directory, the search results, or any directory group. 
The notes are text containing additional information about the contact. Notes are stored in the database 
and are available whenever you sign in. If you delete a contact - for example by applying BLF rules - 
any contact notes are also deleted. If you export a contact, their notes are also exported, and if you import 
a contact with notes, they are visible in the application. 

Adding Contact Notes 
To add contact notes:

Step 1 Select the contact to add notes to.

Step 2 Either:

• Right-click the contact, and then choose Contact Notes. 

• Choose Edit > Contacts > Contact Notes. 
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The Contact Notes dialog box appears.

Step 3 In the text box, type the notes and then either click Save or tab to the control and press Enter to add the 
notes to the contact. 

Note You must enter some text for you to be able to save it. 

The notes appear in the contact’s Notes column. 

Editing Contact Notes 
You can edit existing contact notes. To do so, follow the Adding Contact Notes procedure, but edit the 
existing notes. 

Deleting Contact Notes 
To delete existing contact notes:

Step 1 Select a contact with notes to delete. 

Step 2 Either:

• Right-click the contact, and then choose Delete Notes. 

• Choose Edit > Contacts > Delete Notes. 

Note These menu options are disabled if there are no notes to delete. 

Step 3 The notes are deleted from the contact Notes column. 
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Keyboard shortcuts enable you to quickly do things in the interface without needing to use the mouse or 
menus. 

The application comes configured with the following keyboard shortcuts. 

In addition, you can define shortcuts for the following actions: 

• Resume Call

• Retrieve Parked Call 

• Email 

• Options 

• Import contacts 

• Export contacts 

• Exit 

• Keyboard Shortcut Options 

Action Shortcut

Dial Ctrl+D 

Answer Ctrl+A 

End Call Ctrl+H 

Hold Call Ctrl+L 

Transfer Call (Blind transfer) Ctrl+X 

Consult Transfer (speak to destination before transfer) Ctrl+T 

Direct Transfer Ctrl+R 

Join Call Ctrl+J 

Park Call Ctrl+P 

Start Conference Ctrl+N 

Access Voicemail Ctrl+O 

Sign out of application Ctrl+S

Log out of hunt groups Ctrl+I

Open Help F1 
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• View Contacts 

• Add Contact 

• Edit Selected Contact 

• Delete Selected Contact 

• Add Directory Group 

• Edit Selected Directory Group 

• Delete Selected Directory Group 

• View Contact 

• Open Call Control Pane 

• Open Parked Calls Pane 

• Open Call History Pane 

• Open Directory Pane 

• Lock Pane Layout 

• Revert to Default Layout 

• Load Saved Layout 

• Save Current Layout 

• Open Text Size Options 

• Open About Box 

Note You cannot use the same keyboard shortcut for more than one action. 

Defining and Editing Keyboard Shortcuts 
To define or edit a keyboard shortcut, do the following: 

Step 1 Do either of the following: 

• In the main menu, choose Edit > Keyboard Shortcuts. 

or 

a. In the main menu, choose File > Options. 

b. The Options window appears. 

c. Click the Keyboard Shortcuts tab. 

Step 2 Select the Action to define. This can be an action that already has a shortcut. 

Step 3 Click Set Shortcut. 

Step 4 Type the shortcut you require. For example, to set an action to Ctrl+Y, simply type Ctrl+Y (press and 
hold the Ctrl key and then press the Y key). 

Step 5 Click Apply. 
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Removing Keyboard Shortcuts 
To remove a keyboard shortcut, do the following: 

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts, 
page 6-2. 

Step 2 Select the action from which to remove the keyboard shortcut.

Step 3 Click Clear Shortcut. 

Step 4 Click Apply. 

Resetting Shortcuts to their Default Values 
To reset keyboard shortcuts to their default values, do the following: 

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts, 
page 6-2. 

Step 2 Do one of the following, as appropriate: 

To reset all keyboard shortcuts to their default values, click Reset All Shortcuts to Default. 

To reset a single keyboard shortcut to its default value: 

a. Select the action to reset.

b. Click Reset Shortcut. 

Step 3 Click Apply. 
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Note Access to the functions described in this section may be restricted by your system administrator, and you 
may need a password to access the necessary Options tab. For more information, see Preventing Access 
To Options Tabs, page 4-2. 

Cisco Unified Attendant Console Standard can keep a log of all event that occur within the application. 
This information can be used to gauge the application’s configuration and performance, and to help 
troubleshoot any errors. You can control which application subsystems are monitored, which events are 
logged, and the size and number of the log files. 

To configure logging, do the following:

Step 1 In the main menu, choose File > Options. 

The Options window appears. 

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”. 

Step 2 Click the Logging tab. 

Step 3 Set the following, as required:

• Type the Max Size RollBackups, which is the maximum number of log files to store before you 
re-use (overwrite) the first one. This works in conjunction with Maximum File Size (In MBs).

• Type the Maximum File Size (In MBs). When the file gets this size it is closed and a new log file 
is opened. Works in conjunction with Max Size RollBackups. 

• Select the Logging Level. This is the default amount of detail that will be written into the log file. 
Detail decreases in the following order:

– DEBUG

– INFO

– WARN

– ERROR

– FATAL 

The level you set is applied to all the modules grouped below. 

• Under Modules Setting, set the logging level for each module to override the default value. 
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Step 4 Click Apply. 
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Cisco Unified Attendant Console Standard can handle contact directory files in the following formats: 

• XML File Format, page B-1 

• CSV File Formats, page B-2 

It can also import login devices from CSV files, with the format described in CSV Files for Importing 
Sign In Devices, page B-3. 

XML File Format 
XML files that you import into Cisco Unified Attendant Console Standard must have the following 
format: 

<SpeedDialUsers>
<G n="Sample Group">

<E>
<N>Jim Kathirine</N>
<T>25421</T>
<M>Jim@cisco.com</M>
<D>Jim@cisco.com</D>
<O>This is a sample entry</O>
<P>00443454332</P>
<H>0044556634</H>
<S>Reading</S>
<A>IT</A>
<R>Jason Rumsey</R>
<U>Software Engineer</U>
<V>Management</V>

</E>
</G>

</SpeedDialUsers> 

Tags 

• <SpeedDialUsers> = the file contains XML data for import into Cisco Unified Attendant Console 
Standard. 

• <G> = Directory group name 

• <E> = Individual contact 

• <N> = Name

• <T> = Telephone number

• <M> = Email address
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• <D> = Directory URI 

• <O> = Note 

• <P> = Mobile 

• <H> = Home phone number 

• <S> = Site 

• <A> = Department 

• <R> = Manager 

• <U> = UserField1 

• <V> = UserField2 

CSV File Formats 
Cisco Unified Attendant Console Standard handles two types of comma-separated value (CSV) files: 

• CSV Files for Synchronization 

• CSV Files for Directory Import and Export 

These files differ in the number of data fields they contain in each contact record. 

All CSV files used by Cisco Unified Attendant Console Standard must have the following format: 

• Each contact is on a single line. 

• Empty comma-separated values are valid. 

• Lines starting with # or ; are comments and are ignored. Empty and blank lines are also ignored. 

CSV Files for Synchronization 
In a CSV file for synchronization, the data for each contact must be in the following order: 

Last Name, First Name, Telephone Number, Department, User Field 1, User Field 2, Site, 
Building, Directory URI. 

For example: 

#     * Copyright (c) 2014 by Cisco Inc.
#     * All rights reserved.
# 
# Here is a sample corporate directory file. It should contain
# comma separated entries, one line per user in the directory
# The values should in the following format:
# 
# Last Name, First Name, Telephone number, Department, User Field 1, User Field 2, Site, 
Building, Directory URI
# 
# Empty values are legal (no department etc.)
#
# Lines starting with '#' or ';' are treated as comments
# and ignored. Empty or blank lines are ignored as well

Kathirine,Jim,25421,Marketing,,,,,Jim@cisco.com
Martha,Bryan,87952,Support,,,,,martha@cisco.com
Luce,Richard,2548,Marketing,,,,,luce@cisco.com
Meriall,Thomas,8763,Marketing,,,,,meriall@cisco.com
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Harye,Walter,5563,Marketing,,,,,harye@cisco.com

CSV Files for Directory Import and Export 
In a CSV file for directory import or export, the data for each contact must be in the following order: 

Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle 
Name, Mobile, Home Phone, Site, Department, Manager, User Field 1, User Field 2. 

For example: 

CSV Files for Importing Sign In Devices 
You can import devices that operators use to log into Cisco Unified Attendant Console Standard, as 
described in Importing Sign In Devices, page 4-7. 

These CSV files have the data for each device in the following format: 

Device name, Extension, Line number 

For example: 

#     * Copyright (c) 2014 by Cisco Inc.
#     * All rights reserved.
# 
# Here is a sample device list file. It should contain
# comma separated entries, one line per device in the device list.
# The values should in the following format:
# 
# DeviceName,Extension,LineNumber
# 
# Empty values are not allowed (no DeviceName etc.)
#
# Lines starting with '#' or ';' are treated as comments

#     * Copyright (c) 2014 by Cisco Inc.
#     * All rights reserved.
# 
# Here is a sample import file. It should contain
# comma separated entries, one line per user in the directory
# The values should be in the following format:
#
# Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle Name, Mobile, 
Home Phone, Site, Department, Manager, User Field 1, User Field 2
# 
# Empty values are legal (no email etc.)
#
# Lines starting with '#' or ';' are treated as comments
# and ignored. Empty or blank lines are ignored as well

Kathirine,Jim,25421,This is a sample entry,Sample Group 1,Jim@cisco.com,Jim@cisco.com,Maid,
00443454332,0044556634,Reading,IT,Martin Taylor,Support Engineer,Senior
Martha,Bryan,87952,This is a sample entry.,Sample Group 1,martha@cisco.com,martha@cisco.com,Aryan,
00443454335,0044556635,Reading,IT,Martin Taylor,Support Engineer,Junior
Luce,Richard,2548,This is a sample entry,Sample Group 2,luce@cisco.com,luce@cisco.com,Tace,
00443454339,0044556636,Reading,R&D,Jason Rumsey,Software Engineer,Management
Meriall,Thomas,8763,This is a sample entry,Sample Group 2,meriall@cisco.com,meriall@cisco.com,Kate,
00443454331,0044556637,Reading,R&D,Jason Rumsey,Software Engineer,Junior
Harye,Walter,5563,This is a sample entry,Sample Group 2,harye@cisco.com,harye@cisco.com,Heather,
00443454333,0044556638,Reading,R&D,Jason Rumsey,Software Engineer,Senior
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# and ignored. Empty or blank lines are ignored as well

SEP2893FE130280,5868,1
SEP2893FEA2D22A,5873,1
SEP000C299DA714,5870,1
SEP88AE1DB0F66C,5869,1
SEP00141C48DDD9,5859,1
SEP00141C48DDD9,5870,2

Note Any devices in the file that lack one or more of the fields Device name, Extension, or Line number are 
considered non-Cisco devices and will not be imported. 
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Cisco Unified Attendant Console Standard supports the following phones: 

Phone Type Supported 

3905 Not as Console and cannot support BLF, but can transfer. 

3911

3951

6901 Not tested

6911 Yes

6921 Yes

6941 Yes

6945 Yes

6961 Yes

7821 Yes

7841 Yes

7861 Yes

7902 Not tested (Obsolete) 

7905 Yes

7906 Yes

7910 Yes

7911 Yes

7912 Yes

7920 Yes

7921 Yes

7925 Yes

7925G Yes

7925G-EX Yes

7926 Yes

7931 Yes
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‡ If Log in to hunt groups at sign in is selected, the Cisco Unified Call Manager resets this phone type 
when the user logs in to the Cisco Unified Attendant Console Standard client. 

7940 Yes

7941 Yes

7941G-GE Yes

7942 Yes

7942-G Yes

7945 Yes

7945G Yes

7960 Yes

7961 Yes

7961G-GE Yes ‡

7962 Yes

7965 Yes

7965G Yes

7970 Yes

7971 Yes

7975 Yes ‡

8941 Yes

8945 Yes

8961 Yes

9951 Yes

9971 Yes

Cisco CSF Yes

DX650 Yes

IP Communicator Yes

Jabber Yes - standard Jabber installations (locally installed on the 
operator computer) and VXME installations (installed in a 
VXME environment) are supported as operator devices and 
end points. 

Phone Type Supported 
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I N D E X

A

Access Control Group

assigning roles to 2-6

creating 2-6

accessibility for users with disabilities 1-2

active call information 1-3

alerts, configuring 4-5

Application User

assigning devices to, for directory BLF 2-7

creating and assigning 2-7

B

BLF rules 5-3, 5-7 to 5-10

adding 5-8

deleting 5-9

editing 5-9

reordering 5-10

C

Call Control pane 1-3

Call History pane 1-3

Cisco TAPI wave driver, installing 2-11

Cisco TSP for Cisco Unified Communications Manager 
7.x, installing and configuring 2-10 to 2-12

Cisco Unified Attendant Console Standard

features 1-1

installing 2-8

licensing 2-12 to 2-17

Cisco Unified Communications Manager

compatibility 2-4

configuring 2-5 to 2-8

connecting to a different 4-4

Citrix support 2-2

computer requirements 2-1

contact information

editing 5-14

viewing 5-18

contact notes 5-18

contacts

adding 5-13

searching 5-17

corporate directory 5-1

CSV file 5-1

formats B-2

for synchronization B-2

CUCM, See Cisco Unified Communications Manager

D

device list 4-6

directories 5-1 to 5-19

viewing and using 5-16

directory

change view 5-16

destination fields 5-6

group 5-1

search preferences 5-17

source fields 5-7

sources 5-1

synchronization 5-3 to 5-5

directory field mappings 5-3, 5-6

setting 5-7

directory filters 5-3, 5-5
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creating 5-5

directory groups 5-10 to 5-15

adding contacts manually 5-13

creating 5-10

deleting 5-11

deleting contacts 5-14

editing contacts 5-14

exporting contacts 5-15

importing contacts 5-12

renaming 5-11

Directory pane 1-3

directory tabs 5-16

E

End User account for Presence 2-8

evaluation software, licensing 2-13

exiting Cisco Unified Attendant Console Standard 3-3

export contacts 5-1

exporting contacts 5-15

F

features of Cisco Unified Attendant Console Standard 1-1

file formats when importing data B-1

filtering directories 5-5

firewall exceptions 2-2

H

hardware requirements 2-1

Help, accessing 1-3

hunt group login 3-1, 3-3

I

import/export file formats B-1 to B-4

importing contacts 5-1, 5-12

installing Cisco Unified Attendant Console 
Standard 2-1 to 2-17

interface, description 1-2

introduction to Cisco Unified Attendant Console 
Standard 1-1 to 1-4

J

Jabber support 2-2

K

keyboard shortcuts 6-1 to 6-3

defining and editing 6-2

removing 6-3

resetting to default values 6-3

L

licensing 2-12

bulk licenses 2-15

CUAC Department Edition upgrades 2-14

evaluation software 2-13

purchased software 2-15

resetting license codes 2-16

logging, configuring A-1 to A-2

M

main menu 1-3

N

network requirements 2-2

O

operating system support 2-2

operator
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details, setting 4-3

voicemail prefix, setting 4-5

Options Password 4-2

P

pane

Call Control 1-3

Call History 1-3

Directory 1-3

Parked Calls 1-3

Parked Calls pane 1-3

phones supported C-5 to C-6

phone state, directory display 5-16

Presence Server, connecting to a different 4-3

presence state, directory display 5-16

purchased software, licensing 2-15

R

requirements, hardware and software 2-1

S

searching for contacts 5-17

search preferences 5-17

sign in devices 4-7

software

relicensing 2-17

requirements 2-1

starting Cisco Unified Attendant Console 
Standard 3-1 to 3-3, 4-1 to 4-8

synchronization 5-1, 5-3

configuring 5-4

from CSV Source File 5-4

T

TAPI Service Provider, See TSP

TSP for CUCM 7.x

configuring 2-11

downloading and installing 2-10

TSP installation 2-9

U

User Group

assigning roles to 2-6

creating 2-5

user interface, description 1-2

W

Windows folder permissions 2-3

X

XML file format B-1
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