SIIr
CISCO.

'
g
-
sz
[id
¥
.-
g
z
"
i

Cisco Unified Attendant Console Standard -
Installation and Configuration Guide

Version 10.5
May 12, 2014

Cisco Systems, Inc.
WWW.Cisco.com

Cisco has more than 200 offices worldwide.
Addresses, phone numbers, and fax numbers
are listed on the Cisco website at
www.cisco.com/go/offices.

Text Part Number: OL-25987-01


http://www.cisco.com
http://www.cisco.com/go/offices

THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL
STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT
WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT
SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE
OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB’s public
domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS” WITH
ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT
LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF
DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING,
WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO
OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

CCDE, CCENT, CCSI, Cisco Eos, Cisco HealthPresence, Cisco Ironport, the Cisco logo, Cisco Lumin, Cisco Nexus, Cisco Nurse Connect, Cisco Stackpower,

Cisco StadiumVision, Cisco TelePresence, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flip Video, Flip Video (Design),
Flipshare (Design), Flip Ultra, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Store, and Flip Gift Card are
service marks; and Access Registrar, Aironet, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the
Cisco Certified Internetwork Expert logo, Cisco I0S, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without
Limitation, EtherFast, EtherSwitch, Event Center, Fast Step, Follow Me Browsing, FormShare, GigaDrive, HomeLink, Internet Quotient, IOS, iPhone, iQuick Study,
IronPort, the IronPort logo, LightStream, Linksys, MediaTone, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, Network Registrar,
PCNow, PIX, PowerPanels, ProConnect, ScriptShare, SenderBase, SMARTnet, Spectrum Expert, StackWise, The Fastest Way to Increase Your Internet Quotient, TransPath,
WebEx, and the WebEx logo are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.

All other trademarks mentioned in this document or website are the property of their respective owners. The use of the word partner does not imply a partnership relationship
between Cisco and any other company. (0907R)

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the
document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental.

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
© 2014 Cisco Systems, Inc. All rights reserved.



cHAPTER 1

CHAPTER 2

CONTENTS

About This Guide i
Who Should Read This Guide i
How This Guide is Organized i
Document Conventions i
Obtaining Documentation and Submitting Service Requests i

Introduction to Cisco Unified Attendant Console Standard  1-1
Accessibility for Users with Disabilities 2
Cisco Unified Attendant Console Standard User Interface  1-2
Accessing Help on the Application  1-3

Installing Cisco Unified Attendant Console Standard 2-1

PC Hardware and Software Requirements ~ 2-1
Operating System Support ~ 2-2
Citrix Support ~ 2-2
Jabber Support  2-2
Network Requirements ~ 2-2
Scalability  2-3
Directory Synchronization  2-3
Presence 2-3
Cisco Unified Communications Manager Compatibility — 2-3
Configuring Cisco Unified Communications Manager ~ 2-5
Creating a User Group (CUCM 7.xand 8.x) 2-5
Creating an Access Control Group (CUCM 9.x and 10.x) 25
Assigning Roles to a User Group or Access Control Group ~ 2-6
Creating and Assigning an Application User ~ 2-7
Assigning Devices to Application Users to Enable Directory BLF  2-7
End User Account Required For Presence  2-8
Installing or Upgrading Cisco Unified Attendant Console Standard ~ 2-8
Installing and Configuring the Cisco TSP for Cisco Unified Communications Manager 7.x ~ 2-10
Downloading and Installing the TSP 2-10
Configuring the TSP~ 2-11
Installing the Cisco TAPI Wave Driver  2-11

| oL-25987-01

Cisco Unified Attendant Console Standard - Installation and Configuration Guide g



M Contents

Licensing Cisco Unified Attendant Console Standard ~ 2-12
Licensing New Installations ~ 2-12
Activating Evaluation Software  2-13
Licensing CUAC Department Edition Upgrades — 2-14
Generating Single Licenses  2-14
Generating Bulk Licenses ~ 2-15
Activating Purchased or Upgraded Software  2-15
Resetting License Codes  2-16
Relicensing Software  2-17

cHAPTER 3 Starting Cisco Unified Attendant Console Standard  3-1
Signing Out ~ 3-2
Logging In to Hunt groups ~ 3-2
Logging Out of Hunt groups ~ 3-2
Exiting Cisco Unified Attendant Console Standard ~ 3-3

cHaprTER 4 Configuring Cisco Unified Attendant Console Standard 4-1

Setting the Options Password ~ 4-2
Resetting the Options Password ~ 4-2

Setting Operator Details  4-3

Connecting to a Different Presence Server  4-3

Connecting to a Different Cisco Unified Communications Manager
Setting the Operator Voicemail Prefix ~ 4-4

Configuring Alerts ~ 4-5

Managing Sign In Devices ~ 4-6
Manually Adding Sign In Devices  4-6
Importing Sign In Devices  4-7
Deleting Sign In Devices  4-7

CHAPTER D Directories 5-1

Directory Synchronization  5-3
Synchronizing From a CSV Source File  5-4
Configuring Synchronization ~ 5-4
Directory Filtering  5-5
Creating Directory Filters ~ 5-5
Directory Field Mappings  5-6
Destination Fields  5-6
Source Fields  5-7

4-4

[l Cisco Unified Attendant Console Standard - Installation and Configuration Guide

0L-25987-01 |



Setting Directory Field Mappings ~ 5-7

BLF Rules  5-7
Adding BLF Rules  5-8
Editing BLF Rules  5-9
Deleting BLF Rules ~ 5-10
Reordering BLF Rules  5-10

Directory Groups ~ 5-11
Creating Directory Groups ~ 5-11
Deleting Directory Groups ~ 5-11
Renaming Directory Groups ~ 5-12
Importing Contacts Into Directory Groups — 5-12
Manually Adding Contacts To Directory Groups ~ 5-13
Deleting Contacts From Directory Groups ~ 5-14
Editing Contacts In Directory Groups ~ 5-15
Exporting Contacts From Directory Groups — 5-15
Viewing and Using Directories  5-16
Changing the Directory View  5-17
Searching For Contacts ~ 5-17
Search Preferences  5-17
Viewing Contact Information  5-18
Contact Notes  5-19
Adding Contact Notes ~ 5-19
Editing Contact Notes ~ 5-19
Deleting Contact Notes ~ 5-19

cHaPTER 6 Keyboard Shortcuts  6-1
Defining and Editing Keyboard Shortcuts ~ 6-2
Removing Keyboard Shortcuts ~ 6-3
Resetting Shortcuts to their Default Values  6-3

appeENDIX A Configuring Logging  A-1

arrenpix B Import/Export File Formats  B-1
XML File Format ~ B-1
CSV File Formats  B-2
CSV Files for Synchronization  B-2
CSV Files for Directory Import and Export ~ B-3
CSV Files for Importing Sign In Devices  B-3

| oL-25987-01

Contents W

Cisco Unified Attendant Console Standard - Installation and Configuration Guide g



M Contents

appenpix C Phones Supported by Cisco Unified Attendant Console Standard C-5

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
“. 0L-25987-01 |



About This Guide

This guide describes how to install and configure Cisco Unified Attendant Console Standard.

Who Should Read This Guide

This guide is for deployment engineers, system administrators, and anyone else who installs or
configures Cisco Unified Attendant Console Standard. You should have a knowledge of how to configure
the Cisco Unified Communications Manager used by the application.

How This Guide is Organized

This guide contains the following sections.

Section Contains

Chapter 1, “Introduction to Cisco Unified Introduction to Cisco Unified Attendant Console

Attendant Console Standard” Standard

Chapter 2, “Installing Cisco Unified Attendant |Preparing Cisco Unified Communications Manager

Console Standard” and installing Cisco Unified Attendant Console
Standard

Chapter 3, “Starting Cisco Unified Attendant Starting Cisco Unified Attendant Console Standard

Console Standard” and configuring operator details

Chapter 4, “Configuring Cisco Unified Configuring Cisco Unified Attendant Console

Attendant Console Standard” Standard, including managing sign in devices

Chapter 5, “Directories” Using and controlling directories

Chapter 6, “Keyboard Shortcuts” Setting up keyboard shortcuts

Appendix A, “Configuring Logging” Configuring application logging

Appendix B, “Import/Export File Formats” Formats of import and export files

Appendix C, “Phones Supported by Cisco List of supported Cisco phones

Unified Attendant Console Standard”

Cisco Unified Attendant Console Standard - User Guide
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Document Conventions

The following textual and typographic conventions are used in this document:

~

Note

pe

Tip

A

Convention

Usage

bold font

Commands, keywords and user-entered text appear in bold type.

italic font

Document titles, new or emphasized terms, and arguments for which you supply values
are in italic font.

[l

Elements in square brackets are optional.

{(x|y]z} Required alternative keywords are enclosed in braces and separated by vertical bars.

x|y]lzl] Optional alternative keywords are enclosed in square brackets and separated by vertical
bars.

string A non-quoted set of characters. Do not use quotation marks around the string or the

string will include the quotation marks.

courier font

Terminal sessions and information the system displays appear in courier font.

Means reader take note.

Means the following information will help you solve a problem.

Caution

Means reader be careful. In this situation, you might do something that could result in equipment
damage or loss of data.

Timesaver

A

Warning

Means the described action saves time. You can save time by doing what is described in the paragraph.

Means reader be warned. In this situation, you might do something that could result in bodily injury.

Obtaining Documentation and Submitting Service Requests

For information on obtaining additional documentation and submitting service requests, see the monthly
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical
documentation, at http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS Version 2.0.

] Cisco Unified Attendant Console Standard - User Guide
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CHAPTER 1

Introduction to Cisco Unified Attendant Console
Standard

Cisco Unified Attendant Console Standard is a Microsoft Windows-based operator attendant console
application for use with Cisco Unified Communications Manager (CUCM). For details of the supported
versions, see Cisco Unified Communications Manager Compatibility, page 2-3. Cisco Unified Attendant
Console Standard supports up to 5000 contacts on a single instance.

Cisco Unified Attendant Console Standard enables you to do the following:

Control calls on your local IP Phone, XMPP client (such as Jabber), or Cisco IP Communicator
Make, answer and end calls

Hold and resume calls

Blind/consult transfer calls to directory contacts or voicemail, or any other valid number

Direct transfers

Join calls

Set Call Forward and Do Not Disturb on the operator phone

Park calls

Create and manage conference calls

Import custom directories of contacts not in your Cisco Unified Communications Manager directory
Create custom directories (directory groups) and export them to share with other operators

Synchronize Cisco Unified Attendant Console Standard’s corporate (main) directory with a CUCM
or CSV file source directory

During synchronization with your source directory:
— Map the fields from your source directory to the ones in the corporate directory
- Filter contacts, so that only certain ones are added to the corporate directory
— Modify contact numbers using BLF rules

See the line state and presence of each contact

View call history

Specify the devices used to sign in to the application

Log in to a hunt group when you sign in to the application.

Online help on the application is available. For how to display the help, see Accessing Help on the
Application, page 1-3.

| oL-25988-01
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Chapter1 Introduction to Cisco Unified Attendant Console Standard |

W Cisco Unified Attendant Console Standard User Interface

Accessibility for Users with Disabilities

The Cisco Unified Attendant Console Standard user interface and controls are described in Cisco
Unified Attendant Console Standard User Interface, page 1-2.

Cisco Unified Attendant Console Standard incorporates the following features to make it easier for blind
and visually impaired people to use it:

e Most functions can be accessed using either the mouse or keyboard. You can define keyboard
shortcuts for the most frequently used functions. For more information, see Chapter 6, “Keyboard
Shortcuts”.

* You can set the size of call and directory text in the interface.
e A tooltip is displayed for each graphical interface control when you point to it

For more information on the Cisco Accessibility Program visit
http://www.cisco.com/web/about/responsibility/accessibility/contact.html.

Cisco Unified Attendant Console Standard User Interface

You use the Cisco Unified Attendant Console Standard interface to do all the standard operator tasks,
including making calls, putting calls on hold, and conferencing calls.

An example of the user interface is shown below:

Alials.

‘asco’ File Edit View Call Controls Help n

Call Control 3 Parked Calls 4
79226 i Eoer boimes 0.8 g sum ; % ParkExtension % Caller ID < Parked By Duration
2706 > 2054
@ 2054 2 Unknown Caller mm 6002 2716 (Michael Butty 2054 014
Y 271252054
~2026 ! m 6001 2708 (Joan Fleming) 2054 048

> 972252054

&', Adam Adair
S 272452054

Em Call History 5

¢ Status ¢ From ¢To Time

2714 (Andrew

Recens] Melchard)

2054 2014-05-12 12:45:18

2706 (Peter

Received Holmes)

2054 2014-05-12 12:45:12

el ) 6 &
Search Results ’—‘ Sales | CustomerSupport  + 8
¢ LastName ¢ First Name. + Telephone ¢ Department Notes 9
-~ Beavis Simon 2720 Sales In the office
Cal Yates Steven 221 Sales On vacation until 25th May
Q0 Greer Helen 2722 Sales
o~ | Stevenson John 2723 Sales 10
Q) Adair Adam 2724 Sales
Ll Stewart Katrina 2725 Sales ‘Working at home
Cal Wallace Rusty 2726 T
The legend is on the next page.
Cisco Unified Attendant Console Standard - User Guide
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Introduction to Cisco Unified Attendant Console Standard

Legend

Accessing Help on the Application

Name

Contains

Main menu

Controls for using and configuring the application.

Many of the controls here are also available when you right-click
specific parts of the interface. For example, controls relevant to the
directories are displayed when you right-click in the directory pane.

Current console extension

The extension used to sign in to the application. Click this to display
a menu that you use for signing out and for logging into and out of
hunt groups.

Call Control pane

Active call information on any line on the console phone. The calls in
progress are displayed here, along with their status, duration, and
controls for frequently used actions, such as transferring or ending the
call.

Parked Calls pane

Active parked calls, by default displayed in the order in which they
were parked.

This pane shows the park extension used, the identities of both the
caller and the DN that parked the call, and how long the call has been
parked.

Call History pane

Completed calls in the current session, by default listed in reverse
chronological order. You can change the order in which completed
calls are listed.

This pane is not displayed by default; use View > Show Call History
to display it.

Search box

Tool in the header bar of the Directory pane for finding contacts by last
name, first name, department and number.

Set search preferences

Control how searches are conducted.

Add new directory group

Control for creating a new directory group.

Add contact

Only available for directory groups. Control for adding contacts to
directory groups.

10

Directory pane

Displays the synchronized directory, directory groups and search
results. Includes Search box and controls for creating directory
groups. Contact information includes line state and presence. For
more information, see Chapter 5, “Directories”.

You control the interface using both your mouse and keyboard. Many things that you can do with the
mouse you can also do using your keyboard, provided that the application interface is selected.

Accessing

Help on the Application

You can display help about Cisco Unified Attendant Console Standard by doing one of the following:

¢ In the main menu, choose Help > Cisco Unified Attendant Console Standard Help.
e Press F1.

The Help contains the following to make it easy to find what you need to know:

Cisco Unified Attendant Console Standard - User Guide ]
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M Accessing Help on the Application

e Text search tool
e Index

e Contents list.

Cisco Unified Attendant Console Standard - User Guide
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CHAPTER

Installing Cisco Unified Attendant Console
Standard

To install Cisco Unified Attendant Console Standard you must do the following:

1.

2.

Ensure that the PC running it satisfies the minimum hardware and software requirements. These are
described below.

Within Cisco Unified Communications Manager, create an Application User with associated
phones. If you intend to use the presence facility within Cisco Unified Attendant Console Standard,
you must also set up an End User. For instructions, see Configuring Cisco Unified Communications
Manager, page 2-5.

Install the Cisco Unified Attendant Console Standard software. For instructions, see Installing or
Upgrading Cisco Unified Attendant Console Standard, page 2-8.

PC Hardware and Software Requirements

The PC running Cisco Unified Attendant Console Standard has the following minimum hardware
requirements:

2.4 GHz Core 2 Duo
4 GB RAM
10 GB available hard drive space

100 Mbps network card, connected to the same network as Cisco Unified Communications Manager
using TCP/IP

Monitor with 1024x768 resolution (recommended: monitor with 1440x900 resolution, plus headset)

Keyboard with 10-key number pad.

[ oL-25987-01
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Chapter 2 Installing Cisco Unified Attendant Console Standard |

M PC Hardware and Software Requirements

Operating System Support

Cisco Unified Attendant Console Standard is supported under the following operating systems:
e Windows Vista Professional with SP2 (32-bit or WoW64)

e Windows 7 (32-bit or WoW64) — integration with Cisco Unified Communications Manager versions
7.1(5) or 8.0(x) is not supported under this operating system

e Windows 8 (32-bit or WoW64) — you can integrate only with Cisco Unified Communications
Manager version 10.0(1) or 10.5(1) under this operating system

e Windows 8.1 64-bit — you can integrate only with Cisco Unified Communications Manager version
10.0(1) or 10.5(1) under this operating system

~

Note  The following points:

¢ Cisco Unified Attendant Console Standard is not supported under the following operating systems:
- Windows XP
- Windows 2000
- Windows 2003
— Windows 2008 R1 (32-bit)
— Windows 2008 (64-bit)
- Windows 2012

e If your machine uses a 64-bit operating system, you cannot run Cisco Unified Attendant Console
Standard against Cisco Unified Communications Manager version 7.1(5), as this does not support
the 64-bit TSP required for the systems to be able to communicate with each other.

Citrix Support

Cisco Unified Attendant Console Standard is not supported within a Citrix environment.

Jabber Support

Both standard Jabber installations (locally installed on the operator computer) and VXME installations
(installed in a VXME environment) are supported as operator devices and end points.

Network Requirements

The computer running Cisco Unified Attendant Console Standard must be able to access the Cisco
Unified Communications Manager and the Cisco Unified Presence (CUP) Server. By default, these use
the following two-way TCP ports:

¢ (Cisco Unified Communications Manager — Port 443

e Cisco Unified Presence (CUP) Server — Port 5222

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
m. 0L-25987-01 |



| Chapter2 Installing Cisco Unified Attendant Console Standard

Scalability

Cisco Unified Communications Manager Compatibility ||

If you have a firewall on your computer, you must configure firewall exceptions for these ports or for
any alternatives you may use in your installation.

Cisco Unified Attendant Console Standard supports up to 5000 contacts on a single instance

Directory Synchronization

Note

Presence

Although the recommended maximum Cisco Unified Attendant Console Standard directory size is 5000
contacts, there is no theoretical limit to the number that can be stored. However, if many users (say 500)
with large directories (say 50000 contacts) simultaneously try to synchronize with Cisco Unified
Communications Manager it would struggle to cope.

Cisco Unified Communications Manager's User and CTI (TSP client) resources are perfectly adequate
to support this many concurrent Cisco Unified Attendant Console Standard users.

If you do have many concurrent Cisco Unified Attendant Console Standard users who are synchronizing
more than the recommended maximum number of contacts, we recommend that these users:

e Configure Cisco Unified Attendant Console Standard to sync the directory infrequently; for
example, once a day when they launch the application

e Stagger the times at which they synchronize or launch the application.

Cisco Unified Attendant Console Standard uses its user’s personal Jabber credentials to enable presence
indicators in its directory. So long as hundreds of users are not sharing the same Jabber credentials, the
load on the presence server will be distributed, and there will be no problems with presence.

Cisco Unified Communications Manager Compatibility

Cisco Unified Attendant Console Standard is supported with the following Cisco Unified
Communications Manager versions:

e 7.1(5) — not supported when running under Windows 7 32-bit, or under 64-bit operating systems.
Cisco Unified Presence 7.1(5) is not supported.

e 8.0(1) — not supported when running under Windows 7 32-bit, or any 64-bit operating systems
e 8.0(3) — not supported when running under Windows 7 32-bit, or any 64-bit operating systems
e 8.5(1) — supported on SU1 and above

e 8.6(1)

e 8.6(2)

e 9.0(1)

9.1(1)

9.1(2)

[ oL-25987-01
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W Cisco Unified Communications Manager Compatibility

e 10.0(1) — only supported under 64-bit versions of Windows 8 or Windows 8.1
e 10.5(1) — only supported under 64-bit versions of Windows 8 or Windows 8.1

If you are using Cisco Unified Communications Manager Release 8 or later, the TSP and New Cisco
Media Driver are automatically installed and activated when you install Cisco Unified Attendant
Console Standard. However, Cisco Unified Communications Manager Release 7.1.5 does not support
this silent TSP installation, and you must manually download and install the appropriate TSP and Cisco
TAPI Wave driver according to the instructions in Installing and Configuring the Cisco TSP for Cisco
Unified Communications Manager 7.x, page 2-10.

Note  The following:

e The 32-bit version of TSP is required when running Cisco Unified Attendant Console under a 32-bit
operating system. The 64-bit version of TSP is required when running Cisco Unified Attendant
Console under a 64-bit operating system. Consequently, 64-bit installations are supported only in
conjunction with Cisco Unified Communications Manager versions later than 8.0(3).

e If the installation wizard is unable to download the TSP, you can fix the problem by doing the

following:
a. In your web browser, under Tools, choose Internet Options.
b. In the dialog box, select the Advanced tab.
¢. Under Security, deselect (uncheck) Check for publisher's certificate revocation.

d. Under Security, deselect (uncheck) Check for server certificate revocation.
e. Click OK.

Cisco Unified Attendant Console Standard also integrates with the Cisco Unified Presence Server.

The operating system and Cisco Unified Communications Manager (CUCM) version compatibility is
summarized below:

cucm Windows Vista Windows 7 Windows 8
Version 32-bit and Wow64 32-bit and WoW64  |32-bit and WoW64 | Windows 8.1
7.1(5)! Supported Not supported Not supported Not supported
8.0(1) Supported Not supported Not supported Not supported
8.0(3) Supported Not supported Not supported Not supported
8.5(1)2 Supported Supported Not supported Not supported
8.6(1) Supported Supported Not supported Not supported
8.6(2) Supported Supported Not supported Not supported
9.0(1) Supported Supported Not supported Not supported
9.1(1) Supported Supported Not supported Not supported
9.1(2) Supported Supported Not supported Not supported
10.0(1) Supported Supported Supported Not supported
10.5(1) Supported Supported Supported Supported
1. CUP 7.1(5) not supported.
2. CUCM 8.5(1) supported on SU1 and above.
Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Installing Cisco Unified Attendant Console Standard

Configuring Cisco Unified Communications Manager 1l

Configuring Cisco Unified Communications Manager

Cisco Unified Attendant Console Standard must be able to communicate with the Cisco Unified
Communications Manager, which it does using Cisco Unified Communications Manager TSP.
Consequently, before you install Cisco Unified Attendant Console Standard you must first perform the
following steps:

1. Depending on the version of Cisco Unified Communications Manager you are using, either:

— Creating a User Group (CUCM 7.x and 8.x), page 2-5 — instructions for users of Cisco Unified
Communications Manager 7.x or 8.X.

— Creating an Access Control Group (CUCM 9.x and 10.x), page 2-5 — instructions for users of
Cisco Unified Communications Manager 9.x, 10.0(1) or 10.5(1).

2. Assigning Roles to a User Group or Access Control Group, page 2-6
3. Creating and Assigning an Application User, page 2-7.
4. End User Account Required For Presence, page 2-8.

Creating a User Group (CUCM 7.x and 8.x)

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

If you are using Cisco Unified Communications Manager 7.x or 8.x you must create a User Group. If
you are using Cisco Unified Communications Manager 9.x, 10.0(1) or 10.5(1) you must create an Access
Control Group, as described in Creating an Access Control Group (CUCM 9.x and 10.x), page 2-5.

User groups define the roles and permissions available to the Application Users who are members of that
group.

To create a User Group, do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > User Groups.

Click Add New to create a new User Group.

Type a Name for the new User Group.

Click Save to save the User Group.

Assign roles to the user group, as described in Assigning Roles to a User Group or Access Control
Group, page 2-6.

Creating an Access Control Group (CUCM 9.x and 10.x)

If you are using Cisco Unified Communications Manager 9.x, 10.0(1) or 10.5(1) you must create an
Access Control Group. If you are using Cisco Unified Communications Manager 7.x or 8.x you must
create a User Group, as described in Creating a User Group (CUCM 7.x and 8.x), page 2-5.

Access Control Groups define the roles and permissions available to the Application Users who are
members of that group.

To create an Access Control Group, do the following:

[ oL-25987-01

Cisco Unified Attendant Console Standard - Installation and Configuration Guide g



Chapter 2 Installing Cisco Unified Attendant Console Standard |

M Configuring Cisco Unified Communications Manager

Step1  Use your internet browser to access Cisco Unified CM Administration, and then log in.
Step2  In the main menu, choose User Management > User Settings > Access Control Group.
Step3  Click Add New to create a new Access Control Group.

Step4  Type a Name for the new Access Control Group.

Step5  Click Save to save the Access Control Group.

Step6  Assign roles to the user group, as described in Assigning Roles to a User Group or Access Control
Group, page 2-6.

Assigning Roles to a User Group or Access Control Group

Roles define what the members (Application Users) of a User Group or Access Control Group can do.

To add the roles to a User Group or Access Control Group required to enable Cisco Unified Attendant
Console Standard to work properly, do the following:

Step1  On the Find and List User Groups page, Find the User Group/Access Control Group you just created.
Step2  In the Search Results, click Roles for the User Group/Access Control Group.
Step3  Click Assign Role to Group.
The roles that can be assigned are listed.
Step4  Select the following roles:
e Standard AXL API Access
e Standard CTI Allow Calling Number Modification
¢ Standard CTI Allow Call Park Monitoring
e Standard CTI Allow Control of All Devices
e Standard CTI Allow Reception of SRTP Key Material
¢ Standard CTI Enabled
Step 5 If you are using phone models 69xx, 7931, 7965, 89xx and 99xx, you must also select:
e Standard CTI Allow Control of Phones supporting Connected Xfer and conf
¢ Standard CTI Allow Control of Phones supporting Rollover Mode
Step6  Click Add Selected to assign the roles.
Step7  Click Save.
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Creating and Assigning an Application User

Step 1
Step 2
Step 3
Step 4

Step 5

Step 6

An Application User connects Cisco Unified Attendant Console Standard to the Cisco Unified
Communications Manager using Cisco TSP and AXL.

¢ One operator requires a single Application User with all required devices assigned to it.

e Multiple operators using the same devices require a single Application User with all devices
required by all operators assigned to it.

e Multiple operators using different devices require multiple Application Users, each with the
required devices assigned to it. Operators requiring identical devices can use a single Application
User.

To create an Application User and then assign it to the User Group (CUCM 7.x or 8.x) or Access Control
Group (CUCM 9.x or 10.x), do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > Application User.
Click Add New.
Enter information in the following fields:
e User ID (a name of your choice)
e Password
¢ Confirm Password (this must match the Password)

Depending on the version of Cisco Unified Communications Manager you are connecting to, do one of
the following:

e If you are installing against Cisco Unified Communications Manager 7.x or 8.x, scroll down to the
Permissions Information section and click Add to User Group.

e Ifyou are installing against Cisco Unified Communications Manager 9.x or 10.x, scroll down to the
Permissions Information section and click Add to Access Control Group.

Click Save to save the Application User.

Assigning Devices to Application Users to Enable Directory BLF

Step 1
Step 2
Step 3

Step 4

To be able to see your contacts’ line state in the directory you must assign their devices to be controlled
by the relevant Application User.

To assign controlled devices to an Application User, do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > Application User.

Find and then select your Application User.

The Application User Configuration page appears.

Under Device Information, select the relevant Available Devices and then add them to the Controlled
Devices list. To add many devices you will probably find it easier to click Find more Phones, and then
find, select and Add the devices using the dialog box displayed.
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Step5  Click Save.

End User Account Required For Presence

The presence facility within Cisco Unified Attendant Console Standard requires that each Attendant has
an End User Account with Presence enabled on the Cisco Unified Communication Manager, so that
Cisco Unified Attendant Console Standard can communicate with the Cisco Unified Presence (CUP)
server. The User ID defined in the CUCM End User profile is used to obtain the presence information
for a contact.

In most cases the Attendants will already have an End User Account on the Cisco Unified
Communication Manager. If they do not, ask your telephony system manager to set them up for you.

Installing or Upgrading Cisco Unified Attendant Console
Standard

These instructions apply to both installing Cisco Unified Attendant Console Standard from scratch and
upgrading your installation. When you upgrade your software the installation Wizard offers you details
of your current installation, which you can accept or change, as required. You do not need to uninstall
the old version before installing the new software.

Cisco Unified Attendant Console Standard requires .NET framework 4 to run. If NET framework 4 has
not been supplied or configured before installation, the installation wizard installs and configures it for
you.

Note  To be able to install the software you must have administrator rights.

To install Cisco Unified Attendant Console Standard, do the following:

Step 1 Browse to the installation location and run CUACS_Setup.exe.
The installation wizard appears.
Step2  In the Welcome page, click Next.
Step3  In the Cisco Unified Communications Manager Connection Details page, type the following:

e The Cisco Unified Communications Manager Host Name, Fully Qualified Domain Name
(FQDN) or IP address

e The Cisco Unified Communications Manager Application User ID to use
e The Password that corresponds with the Cisco Unified Communications Manager User ID.
and then click Next.

If you are upgrading your Cisco Unified Attendant Console Standard software, this page will contain
your current details.

Note  The following:

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Step 4

Note

Step 5

Step 6

Note

Step 7

Step 8

Step 9

Installing or Upgrading Cisco Unified Attendant Console Standard ||

e Port 443 is used by default. You can change the Cisco Unified Communications Manager
configuration after you have installed Cisco Unified Attendant Console Standard. For instructions,
see Connecting to a Different Cisco Unified Communications Manager, page 4-4.

e Connecting to the Cisco Unified Communications Manager also populates the Primary CTI
Manager. If you want to use a different node as the Primary CTI Manager, you can do this through
the Cisco TSP configuration after installing Cisco Unified Attendant Console Standard.

In the two Security Alert messages, click Yes.

During installation the Cisco Unified Communications Manager TSP appropriate to the Cisco Unified
Communications Manager you intend to use is downloaded. If you intend to use Cisco Unified
Communications Manager release 8.0(1) or later, the TSP is also automatically installed. If you intend
to use Cisco Unified Communications Manager release 7.1(5) you must manually install the compatible
Cisco TSP, as described in Installing and Configuring the Cisco TSP for Cisco Unified Communications
Manager 7.x, page 2-10.

In the Language Information page, select the language you want to use, and then click Next.

If you are upgrading your Cisco Unified Attendant Console Standard software, this page will contain
your current details.

In the Cisco Unified Presence Server Connection Information page, type the following:
e The Server Address
e The Domain containing the server
¢ The Cisco Unified Presence User Name to use
e The Cisco Unified Presence Password appropriate to the User Name
and then click Next.

If you are upgrading your Cisco Unified Attendant Console Standard software, this page will contain
your current details.

Port 5222 is used by default. You can change the Presence configuration after you have installed Cisco
Unified Attendant Console Standard. For instructions, see Connecting to a Different Presence Server,
page 4-3.

In the Choose Destination Location page, either accept the default folder (recommended) or Browse to
the folder in which to install the application, and then click Next.

In the Start Copying Files page, if the details are correct, click Next. If not, click Back and correct the
information.

Cisco Unified Attendant Console Standard is installed.

In the InstallShield Wizard Complete page, select Yes, I want to restart my computer now, and then
click Finish.
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Installing and Configuring the Cisco TSP for Cisco Unified
Communications Manager 7.x

The Cisco TAPI (or Telephony) Service Provider (TSP) enables Cisco Unified Attendant Console
Standard to communicate with the Cisco Unified Communications Manager CTI Manager service, which
provides call control.

Cisco Unified Attendant Console Standard installation also automatically installs the Cisco TSP
appropriate to your Cisco Unified Communications Manager—unless you are using Cisco Unified
Communications Manager Release 7.x, in which case you must manually install the Cisco TSP for that
release.

This appendix describes the following steps:

1. Downloading and Installing the TSP.

2. Configuring the TSP, page 2-11.

3. Installing the Cisco TAPI Wave Driver, page 2-11.

If you need to uninstall the Cisco TSP, follow the instructions in the file C:\Program
Files\Cisco\CiscoTSP.txt, which is created when the TSP is installed. This file also includes instructions
for installing the Cisco TAPI Wave driver.

Downloading and Installing the TSP

Step 1

Step 2

Step 3
Step 4
Step 5
Step 6
Step 7

To download and install the Cisco TSP, do the following:

Use your internet browser to access Cisco Unified Communications Manager Administration, and then
choose Application > Plug ins.

Find the Cisco Telephony Service Provider using the search field (Figure 2-1).

Figure 2-1 Find and List Plugins Search Options

Find and List Plugins

Search Options
Find Plugin where Plugin |Name j |I:|egins with j |Ciscu Telephony Service f
and Plugin Type equals ||nsta|latiun j

In the Search Results, click Download on the Cisco Telephony Service Provider line.

Save CiscoTSP.exe on your desktop.

Double-click the CiscoTSP.exe icon on your desktop and follow the instructions.

During installation, you are asked if you want to install multiple instances of TSP; click No.

After a successful installation, restart your system for the changes to take effect.
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Configuring the TSP

Step 1

Step 2
Step 3
Step 4
Step 5

Step 6
Step 7
Step 8

Note

Step 9
Step 10

Step 11
Step 12
Step 13
Step 14
Step 15

To configure TSP, do the following:

Click the Start button, and then in the Start menu, choose Settings > Control Panel > Phone and
Modem Options.

Select the Advanced tab.
Select CiscoTSPO0O1.tsp.
Click Configure, and then select the User tab.

In User Name, type the User ID of the Cisco Unified Communications Manager Application User
created in Configuring Cisco Unified Communications Manager, page 2-5.

Type the Password, and then again in Verify Password.
Select the CTI Manager tab.

Under Primary CTI Manager Location, select and then type either the IP Address or Host Name of
the CTI Manager to connect to. If a second CTI Manager is available, you can optionally specify a
Backup CTI Manager Location.

The CTI Manager service runs on each CUCM node in a cluster. Your primary CTI Manager should be
on the Cisco Unified Communications Manager publisher, and your backup CTI Manager on the
subscriber.

Select the Wave tab.

Type the Desired number of possible Automated Voice lines. Specify sufficient to allow all your CTI
Ports to be monitored by this TSP. You can specify a larger number to cater for future expansion. To
change the number in the future, you will have to uninstall and reinstall the Cisco TAPI Wave driver.

Click OK.

Select the Advanced tab.

In Provider Open Completed Timeout (secs), type 300.
Click OK.

Reboot the machine.

You now need to install the Cisco TAPI Wave driver.

Installing the Cisco TAPI Wave Driver

Step 1
Step 2
Step 3
Step 4
Step 5

To install the Cisco TAPI Wave driver, do the following, or the equivalent for your operating system:

In Control Panel, double-click Add/Remove Hardware.
In the Add Hardware wizard, click Next.

Select Yes, I have already connected the hardware.
Select Add a New Hardware Device, and then click Next.

Select Install the hardware that I manually select from a list, and then click Next.
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Step6  From the list of hardware types, select Sound, video and game controller, and then click Next.
Step7  When prompted to select the device driver, click Have Disk.

Step8  In the Install From Disk dialog box, Browse to C:\Program Files\Cisco Systems\Wave Drivers, select
the file oemsetup.inf, and then click Open

Step9  Click OK.

Step10 In the Select a Device Driver page, select the Cisco TAPI Wave Driver, and then click Next.
Step11  In the Start Hardware Installation page, click Next.

Step12 If prompted for Digital signature Not Found, click Continue Anyway.

Step13  If prompted The file avaudio32.dll on Windows NT Setup Disk #1 is needed, browse to C:\Program
Files\Cisco\Wave Drivers, and then click OK.

Step14 Click Yes.
Step15 Click Finish.

Step16 When prompted, click Yes to restart your computer.

Licensing Cisco Unified Attendant Console Standard

This section describes how to license your Cisco Unified Attendant Console Standard software under
these scenarios:

¢ Installing Cisco Unified Attendant Console Standard from scratch. For more information, see
Licensing New Installations, page 2-12.

e Upgrading an existing Cisco Unified Attendant Console Department Edition installation to Cisco
Unified Attendant Console Standard. For more information, see Licensing CUAC Department
Edition Upgrades, page 2-14.

~

Note  You do not need to relicense Cisco Unified Attendant Console Standard version upgrades.

This section also describes:
e Activating Purchased or Upgraded Software, page 2-15

e Relicensing Software, page 2-17

Licensing New Installations

When you install Cisco Unified Attendant Console Standard onto a new system (not an upgrade) you
may need to use the following procedures:

e Activating Evaluation Software

e Activating Purchased or Upgraded Software, page 2-15

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Activating Evaluation Software

Step 1

Tip

Step 2
Step 3
Step 4
Step 5

Note
Step 6
Step 7

Note

Step 8

Step 9

Step 10

Step 11
Step 12

You can use downloaded software for 10 days before you must license it. Licensing the software enables
you to activate the software for 60 more days of evaluation. If you do not activate the download, you will
be unable to use it after the tenth day.

To activate the evaluation software, do the following:

Sign into each instance of Cisco Unified Attendant Console Standard that you want to license and
activate, and then do the following:

a. Choose Help > About Cisco Unified Attendant Console Standard.
b. In the information box, click Register.

c. Note the Machine Code. This is the registration code for that instance.

Keep these codes safe, as you require them to activate the 60 evaluation period and to license purchased
software.

Use your internet browser to go the Cisco Unified Attendant Console Downloads and Licensing website.
Enter your User Name and Password, and then click Log In.
In the navigation bar, click ACTIVATE EVALUATION SOFTWARE.

Select your Reseller, then select your Customer, and then select your Customer Site.

If your reseller, customer or site are not available, choose the options to add them.

Select the Version and the Product that you have installed, and then click Next.
Enter the Registration Codes collected in Step 1, and then click Next.

Click # to create new fields for additional codes.

Enter any additional email addresses to receive the registration file, and then click Submit.

If the registration codes are valid, a registration (.RGF) file is e-mailed to you. The .RGF file contains
activation keys and serial numbers for the 60 day evaluation period. The .RGF file can hold licensing
information for multiple instances, but each license needs to be individually applied.

Open the email and save the .RGF file to a location that can be browsed by Cisco Unified Attendant
Console Standard.

In Cisco Unified Attendant Console Standard, do one of the following:
e In the main menu, choose Help > About Cisco Unified Attendant Console Standard.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

In the message box, click Register.
In the License dialog box, either:
a. Select File Registration.

b. Type the name of or browse to the .RGF file.
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c. Click Validate.

or — if you know details of the license for the specific instance you are licensing

a. Select Key Registration.

b. Type an activation key Serial Number, which is included with the license in the .RGF file.
c. Type the corresponding Registration Code.

d. Click Register.

Arc Solutions Software Procurement ADMINISTRATION web site

Licensing CUAC Department Edition Upgrades

If you have an upgrade agreement, you can upgrade any Cisco Unified Attendant Console Department
Edition (version 8.x or 9.x) installations to Cisco Unified Attendant Console Standard. To do so, you
need to obtain the necessary number of Cisco Unified Communications Software Subscription (UCSS)
licenses: one per instance.

If you have the necessary rights, you can obtain the licenses through the S+ Admin Website, where you
can generate licenses one at a time or in groups.

Generating Single Licenses

To generate a single license:

Step 1 User your internet browser to go to the Arc Solutions Software Procurement ADMINISTRATION web site
and choose Licenses > Generate License.

Step2  In Product Family, select Cisco Unified Attendant Console Standard.
Step 3 In Product Name, select Console Selection - CUACS.
Step 4 In Version, select 10.x.
Step5 In License Type, select UCSS.
Step6  Click Add, and then type the license order details:
e Sale Order Number (mandatory)

e Note
e Ship Set
e Line

e Unit Number
Step7  Click Generate Single License.
The License Code (LAC) is displayed.
Step8  Save the LAC for future use.

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Generating Bulk Licenses

Step 1

Step 2
Step 3
Step 4
Step 5
Step 6

Step 7
Step 8

To generate a group of licenses:

Use your internet browser to go to the Arc Solutions Software Procurement ADMINISTRATION web site
and choose Licenses > Bulk Generate.

In Product Family, select Cisco Unified Attendant Console Standard.
In Product Name, select Console Selection - CUACS.

In Version, select 10.x.

In License Type, select UCSS.

Type the Number of License Codes to create (one per instance of Cisco Unified Attendant Console
Standard).

In File Format, select Excel Workbook (.xls).

When prompted open or save the XLS file.

Activating Purchased or Upgraded Software

Note

Step 1
Step 2
Step 3

You can purchase the software at any time in the evaluation period, giving you unlimited use. When you
purchase the software Cisco provides you with a 27-digit license activation code (LAC) for each instance
of the application you have purchased. After activating the software, you cannot revert to the trial
version. If you upgrade your software from Cisco Unified Attendant Console Department Edition, you
must activate it before you can use it.

When you upgrade using UCSS licenses you can convert Cisco Unified Attendant Console Department
Edition license instances into the same number of Cisco Unified Attendant Console Standard instances.
You can upgrade either:

e All the Cisco Unified Attendant Console Department Edition seats into Cisco Unified Attendant
Console Standard at once.

¢ Some of the Cisco Unified Attendant Console Department Edition seats and then upgrade the
remainder later.

For example, if you had a Cisco Unified Attendant Console Department Edition LAC with 10 seats, you
can either activate all 10 LAC codes at once to obtain 10 Cisco Unified Attendant Console Standard
licenses, or you can, say, obtain 5 Cisco Unified Attendant Console Standard licenses today and the
remainder later. Once you have generated at least one license against the Cisco Unified Attendant
Console Department Edition LAC, it becomes disabled and can't be reset.

To activate your purchased or upgraded software, do the following:

Use your internet browser to go the Cisco Unified Attendant Console Downloads and Licensing website.
Enter your User Name and Password, and then click Log In.
In the navigation bar, click ACTIVATE PURCHASED SOFTWARE.
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Step 4

Note

Step 5

Step 6

Note

Step 7

Step 8

Step 9

Step 10

Step 11
Step 12

Select your Reseller, then select your Customer, and then select your Customer Site.

If your reseller, customer or site are not available, click the control to add them.

Select the Version and the Product (CUAC Standard Edition) that you have installed, and then click
Next.

Enter a unique Registration Code (one of the machine codes collected on page 2-13) and License
Activation Code pair for each instance, and then click Next.

Click # to create new fields for any additional pairs of codes.

If all the License Activation Codes are UCSS codes for Cisco Unified Attendant Console Standard, enter
details of the previously used Cisco Unified Attendant Console Department Edition Registration Code
and License Activation Code pairs that you wish to upgrade to Cisco Unified Attendant Console
Standard.

In the License Request Confirmation page, optionally enter an additional e-mail address and click
Submit. If you want to change the codes you entered in Step 6 before proceeding, click Back.

A registration (.RGF) file is e-mailed to you, and license request confirmation information is displayed
in the web page.

Open the email and save the registration file to a location that can be browsed by Cisco Unified Attendant
Console Standard.

In Cisco Unified Attendant Console Standard, do one of the following:
e In the main menu, choose Help > About Cisco Unified Attendant Console Standard.

e Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

In the message box, click Register.

In the License dialog box, either:

a. Select File Registration.

b. Type the name of or browse to the .RGF file.

c. Click Validate.

or — if you know details of the license for the specific instance you are licensing

a. Select Key Registration.

b. Type an activation key Serial Number, which is included with the license in the .RGF file.
c. Type the corresponding Registration Code.

d. Click Register.

Resetting License Codes

The registration codes you gather when activating software incorporate information about the system
that will be running Cisco Unified Attendant Console Standard. If the system changes - for example,
because it has been rebuilt - the parameters will change and the corresponding LACs will no longer work.
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Step 2
Step 3

Step 4

Licensing Cisco Unified Attendant Console Standard 1l

You can reset (recreate) LACs to work on new systems in the following way:

Use your internet browser to go to the Arc Solutions Software Procurement ADMINISTRATION web site
and choose License Management.

Click Verify and Reset LAC.

Search for Cisco Unified Attendant Console Standard LAC details using the LAC Code, or look up the
LAC using one of the following:

e Cisco SO Number

e Registration Code

e User Name

¢ Email Address
The Cisco Unified Attendant Console Standard LAC detail is displayed.
If the LAC has been activated (used), select it and then reset it.

Relicensing Software

If you do any of the following you must re-license the software with a new registration code:

¢ Reinstall the operating system on the same hardware

¢ Install a different operating system on the same hardware

e Add or remove certain hardware (such as an NIC card)

e Change the machine name

e Perform a major upgrade of the Cisco Unified Attendant Console Standard software
And within a VM Environment:

e Copy the VM image

e Perform a major upgrade of the Cisco Unified Attendant Console Standard software

All these cause the license to expire, and the System and User Configuration menus to disappear from
Cisco Unified Attendant Admin.

To re-license Cisco Unified Attendant Console Standard, contact Cisco TAC and request a re-host. You
will need to provide them with either the original license activation codes or the SO number of your
purchase.
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CHAPTER

Starting Cisco Unified Attendant Console
Standard

To start Cisco Unified Attendant Console Standard, do the following:

Step1  Double-click the desktop icon.
In the sign in screen, beneath the banner, a field contains either:
e The extension number of the attendant phone last used to sign in
e The instruction, Enter Extension Number
Step2  To use an existing number, proceed to Step 6.
Step3  To use a new extension number, type the number.

As you type, the application lists those devices defined for signing in that match (for more information
on defining devices, see Managing Sign In Devices, page 4-6). If devices have not been defined, the
Cisco devices assigned to the TSP user on your computer are listed. The more you type, the shorter the
list becomes. The list contains the name, extension number and line for each matching device.

Note  If a list of devices has been configured you can only sign in using one of the numbers in the list.

Step4  To select a number, highlight it in the list and either press Enter or double-click it. You can close the list
and clear the selection by pressing Esc.

Step5  If the sign in extension is part of one or more hunt groups, and you want the application to log you into
them during sign in, select Log in to hunt groups at sign in.

Note  The following:

e If you are already logged into your hunt groups, you do not need to set L.og in to hunt groups at
sign in.

¢ You cannot log in to a hunt group using an extension that is already being used by another Cisco
Unified Attendant Console Standard user.

* You can also log in or out of hunt groups as described in Logging In to Hunt groups, page 3-2 and
Logging Out of Hunt groups, page 3-2.

Step6  Click Sign In or press Enter.

Cisco Unified Attendant Console Standard - User Guide
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The main application user interface appears, ready for you to use.

If there was no device list and you entered the extension number of a valid Cisco device, that device and
all its lines is added to the device list.

While the application is running, you can change the attendant console operator directory number and
whether it is remembered.

Signing Out

To sign out from your current attendant console session, do either of the following:

¢ In the main menu, click the extension number at the top right of the interface, and then select Sign
out of application.

e Use the Ctrl+S keyboard shortcut.

The sign in screen is displayed, and the application continues to run and any synchronization currently
in progress continues. When you sign out you are automatically logged out of any hunt groups to which
you belong.

To resume using the application, sign in as before.

Logging In to Hunt groups

A hunt group is a group of extensions configured so that an unanswered call to any extension gets
forwarded to one of the other lines in the group. Cisco Unified Communications Manager supports hunt
groups, and Cisco Unified Attendant Console Standard enables you to sign in using a device that is part
of one or more hunt groups, so that calls to the groups can be received through your operator phone.

If you are logged out from any hunt groups you will not receive any calls through the groups.

If you are not logged in to the hunt groups of which your extension is part, you can either log in to them
when you sign in to the application (as described on page 3-1), or you can click the extension number at
the top right of the interface, and then select Log in to hunt groups.

While you are logging in to the hunt group (which may take a few seconds) you will not be able to receive
any new calls, but current calls will continue unaffected, and you will be logged in at the end of the
current call.

Logging Out of Hunt groups

If you are logged in to a hunt group, to log out do either of the following:
e Click the extension number at the top right of the interface, and then select Log out of hunt groups.
e User the Ctrl+I keyboard shortcut.

Also, when you sign out you are automatically logged out of any hunt groups to which you belong.

While you are logging out you cannot take calls, but current calls will continue unaffected. You will be
logged out at the end of the current call.
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Exiting Cisco Unified Attendant Console Standard

To exit Cisco Unified Attendant Console Standard, do one of the following:
¢ In the main menu, choose File > Exit.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

e (Click the window close button.

Cisco Unified Attendant Console Standard - User Guide
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Configuring Cisco Unified Attendant Console
Standard

This chapter describes how to configure Cisco Unified Attendant Console Standard.

All the configuration functions are contained within tabbed pages of the Options window, which you
access by choosing File > Options. The following Options tabs are password protected:

Configuration
Directory Filters
Directory Mappings
BLF Rules

Device List

Logging

which means that you must know a valid password to be able to access them. How to set and manage
this password is described in Setting the Options Password, page 4-2.

This chapter also describes the following configuration procedures:

“Setting Operator Details” on page 4-3

“Connecting to a Different Presence Server” on page 4-3

“Connecting to a Different Cisco Unified Communications Manager” on page 4-4
“Setting the Operator Voicemail Prefix” on page 4-4

“Configuring Alerts” on page 4-5

“Managing Sign In Devices” on page 4-6

For details of configuring synchronization with Call Manager, see Configuring Synchronization,
page 5-4.

For details of moving, stretching and hiding parts of the interface, see the Cisco Unified Attendant
Console Standard online Help.

| oL-25988-01

Cisco Unified Attendant Console Standard - User Guide ]



Chapter4  Configuring Cisco Unified Attendant Console Standard

M Setting the Options Password

Setting the Options Password

Step 1

Step 2
Step 3
Step 4
Step 5

Step 6

Step 7

Note

In its default state, all the Options tabs are accessible by any user.
When you set the Options password you prevent access to the Options tabs listed on page 4-1.

To set the Options password, do the following:

In the main menu, choose File > Options.

The Options window appears.

Click the Options Password tab.

Type the Password, and then type it again in Confirm Password (case-sensitive).
Select a Security Question.

Type the Security Answer. If you forget your password, you will be unable to change it without
supplying this answer exactly as typed here (case-sensitive).

Click Apply.
If you have entered any incorrect information, the corresponding field is highlighted.
Close the Options window.

The Options tabs are now inaccessible.

If you leave the Password, Confirm Password and Security Answer fields all empty, you make all
Options tabs accessible.

Resetting the Options Password

Step 1

Step 2
Step 3

Step 4

Step 5

When you reset the Options password you gain access to the Options tabs listed on page 4-1. You can
only reset the Options password if you have already set it.

To reset the Options password, do the following:

In the main menu, choose File > Options.
The Options window appears.
Click the Options Password tab.

In Enter Password, type your password (case-sensitive). If you do not remember your password, click
Reset Password, and then type your Security Answer (case sensitive).

Press Enter or click Apply.
If you have entered any incorrect information, the corresponding field is highlighted.

You can now set your password and security question as described above; all Options tabs are enabled,
and remain so until you close the Options window.
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Setting Operator Details

Step 1

Note

Step 2
Step 3

Note

Step 4

You set your operator details either when you start Cisco Unified Attendant Console Standard or while
it is running.

To set the operator details while Cisco Unified Attendant Console Standard is running, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Operator Details tab.

Under Operator Details, type the Extension of the attendant console operator.

If a Device List is defined (see “Managing Sign In Devices” on page 4-6), the same restrictions as on the
sign in extension apply, but the list is not displayed when you start typing.

Click Apply.

Connecting to a Different Presence Server

Step 1

Note

Step 2
Step 3

Step 4

Once Cisco Unified Attendant Console Standard is installed, you can connect to a different Presence
Server than the one you specified during installation. The Presence Server provides the presence status
of directory contacts; you need to have a valid User and Password to communicate with the server.

To connect to a different Presence Server, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Operator Details tab.
Under Presence Details, edit the following as required:
e The Presence Server Address.
e The Presence Server Port number. By default, this is 5222.
¢ The Domain containing the Presence Server
e The Presence Server User name.
e The Password that corresponds with the User name.
Click Apply.
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The application validates the connection. If this fails, it prompts you for the correct connection details.

Step5  Exit and then restart Cisco Unified Attendant Console Standard for the change to take effect.

Connecting to a Different Cisco Unified Communications
Manager
~

Note  Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

Once Cisco Unified Attendant Console Standard is installed, you can connect to a Cisco Unified
Communications Manager different from the one you specified during installation, and so use a different
source directory. However, the new Cisco Unified Communications Manager must be the same major
revision as the one specified during installation; you cannot upgrade to a later revision using this method.

To connect to a different Cisco Unified Communications Manager, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Step2  Click the Configuration tab.
Step3  Under Call Manager Detail, edit the following as required:
¢ The Cisco Unified Communications Manager Server Address.
e The Cisco Unified Communications Manager Port number. By default, this is 443.
e The Cisco Unified Communications Manager Application Username.
e The Application Password that corresponds with the Username.
Stepd  Click Apply.
If the new CUCM version does not match the currently configured CUCM version a message appears.

Step5  Exit and then restart Cisco Unified Attendant Console Standard for the change to take effect.

Setting the Operator Voicemail Prefix
~

Note  Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.
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Step 1

Note

Step 2
Step 3
Step 4

Configuring Alerts

If your operator uses a separate voicemail number, you define its prefix.

To set the operator voicemail prefix, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Configuration tab.

Under Transfer to Voicemail Option, type the attendant console operator Voicemail Prefix.
Click Apply.

Configuring Alerts

Step 1

Note

Step 2
Step 3

Cisco Unified Attendant Console Standard alerts you when the following events occur (listed in order of
precedence):

1. Call is ended (not by console)
Device is in service (the console device)
Call is ringing at primary device

Call is ringing at secondary device

LA o

Device is out of service (the console device)

6. A system error has occurred

If two or more alerts occur simultaneously, you are alerted about the one with the highest precedence.
Cisco Unified Attendant Console Standard can produce the following visual alerts:

e If the application is not the active window, it becomes the active window and is placed in front of
any other open window, ready for you to interact with it.

e If the application is not the active window, then in the Windows taskbar the application icon flashes.

Procedure

To configure alerts, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Alerts tab.

Under Alerts Detail, for each event, do the following:
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e Select the Taskbar check box if you want the application icon in the Windows taskbar to flash and
be overlaid with an alert symbol when that event occurs.

e Select the Pop-to-Front check box if you want the application window to be displayed in front of
the other windows if minimized to the taskbar when the event occurs.

Step4  Click Apply.

Managing Sign In Devices

Attendants can only sign in to Cisco Unified Attendant Console Standard using a valid Cisco device,
with a device name, extension and line number. For attendants to be able to make calls, the device must
also be associated with the Application User/End user configured in the Cisco TSP.

System administrators define which devices are available for attendants to use; these devices constitute
the Device List, which is accessible using File > Options > Device List. At start-up and during
execution, the application checks whether the devices in the Device List are associated with the
Application User/End User configured in the Cisco TSP.

e If they are not, they are marked as invalid. These have a lighter color in the list, and attendants
cannot make calls using them.

e If they were previously marked as invalid, but are now associated with the Application/End user,
they are marked as valid, and attendants can make calls using them.

Administrators can either manually add devices to the list, or import them from CSV files.

While importing sign in devices from a CSV file, the application checks that each device is associated
with the Application/End User configured in the Cisco TSP. If a device is not associated, it is shown as
invalid in the Device List.

If additional lines are later associated with a sign in device (using Cisco Unified Communications
Manager), they get added to the Device List. After these changes, attendants will still be able to sign in
using the old extension.

Manually Adding Sign In Devices
~

Note  Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To manually add devices:

Step1  Choose File > Options > Device List.
The Device List appears.
Step 2 Under Device List, click Add Devices.

Step3  In Search Devices, type a device name. All devices matching what you type are listed; and the more
characters you type, the shorter the list becomes. Non-Cisco devices are not listed.

Stepd  For each device you want to add, select the Add checkbox.

Cisco Unified Attendant Console Standard - User Guide
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Step 5

Managing Sign In Devices W

If there are multiple lines on the selected device, all the lines are selected and added to device list.

Click Apply.

The devices are added to the Device List.

Importing Sign In Devices

~

Note

Step 1
Step 2

Note

Step 3

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

You can import sign in devices from a CSV file with the format described in CSV Files for Importing
Sign In Devices, page B-3.

To import devices from a CSV file:

Choose File > Options > Device List.
Under Import From CSYV, click Browse and select the file to import.

The file name and path are displayed under File Location.

If you click View Sample you can view the required format of the CSV file for importing login devices.

Click Import Devices.

The file format is validated, and if any devices in the file are non-Cisco, you are informed that they will
no be imported, and then you are prompted to continue. To import the Cisco devices from the file, click
Yes. To abort the process, click No.

The devices are imported and added to the Device List. As the devices are imported, they are checked
against those already listed and any matching devices are ignored.

Deleting Sign In Devices

~

Note

Step 1

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To remove devices:

Choose File > Options > Device List.

In the Device List, click the corresponding X in the Delete column.
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~

m If a device has multiple lines, all are deleted from the list. The device remains in the database.

Step2  In the confirmation message, click Yes.
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m. 0L-25988-01 |



Note

Note

CHAPTER

Directories

Cisco Unified Attendant Console Standard displays one or more directories of contacts. Always
displayed is your corporate directory (shown in the interface as Directory), which is copied from one
or more of the following sources:

¢ Cisco Unified Communications Manager

e A comma-separated-variable (CSV) file. CSV file names have the .csv extension.

The CSV file can be on any shared network location to which Cisco Unified Attendant Console Standard
has read and write access. However, it the file does not include a unique identifier (Primary Key) for each
contact, it needs to be on the machine running Cisco Unified Attendant Console Standard.

Cisco Unified Communications Manager is the usual source of your corporate directory. Up to date
contact information is copied from the source into Cisco Unified Attendant Console Standard by the
synchronization process. For a description of this, see Directory Synchronization, page 5-3.

Directory Groups

You can also view and connect to contacts that are not in your synchronized directory but which you
want to be able to select quickly. These directory groups can contain any combination of the following:

e Contacts imported (copied) from sources other than those listed above. These sources are either CSV
files or Extensible Markup Language (XML) files. For more information, see Importing Contacts
Into Directory Groups, page 5-12.

¢ Contacts you enter yourself. For more information, see Manually Adding Contacts To Directory
Groups, page 5-13.

As well as importing contacts into directory groups, you can also export (copy) directory groups to CSV
files, so that they can be used by other attendants or even in other applications.

The format of CSV files imported/exported is different from that of CSV files used for synchronization.

You cannot amend contact records in the corporate directory. By contrast, directory groups are not
updated by synchronization; and you can amend the contact details they contain.

For more information, see “Directory Groups” on page 5-11.
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The relationships between directories and external information is summarized below.

|
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Legend
1. Cisco Unified Attendant Console Standard.

2. Corporate directory.

3. Directory groups.

4. Cisco Unified Communications Manager.
5.

6.

7. XML file.

8.

9. Import contacts.

10. Export contacts.

11. Manually entered contact.

CSV file for synchronization. For details of the format, see CSV File Formats, page B-2.
CSV file for importing and exporting. For details of the format, see CSV File Formats, page B-2.

Synchronize contacts. Includes applying Directory Filter, Directory Mapping Rules and BLF rules.

] Cisco Unified Attendant Console Standard - User Guide

0L-25988-01 |



| Chapter5 Directories

Directory Synchronization W

Directory Synchronization

Note

The process of copying contacts from your source directories into Cisco Unified Attendant Console
Standard is known as synchronization, because the information in the source and internal directories is
identical at the instant of copying. When synchronization occurs, the contacts from both the Cisco
Unified Communications Manager and the CSV file (if you specify one) are copied into Cisco Unified
Attendant Console Standard. The actual data that is displayed in your corporate directory depends not
only on what is in your sources but also on any directory field mappings, directory filters or BLF rules
you have configured.

If synchronization detects that a contact it is copying is already in Cisco Unified Attendant Console
Standard, it first validates the information (checks that it is correct) and then updates Cisco Unified
Attendant Console Standard with any information that has changed since the last synchronization. If a
synchronization fails mid-process — for example, because of a network failure — it starts again from the
beginning.

The synchronization process needs to know what contact data to copy from the source to your corporate
directory, and it gets this information from directory field mappings; for more information, including
how to set the mappings, see Directory Field Mappings, page 5-6.

You can choose to copy only certain contacts to Cisco Unified Attendant Console Standard by applying
adirectory filter, this ensures that only those contacts that have the characteristics you specify in a series
of directory rules are added to the corporate directory. For example, you can synchronize the contacts
from only a specific department. For more information, see Directory Filtering, page 5-5.

During synchronization you can modify the first part of your contact telephone numbers, so that the
numbers in your corporate directory differ from those in your source directory. For example, you might
have telephone number stored in Cisco Unified Communications Manager as 01189728567, but in the
corporate directory you want to see it as 8567. You achieve this number conversion by creating BLF
Rules, which are applied during synchronization. For more information, see BLF Rules, page 5-7.

The following:

e The converted numbers must match the DNs monitored in TAPI, otherwise the line state will not be
displayed in the directories.

e These converted numbers are used by Cisco Unified Attendant Console Standard when it dials. If
you set up BLF Rules, you also need to set up translations in Cisco Unified Communications
Manager to convert the numbers in Cisco Unified Attendant Console Standard back to the originals,
so that you can call those numbers.

Directory synchronization takes place at regular intervals that you define; and you can configure Cisco
Unified Attendant Console Standard to synchronize with the source directory when you start it (this is
actually the default situation). For more information, see Configuring Synchronization, page 5-4.

| oL-25988-01

Cisco Unified Attendant Console Standard - User Guide ]



Chapter5 Directories |

M Directory Synchronization

Synchronizing From a CSV Source File

When you synchronize from a CSV file, the file structure is first validated. For more information on valid
CSV file formats, see CSV File Formats, page B-2. The first column of the CSV file must contain a
unique identifier, known as a GUID, which identifies that contact as unique. If it does not, Cisco Unified
Attendant Console Standard adds a first, GUID, column.

If your CSYV file does not have a GUID column, and you intend storing it in a shared location that does
not have write access, then before you put it there, you should place it locally and provide read-write
access so that Cisco Unified Attendant Console Standard can add the GUID column.

Configuring Synchronization

~

Note

Step 1

Note

Step 2
Step 3

Step 4

Step 5

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

When you install Cisco Unified Attendant Console Standard, a set of default synchronization parameters
are created, which should work for your installation. However, you can change these parameters to the
values you require.

To configure synchronization, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Configuration tab.
Under Sync Detail, do the following:
a. To synchronize when the application starts, select the Auto Synch Startup check box.

b. In Sync Interval (In Hours), type the interval in hours between automatic synchronizations. The
default is zero.

If you do not want to specify a different Cisco Unified Communications Manager, skip this step.
Otherwise, under Call Manager Detail, edit the following as required:

e The Cisco Unified Communications Manager Server Address.
¢ The Cisco Unified Communications Manager Port number. By default, this is 443.

e The Cisco Unified Communications Manager Application Username. The application user must
have the roles described in Assigning Roles to a User Group or Access Control Group, page 2-6.

e The Application Password that corresponds with the Username.

If you do want to synchronize to a CSV file source, under CSV Detail, Browse to the File Location of
your CSV source, and either type its name or select it, and then click OK.

If you specify a CSV file source, the application synchronizes to both it and any specified Cisco Unified
Communications Manager when you restart the application.
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If you do not have a CSV source, click Clear to clear this field.
To view a sample CSV file, click View Sample.
Step6  Click Apply.

Directory Filtering

A directory filter consists of a series of directory rules that are applied during synchronization to ensure
that only certain contacts are copied to the corporate directory.

Each directory rule can compare one of the following contact details to a text string:
e Department
e Telephone
e Location
The rule makes the comparison according to one of the following conditions:
e Begins with
e Contains
e [sexactly
e Ends with

So, for example, you might only want to copy contacts whose Department Is exactly Sales. This would,
however, exclude anyone whose department is Sales America, for example. Or maybe you want to
synchronize those contacts whose Department Ends with ing, which would copy the contacts from both
Marketing and Engineering (and any other department ending in those letters).

Directory filters can consist of any number of directory rules, combined using these logical operators:
e AND
¢ OR

So, for example, you might have a rule that synchronizes only those contacts whose Department Is
exactly Sales AND their Location Ends with America, so that your corporate directory contains all the
new world sales staff. When you use more than two rules, the AND operator has precedence over OR;
so a rule with the structure X AND Y OR Z is equivalent to (X AND Y) OR Z.

Creating Directory Filters
A

Note  Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To create a directory filter, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Cisco Unified Attendant Console Standard - User Guide
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~

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Step2  Click the Directory Filters tab.
Step3 Do the following, as many times as required until your filter is complete:

a. If this is not the first rule in the filter, select the Link (Logical Operation) to apply between the
previous rule and the one you are about to define.

b. Select the contact Field to compare.
c. Select the Condition to use in the comparison.
d. In Value, type the text to compare with the Field.
e. Click Add.
Step4  Click Apply.

The next time you synchronize with your source, the filter is applied and only those contacts satisfying
the filter are copied to the corporate directory.

Directory Field Mappings

Before you synchronize contacts into Cisco Unified Attendant Console Standard the application needs
to know which contact data fields (source fields) to import from Cisco Unified Communications
Manager or a CSV file, and what destination fields within the application to populate with the data. This
is called defining the directory field mappings.

You can specify separate directory field mappings for the data from your Cisco Unified Communications
Manager and from a CSV file; so, for example, you could import your sales contacts from Cisco Unified
Communications Manager, and your marketing contacts from a CSV file.

When you install Cisco Unified Attendant Console Standard default directory field mappings are defined
for you. You can, however, change these mappings or define your own. How to do these is described in
Setting Directory Field Mappings, page 5-7.

Destination Fields

Cisco Unified Attendant Console Standard supports the following contact destination fields:
e Department
e Directory URI
¢ Email
e First Name
¢ Home Phone
e Last Name
e Location
e Manager

e Middle Name

Cisco Unified Attendant Console Standard - User Guide
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e Mobile

e Telephone (automatically mapped from source)
e User Field 1

e User Field 2

By default, Cisco Unified Attendant Console Standard has mappings set up for synchronizing contacts
from Cisco Unified Communications Manager (CUCM) and CSV files. However, you may wish to
change the default mappings, or define your own.

Setting Directory Field Mappings

~

Note

Step 1

Note

Step 2
Step 3
Step 4

Step 5

BLF Rules

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To set the directory field mappings, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Directory Mappings tab.

Select a Directory Source: CUCM or CSV.

Do the following, as required:

To add a mapping, select the Source Field, Destination Field, and then click Add.

To delete a mapping, click the corresponding Delete symbol, and then in the confirmation message, click
Yes.
Click Apply.

The next time you synchronize with your source, the mappings are applied.

BLF rules are applied during synchronization to convert directory numbers to a different format by
searching for and replacing specific number prefixes. You can define sets of multiple rules to be applied
one after the other during synchronization, and you can define different sets of rules for synchronizing
from Cisco Unified Communications Manager and CSV files.

| oL-25988-01

Cisco Unified Attendant Console Standard - User Guide ]



Chapter5 Directories

I BLFRules

BLF rules are applied in the order they are listed in the BLF Rules List. For example, if the first rule
modifies the number from 01189597895 to 8957, the next rule is applied to the modified number. By
moving rules up or down in the list, you change the order in which they are applied.

Adding BLF Rules

~

Note

Step 1

Note

Step 2
Step 3

Step 4
Step 5
Step 6
Step 7

Step 8
Step 9

Step 10

Step 11
Step 12

Step 13

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To add a BLF rule, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the BLF Rules tab.

A list of all existing BLF rules is displayed. By default, no rules are defined.
Click New Rule.

The BLF Rule Detail page appears.

Type a Rule Name.

In Begins With, type the digits to search for at the start of the number.

In Length, type the number of digits in the original contact number.

In Number of Digits to Remove, type the number of digits to remove from the start of the contact
number.

In Prefix, type the string of digits to replace the ones removed.

If you want to remove non-digit characters (such as +) from the number, specify any not to remove by
typing them (with no separators) in Ignorable Characters.

To remove non-numeric characters from the number — except any you specified in Ignorable
Characters — select the Remove Non-digit Characters check box.

Select the Directory Source: CUCM or CSV.
You can test your rule by doing the following under Test BLF Rule:
a. In Enter a number to test the Rule, type a number, and then click Run Test.

b. Check that the number displayed in Test Results matches your expectations. If not revise the rule
settings.

Click Apply.
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Editing BLF Rules

S

Note

Step 1

Note

Step 2

Step 3
Step 4
Step 5
Step 6
Step 7

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To edit an existing BLF rule, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the BLF Rules tab.

A list of all existing BLF rules is displayed.

Select the rule to edit.

Click Edit Rule to display the BLF Rule Detail page.

Edit the fields, as required. These are described in Adding BLF Rules.
Test the rule, as required.

Click Apply.
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Deleting BLF Rules
N

Note  Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To delete a BLF rule, do the following:

Step1  In the main menu, choose File > Options.

The Options window appears.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Step2  Click the BLF Rules tab.
A list of all existing BLF rules is displayed.
Step3  Select the rule to delete.
Stepd  Click Delete Rule.
Step5  Click Apply.

Reordering BLF Rules
~

Note  Access to the functions described in this section may be restricted by your system administrator, and you

may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

To change the order in which BLF rules are applied during synchronization, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Step2  Click the BLF Rules tab.
A list of all BLF existing rules is displayed.
Step 3 On each rule to move, do the following, as required:
a. Select the rule.
b. To move the rule towards the top of the list, click Move Up.

¢. To move the rule towards the bottom of the list, click Move Down.

Cisco Unified Attendant Console Standard - User Guide
m. 0L-25988-01 |



| Chapter5 Directories

Directory Groups W

Step4  Click Apply.

Directory Groups

Directory groups contains special contacts — including contacts not in your source directory — that you
want to be able to select quickly. You must create your directory group before adding contacts to it. For
details of how to do this, see Creating Directory Groups, page 5-11.

You add contacts to directory groups by either of the following methods:

¢ Importing contacts from CSV files or XML files, as described in Importing Contacts Into Directory
Groups, page 5-12.

e Manually creating contacts, see Manually Adding Contacts To Directory Groups, page 5-13.

You can amend the name of a directory group, and the details of any contact in the group. You can also
export the contacts from directory groups to CSV files,

Creating Directory Groups

You need to create directory groups before you can import data to them.

To create a directory group, do the following:

Step1 Do one of the following:
e Click the Add new directory group (+) control.
e In the main menu, choose Edit > Add directory group.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

The New Directory Group dialog box appears.
Step2  Type a Directory Group Name, and then either click Save or press Enter.

The directory group is added as a new tab in the directory display.

Deleting Directory Groups
~

Note  You cannot delete directory groups while synchronization is in process.

To delete a directory group, do one of the following:

Step 1 Right-click the directory group tab.
Step2  Select Delete Directory Group.

Cisco Unified Attendant Console Standard - User Guide
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Step3  In the confirmation message, click Yes.

or

Step 1 Select the directory group, and then do one of the following:
¢ In the main menu, choose Edit > Delete directory group.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

Renaming Directory Groups

To rename a directory group, do the following:

Step1  Right-click the directory group tab.
Step2  Select Edit Directory Group.
Step3  In the dialog box, type the new group name, and then click Save.

or

Step1 Do one of the following:
e In the main menu, choose Edit > Edit directory group.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

Step2  In the dialog box, type the new group name, and then click Save.

Importing Contacts Into Directory Groups

You can import contacts from the following types of file into an existing directory group.
e XML - for example, one previously exported from Cisco Attendant Console (CAC)
e CSV

For details of the formats of these files, see Appendix B, “Import/Export File Formats”.

~

Note  The following points:

* You cannot import contacts into a directory group while the application is synchronizing to the
corporate directory.

Cisco Unified Attendant Console Standard - User Guide
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Step 1

Step 2

Note

Step 3

Directory Groups W

e When you import from these types of file, no checks are made to see if the contact information
duplicates that in any directory group, including the one that you are importing the data into.

At the start of the import process Cisco Unified Attendant Console Standard validates the file structure
and format. If either is incorrect, you are alerted to the fact and the process is aborted.

You can only import contacts into an existing directory group — either one that already contains contacts,
or a new one created especially for the purpose. See Creating Directory Groups, page 5-11.

To import contacts into a directory group, do one of the following:

Do one of the following:
¢ In the main menu, choose File > Import contacts.
or
a. In the main menu, choose File > Options.
b. In the Options window, click the Import/Export tab.
or
e Right-click in any directory group, and then select Import Contacts.
or

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

Under Import CSV/XML, do the following:

a. In File Name, click Browse and select the file to import.

You cannot type a file name or edit the name of a selected file.

b. Select the File Type.

c. If the Directory Group to receive the contacts is not correct, select the correct one.
d. Click Import Contacts.

The import progress is displayed.

When the import is complete, close the dialog box.

Manually Adding Contacts To Directory Groups

~

Note

Step 1

You can manually add contacts to directory groups.

You cannot manually add contacts to your corporate directory.

To add a contact to the displayed directory group, do the following:

Do one of the following:
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Cisco Unified Attendant Console Standard - User Guide ]



Chapter5 Directories

M Directory Groups

Step 2

Step 3
Step 4
Step 5

Note

Step 1
Step 2

Step 3

e Right-click the directory group contact listing, and then select Add Contact.
e Select the directory group and do either of the following:
— In the main menu, choose Edit > Contacts > Add contact.

— Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

The Contact dialog box appears.

Type the contact information, which is described in Destination Fields, page 5-6. You can also enter a
contact Note.

Click Save.
In the confirmation message, click OK.

When you have finished adding contacts, close the Contact dialog box.

Alternatively, you can drag (copy) contacts from the corporate directory or another directory group, and
then drop them into the target directory group.

This creates a duplicate contact in the directory group. Take care not to create multiple duplicates.

To drag contacts into a directory group:

Display the directory containing the contact to copy.

Select the contact and then, holding the mouse button, drag the contact over the appropriate directory
group tab to list its contents.

Drag the contact into the list, and then drop it.

Deleting Contacts From Directory Groups

~

Note

Step 1
Step 2

You can delete contacts from directory groups.

You cannot delete contacts from your corporate directory.

To delete a contact from the displayed directory group, do the following:

Select the contact to delete.
Do one of the following:
e Right-click and then select Delete Contact.
¢ In the main menu, choose Edit > Contacts > Delete contact.

e Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.
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Step 3

Directory Groups

In the confirmation message, click Yes.

Editing Contacts In Directory Groups

~

Note

Step 1
Step 2

Step 3
Step 4
Step 5

You can edit the information belonging to a contact in a directory group.

You cannot edit contacts that have been synchronized into the corporate directory.

To edit a contact in a directory group, do the following:

Open the relevant group and display the contact.

Do one of the following:

Right-click the contact, and then select Edit Contact.
In the main menu, choose Edit > Contacts > Edit contact.

Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.

The Contact dialog box appears.

Edit the contact information, which is described in Destination Fields, page 5-6.

Click Save.

In the confirmation message, click OK.

Exporting Contacts From Directory Groups

Step 1

You can export a directory group into a preexisting CSV file.

To export a directory group, do the following:

Do one of the following:

In the main menu, choose File > Export contacts.

or

In the main menu, choose File > Options.

In the Options window, click the Import/Export tab.

or

Right-click in any directory group, and then select Export Contacts.
or

Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 6-2.
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Step2  Under Export CSV do the following:

b.

In File Name, click Browse and navigate to the target folder.

Either type a file name (to create a new CSV file) or select an existing file to export to. If you select
an existing file you are prompted to overwrite it; click Yes to overwrite the file.

Select the Directory Group to export.
Click Export Contacts.
The export progress is displayed.

Viewing and Using Directories

The bottom part of the interface consists of the directories and their associated controls. For example:

1 2
| Search Results ‘ ‘ mkhan1 3 K dkjhjhgfsadlkjgsue + 4
| Last Name First Name Telephone & Department Notes 6 %
7 @ § CallManager34540 sama34540 34540 Phase2
CallManager51700 Cisco51700 51700 ucs
8 0 Name107717 User 107717 146716 Sales
CallManager14937 sam14937 14937 Phase2
CallMananarR2253 CisroR7253 RI7R3 Lics ™

Legend

1. Search — type details of the contact to search for.

2. Search Preferences — define which contact information to search.

3. Directory tabs — select the directory to display. Includes both corporate directory and directory
groups.

4. Create a new directory group.

5. Column headings — identify the data and enable you to change the column order and the contact sort
order. These are described below.

6. (Visible only when viewing a directory group) Add contacts to the group.

1. Phone state — the state of the contact’s phone, such as Ringing, On hook, and Do not disturb.

8. Presence state — this mimics a Jabber or CUPC client, where a symbol indicates the real-time status

of the contact, such as Available, Do not disturb, and Away. All other contacts have their
subscriptions opened only when displayed in the Directory pane.

The following columns of information are displayed for each contact:

Last Name — the contact’s last name.

First Name — the contact’s first name.
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e Telephone — the contact’s telephone number.
e Department — the contact’s department.
e Notes — about the contact.

If the contact was imported or manually entered into Cisco Unified Attendant Console Standard you can
edit this information.

Changing the Directory View

You can change the order of the columns by using your mouse to select a column heading and then
dragging it to another place in the table.

When the data is first displayed it appears in its default order, as copied from the Call Manager. You can
change the alphanumeric sort order of the table rows by clicking any column heading — the table will be
sorted according to the data in that column. The small arrowhead at the top of the cell shows the direction
in which the column is sorted: an up-arrow for ascending (normal alphanumeric) order, a down-arrow
for descending (reverse) order, and no arrow for default order. Repeatedly clicking the column heading
toggles you through these sort modes.

Searching For Contacts

You can search for contacts in any open directory (the corporate directory and any directory groups you
are displaying). Details of matching contacts are shown under the Search Results directory tab.

You can search any of the following contact detail fields:
e First Name
e Last Name
e Directory Number
e Department

You can disable the ability to search any of these fields by setting the Search Preferences. These are
described in Search Preferences, page 5-17.

You do not need to specify which field you want to search: the string you type in the Search field is
matched against all of them. So, for example, if you have a Sales department, and a staff member with
the last name Saunders, searching for the characters Sa, will display all the matching last names (and
first names) and list everyone in Sales.

Searching begins as soon as you start typing; and the more characters you type, the fewer contacts will
match. When the contact you require is displayed, select it and then use the controls interface to
communicate with that contact.

Search Preferences

The Search Preferences enable you control what fields are searched and what contacts are displayed.

You can restrict which contact detail fields are searched using the Searchable Fields. De-select (clear)
any you do not want to search:

¢ First Name

e Last Name

| oL-25988-01
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¢ Telephone
¢ Department
You can also limit which contacts are displayed in the search results using these Filters:

e Has Telephone — Display only those contacts with a directory number (DN) assigned. All other
contacts are filtered out (excluded) from the search results.

e Has Emails — Display only those contacts with an email address assigned. All other contacts are
filtered out (excluded) from the search results.

Setting Search Preferences
To set the search preferences, do the following;

Step 1 Click Search Preferences.
Step2  In the Search Preferences dialog box, select the required check boxes.
Step3  Click Save.

Step 4 In the confirmation message, click OK.

Viewing Contact Information

The directory display contains basic information about each contact. You can view more information
about a selected contact by viewing their contact details. How you view contact details depends on
whether the contact is in the corporate directory or a directory group.

To view a contact’s details, do the following:

Step 1 Display the directory containing the contact.
Step2  Right-click the contact.
Step3 Do one of the following, as appropriate:
e If the contact is in the corporate directory, click View.
e If the contact is in a directory group, click Edit Contact.
The Contact dialog box is displayed.

If you are viewing the details of a contact in a directory group, you can also edit the details, as described
in Editing Contacts In Directory Groups, page 5-15.

Stepd  When you have finished viewing the information, click Cancel.

Cisco Unified Attendant Console Standard - User Guide
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Contact Notes

Contact Notes

You can add notes to any contact record in the main directory, the search results, or any directory group.
The notes are text containing additional information about the contact. Notes are stored in the database
and are available whenever you sign in. If you delete a contact - for example by applying BLF rules -
any contact notes are also deleted. If you export a contact, their notes are also exported, and if you import
a contact with notes, they are visible in the application.

Adding Contact Notes

To add contact notes:

Step 1 Select the contact to add notes to.
Step2  Either:
¢ Right-click the contact, and then choose Contact Notes.
¢ Choose Edit > Contacts > Contact Notes.
The Contact Notes dialog box appears.

Step3  In the text box, type the notes and then either click Save or tab to the control and press Enter to add the
notes to the contact.

Note  You must enter some text for you to be able to save it.

The notes appear in the contact’s Notes column.

Editing Contact Notes

You can edit existing contact notes. To do so, follow the Adding Contact Notes procedure, but edit the
existing notes.

Deleting Contact Notes

To delete existing contact notes:

Step 1 Select a contact with notes to delete.

Step2  Either:
e Right-click the contact, and then choose Delete Notes.
¢ Choose Edit > Contacts > Delete Notes.

Note  These menu options are disabled if there are no notes to delete.

Cisco Unified Attendant Console Standard - User Guide
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Step3  The notes are deleted from the contact Notes column.
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CHAPTER

Keyboard shortcuts enable you to quickly do things in the interface without needing to use the mouse or

menus.

The application comes configured with the following keyboard shortcuts.

Action Shortcut
Dial Ctrl+D
Answer Ctrl+A
End Call Ctrl+H
Hold Call Ctrl+L
Transfer Call (Blind transfer) Ctrl+X
Consult Transfer (speak to destination before transfer) |Ctrl+T
Direct Transfer Ctrl+R
Join Call Ctrl+J
Park Call Ctrl+P
Start Conference Ctrl+N
Access Voicemail Ctrl+O
Sign out of application Ctrl+S
Log out of hunt groups Ctrl+I
Open Help F1

In addition, you can define shortcuts for the following actions:

¢ Resume Call

e Retrieve Parked Call
e Email

e Options

e Import contacts

e Export contacts

e Exit

e Keyboard Shortcut Options

| oL-25988-01
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~

Note

Defining and Editing Keyboard Shortcuts

To define or edit a keyboard shortcut, do the following:

Step 1

Step 2
Step 3
Step 4

Step 5

View Contacts

Add Contact

Edit Selected Contact

Delete Selected Contact

Add Directory Group

Edit Selected Directory Group
Delete Selected Directory Group
View Contact

Open Call Control Pane

Open Parked Calls Pane

Open Call History Pane

Open Directory Pane

Lock Pane Layout

Revert to Default Layout
Load Saved Layout

Save Current Layout

Open Text Size Options

Open About Box

You cannot use the same keyboard shortcut for more than one action.

Do either of the following:

.
or
a.
b.

C.

In the main menu, choose Edit > Keyboard Shortcuts.

In the main menu, choose File > Options.

The Options window appears.

Click the Keyboard Shortcuts tab.

Select the Action to define. This can be an action that already has a shortcut.

Click Set Shortcut.

Type the shortcut you require. For example, to set an action to Ctrl+Y, simply type Ctrl+Y (press and
hold the Ctrl key and then press the Y key).

Click Apply.
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Removing Keyboard Shortcuts

To remove a keyboard shortcut, do the following:

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts,
page 6-2.

Step2  Select the action from which to remove the keyboard shortcut.
Step3  Click Clear Shortcut.
Step4  Click Apply.

Resetting Shortcuts to their Default Values

To reset keyboard shortcuts to their default values, do the following:

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts,
page 6-2.

Step2 Do one of the following, as appropriate:
To reset all keyboard shortcuts to their default values, click Reset All Shortcuts to Default.
To reset a single keyboard shortcut to its default value:
a. Select the action to reset.
b. Click Reset Shortcut.
Step3  Click Apply.

Cisco Unified Attendant Console Standard - User Guide
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Step 1

Note

Step 2
Step 3

APPENDIX A

Configuring Logging

Access to the functions described in this section may be restricted by your system administrator, and you
may need a password to access the necessary Options tab. For more information, see Setting the Options
Password, page 4-2.

Cisco Unified Attendant Console Standard can keep a log of all event that occur within the application.
This information can be used to gauge the application’s configuration and performance, and to help
troubleshoot any errors. You can control which application subsystems are monitored, which events are
logged, and the size and number of the log files.

To configure logging, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Click the Logging tab.
Set the following, as required:

e Type the Max Size RollBackups, which is the maximum number of log files to store before you
re-use (overwrite) the first one. This works in conjunction with Maximum File Size (In MBs).

e Type the Maximum File Size (In MBs). When the file gets this size it is closed and a new log file
is opened. Works in conjunction with Max Size RollBackups.

e Select the Logging Level. This is the default amount of detail that will be written into the log file.
Detail decreases in the following order:

- DEBUG
- INFO
- WARN
- ERROR
- FATAL
The level you set is applied to all the modules grouped below.

e Under Modules Setting, set the logging level for each module to override the default value.
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Step4  Click Apply.
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Import/Export File Formats

Cisco Unified Attendant Console Standard can handle contact directory files in the following formats:
e XML File Format, page B-1
e (CSV File Formats, page B-2

It can also import login devices from CSV files, with the format described in CSV Files for Importing
Sign In Devices, page B-3.

XML File Format

XML files that you import into Cisco Unified Attendant Console Standard must have the following
format:

<SpeedDialUsers>
<G n="Sample Group">
<E>
<N>Jim Kathirine</N>
<T>25421</T>
<M>Jim@cisco.com</M>
<D>Jim@cisco.com</D>
<O0>This is a sample entry</0>
<P>00443454332</P>
<H>0044556634</H>
<S>Reading</S>
<A>TIT</A>
<R>Jason Rumsey</R>
<U>Software Engineer</U>
<V>Management</V>
</E>
</G>
</SpeedDialUsers>

Tags

e <SpeedDialUsers> = the file contains XML data for import into Cisco Unified Attendant Console
Standard.

¢ <G> = Directory group name
¢ <E> = Individual contact

e <N>= Name

e <T> = Telephone number

e <M> = Email address

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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¢ <D> = Directory URI

e <0O>=Note

e <P> = Mobile

e <H> = Home phone number
e <S> =Site

* <A> = Department

¢ <R> = Manager

¢ <U> = UserFieldl

® <V> = UserField2

CSV File Formats

Cisco Unified Attendant Console Standard handles two types of comma-separated value (CSV) files:
e (CSV Files for Synchronization
e (CSV Files for Directory Import and Export
These files differ in the number of data fields they contain in each contact record.
All CSV files used by Cisco Unified Attendant Console Standard must have the following format:
e FEach contact is on a single line.
¢ Empty comma-separated values are valid.

e Lines starting with # or ; are comments and are ignored. Empty and blank lines are also ignored.

CSV Files for Synchronization

In a CSV file for synchronization, the data for each contact must be in the following order:

Last Name, First Name, Telephone Number, Department, User Field 1, User Field 2, Site,
Building, Directory URI.

For example:

# * Copyright (c) 2014 by Cisco Inc.

# * All rights reserved.

#

# Here is a sample corporate directory file. It should contain
# comma separated entries, one line per user in the directory
# The values should in the following format:

#

# Last Name, First Name, Telephone number, Department, User Field 1, User Field 2, Site,
Building, Directory URI

#

# Empty values are legal (no department etc.)

#

# Lines starting with '#' or ';' are treated as comments

# and ignored. Empty or blank lines are ignored as well
Kathirine,Jim, 25421,Marketing,,,,,Jim@cisco.com

Martha, Bryan, 87952, Support, ,,, ,martha@cisco.com

Luce,Richard, 2548,Marketing,,,,, luce@cisco.com

Meriall, Thomas, 8763,Marketing,,,, ,meriall@cisco.com
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Harye,Walter,5563,Marketing,,,, ,harye@cisco.com

CSV Files for Directory Import and Export

In a CSV file for directory import or export, the data for each contact must be in the following order:

Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle
Name, Mobile, Home Phone, Site, Department, Manager, User Field 1, User Field 2.
For example:

# * Copyright (c) 2014 by Cisco Inc.

# * All rights reserved.

#

# Here is a sample import file. It should contain

# comma separated entries, one line per user in the directory

# The values should be in the following format:

#

# Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle Name, Mobile,

Home Phone, Site, Department, Manager, User Field 1, User Field 2

Empty values are legal (no email etc.)
Lines starting with '#' or ';' are treated as comments

#
#
#
#
# and ignored. Empty or blank lines are ignored as well

Kathirine,Jim, 25421, This is a sample entry, Sample Group
00443454332,0044556634,Reading, IT,Martin Taylor, Support
Martha, Bryan, 87952, This is a sample entry.,Sample Group
00443454335,0044556635,Reading, IT,Martin Taylor, Support

Luce,Richard, 2548, This is a sample entry, Sample Group 2,

1,Jim@cisco.com,Jim@cisco.com,Maid,
Engineer, Senior
1,martha@cisco.com,martha@cisco.com, Aryan,
Engineer,Junior

luce@cisco.com, luce@cisco.com, Tace,

00443454339,0044556636,Reading, R&D,Jason Rumsey, Software Engineer,Management

Meriall, Thomas, 8763, This is a sample entry, Sample Group

2,meriall@cisco.com,meriall@cisco.com, Kate,

00443454331,0044556637,Reading, R&D, Jason Rumsey, Software Engineer,Junior

Harye,Walter,5563,This is a sample entry, Sample Group 2,

harye@cisco.com, harye@cisco.com, Heather,

00443454333,0044556638,Reading, R&D, Jason Rumsey, Software Engineer, Senior

CSV Files for Importing Sign In Devices

You can import devices that operators use to log into Cisco Unified Attendant Console Standard, as

described in Importing Sign In Devices, page 4-7.
These CSV files have the data for each device in the following format:
Line number

Device name, Extension,

For example:

* Copyright (c) 2014 by Cisco Inc.
* All rights reserved.
Here is a sample device list file. It should contain
comma separated entries, one line per device in the device list.
The values should in the following format:

DeviceName, Extension, LineNumber

Empty values are not allowed (no DeviceName etc.)

H H o F o FH H H H I I I

Lines starting with '#' or ';' are treated as comments

| oL-25987-01
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# and ignored. Empty or blank lines are ignored as well

SEP2893FE130280,5868,1
SEP2893FEA2D22A,5873,1
SEP000C299DA714,5870,1
SEP88AE1DBOF66C, 5869, 1
SEP00141C48DDD9, 5859,1
SEP00141C48DDD9, 5870, 2

Note Any devices in the file that lack one or more of the fields Device name, Extension, or Line number are
considered non-Cisco devices and will not be imported.
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Phones Supported by Cisco Unified Attendant
Console Standard

Cisco Unified Attendant Console Standard supports the following phones:

Phone Type Supported
3905 Not as Console and cannot support BLF, but can transfer.
3911

3951

6901 Not tested
6911 Yes

6921 Yes

6941 Yes

6945 Yes

6961 Yes

7821 Yes

7841 Yes

7861 Yes

7902 Not tested (Obsolete)
7905 Yes

7906 Yes

7910 Yes

7911 Yes

7912 Yes

7920 Yes

7921 Yes

7925 Yes
7925G Yes
7925G-EX Yes

7926 Yes

7931 Yes
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Phone Type Supported

7940 Yes

7941 Yes

7941G-GE Yes

7942 Yes

7942-G Yes

7945 Yes

7945G Yes

7960 Yes

7961 Yes

7961G-GE Yes

7962 Yes

7965 Yes

7965G Yes

7970 Yes

7971 Yes

7975 Yes

8941 Yes

8945 Yes

8961 Yes

9951 Yes

9971 Yes

Cisco CSF Yes

DX650 Yes

IP Communicator |Yes

Jabber Yes - standard Jabber installations (locally installed on the
operator computer) and VXME installations (installed in a
VXME environment) are supported as operator devices and
end points.
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