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About This Guide

This guide describes how to install and configure Cisco Unified Attendant Console Standard.

Who Should Read This Guide

This guide is for deployment engineers, system administrators, and anyone else who installs or
configures Cisco Unified Attendant Console Standard. You should have a knowledge of how to configure
the Cisco Unified Communications Manager used by the application.

How This Guide is Organized

This guide contains the following sections.

Section Contains

Chapter 1, “Introduction to Cisco Unified Introduction to Cisco Unified Attendant Console

Attendant Console Standard” Standard

Chapter 2, “Installing Cisco Unified Attendant |Preparing Cisco Unified Communications Manager

Console Standard” and installing Cisco Unified Attendant Console
Standard

Chapter 3, “Starting Cisco Unified Attendant Starting Cisco Unified Attendant Console Standard

Console Standard” and configuring operator details

Chapter 4, “Directories” Using and controlling directories

Chapter 5, “Keyboard Shortcuts” Setting up keyboard shortcuts

Appendix A, “Configuring Logging” Configuring application logging

Appendix B, “Import/Export File Formats” Formats of import and export files

Appendix C, “Phones Supported by Cisco List of supported Cisco phones

Unified Attendant Console Standard”

Cisco Unified Attendant Console Standard - User Guide
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Document Conventions

The following textual and typographic conventions are used in this document:

N

Note

pe

Tip

A

Convention

Usage

bold font

Commands, keywords and user-entered text appear in bold type.

italic font

Document titles, new or emphasized terms, and arguments for which you supply values
are in italic font.

[l

Elements in square brackets are optional.

{(x|y]z} Required alternative keywords are enclosed in braces and separated by vertical bars.

x|y]lzl] Optional alternative keywords are enclosed in square brackets and separated by vertical
bars.

string A non-quoted set of characters. Do not use quotation marks around the string or the

string will include the quotation marks.

courier font

Terminal sessions and information the system displays appear in courier font.

Means reader take note.

Means the following information will help you solve a problem.

Caution

Means reader be careful. In this situation, you might do something that could result in equipment
damage or loss of data.

Timesaver

A

Warning

Means the described action saves time. You can save time by doing what is described in the paragraph.

Means reader be warned. In this situation, you might do something that could result in bodily injury.

Obtaining Documentation and Submitting Service Requests

For information on obtaining additional documentation and submitting service requests, see the monthly
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical
documentation, at http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS Version 2.0.

] Cisco Unified Attendant Console Standard - User Guide
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CHAPTER 1

Introduction to Cisco Unified Attendant Console
Standard

Cisco Unified Attendant Console Standard is a Microsoft Windows-based operator attendant console
application for use with Cisco Unified Communications Manager (CUCM). For details of the supported
versions, see Cisco Unified Communications Manager Compatibility, page 2-3. Cisco Unified Attendant
Console Standard supports up to 5000 contacts on a single instance, and up to 100 instances can be
supported per CUCM cluster.

Cisco Unified Attendant Console Standard enables you to do the following:

Control calls on your local IP Phone, XMPP client (such as Jabber), or Cisco IP Communicator
Make, answer and end calls

Hold and resume calls

Blind/consult transfer calls to directory contacts or voicemail, or any other valid number

Direct transfers

Join calls

Set Call Forward and Do Not Disturb on the operator phone

Park calls

Create and manage conference calls

Import custom directories of contacts not in your Cisco Unified Communications Manager directory
Create custom directories (directory groups) and export them to share with other operators

Synchronize Cisco Unified Attendant Console Standard’s corporate (main) directory with a CUCM
or CSV file source directory

During synchronization with your source directory:
— Map the fields from your source directory to the ones in the corporate directory
- Filter contacts, so that only certain ones are added to the corporate directory
— Modify contact numbers using BLF rules

See the line state and presence of each contact

View call history

Online help on the application is available. For how to display the help, see Accessing Help on the
Application, page 1-3.

| oL-25988-01
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W Cisco Unified Attendant Console Standard User Interface

Accessibility for Users with Disabilities

The Cisco Unified Attendant Console Standard user interface and controls are described in Cisco
Unified Attendant Console Standard User Interface, page 1-2.

Cisco Unified Attendant Console Standard incorporates the following features to make it easier for blind
and visually impaired people to use it:

e Most functions can be accessed using either the mouse or keyboard. You can define keyboard
shortcuts for the most frequently used functions. For more information, see Chapter 5, “Keyboard
Shortcuts”.

® You can set the size of call and directory text in the interface.
e A tooltip is displayed for each graphical interface control when you point to it

For more information on the Cisco Accessibility Program visit
http://www.cisco.com/web/about/responsibility/accessibility/contact.html.

Cisco Unified Attendant Console Standard User Interface

You use the Cisco Unified Attendant Console Standard interface to do all the standard operator tasks,
including making calls, putting calls on hold, and conferencing calls.

An example of the user interface is shown below:

¥ Cisco Unified Attendant Console Standard !
atlvalee . . ~
cisco File FEdit View CallControls Help

Call Control Parked Calls 3

0 300446 A E = Park Extension Caller ID Parked by Duration

o 300500

Call History 4 X

Status From To Time. _‘

=
Received 1026 (Qureshi, Zeshan) 300446 (taylor, Martin) 2013-11-25 16:20 ‘

Received 1026 (Qureshi, Zeshan) 300446 {taylor, Martin) 2013-11-25 1619 |+

Search 6
Preferences

Search Results =t Sample 1 4 T
Last Name First Name e Department
Al Imean b
taylor Martin
Qureshi Zeshan

Webber Mark

The legend is on the next page.

Cisco Unified Attendant Console Standard - User Guide
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| Chapter1 Introduction to Cisco Unified Attendant Console Standard

Accessing

Legend

Accessing Help on the Application

# |Name

Contains

1 [Main menu

Controls for using and configuring the application.

Many of the controls here are also available when you right-click
specific parts of the interface. For example, controls relevant to the
directories are displayed when you right-click in the directory pane.

2 |Call Control pane

Active call information on any line on the console phone. The calls in
progress are displayed here, along with their status, duration, and
controls for frequently used actions, such as transferring or ending the
call.

3 |Parked Calls pane

Active parked calls, by default displayed in the order in which they
were parked.

This pane shows the park extension used, the identities of both the
caller and the DN that parked the call, and how long the call has been
parked.

4 |Call History pane

Completed calls in the current session, by default listed in reverse
chronological order. You can change the order in which completed
calls are listed.

This pane is not displayed by default; use View > Show Call History
to display it.

5 |Search box

Tool in the header bar of the Directory pane for finding contacts by last
name, first name, department and number.

6 |Set search preferences

Control how searches are conducted.

7 |Add new directory group

Control for creating a new directory group.

8 |Add contact

Only available for directory groups. Control for adding contacts to
directory groups.

9 |Directory pane

Displays the synchronized directory, directory groups and search
results. Includes Search box and controls for creating directory
groups. Contact information includes line state and presence. For
more information, see Chapter 4, “Directories”.

You control the interface using both your mouse and keyboard. Many things that you can do with the
mouse you can also do using your keyboard, provided that the application interface is selected.

Help on the Application

You can display help about Cisco Unified Attendant Console Standard by doing one of the following:

e In the main menu, choose Help > Cisco Unified Attendant Console Standard Help.

e Press F1.

The Help contains the following to make it easy to find what you need to know:

e Text search tool
e Index

e Contents list.

| oL-25988-01

Cisco Unified Attendant Console Standard - User Guide ]



Chapter1 Introduction to Cisco Unified Attendant Console Standard |

M Accessing Help on the Application
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CHAPTER

Installing Cisco Unified Attendant Console
Standard

To install Cisco Unified Attendant Console Standard you must do the following:

1.

2.

Ensure that the PC running it satisfies the minimum hardware and software requirements. These are
described below.

Within Cisco Unified Communications Manager, create an Application User with associated
phones. If you intend to use the presence facility within Cisco Unified Attendant Console Standard,
you must also set up an End User. For instructions, see Configuring Cisco Unified Communications
Manager, page 2-4.

Install the Cisco Unified Attendant Console Standard software. For instructions, see Installing Cisco
Unified Attendant Console Standard, page 2-8.

PC Hardware and Software Requirements

The PC running Cisco Unified Attendant Console Standard has the following minimum hardware
requirements:

2.4 GHz Core 2 Duo

4 GB RAM

10 GB hard drive

CD-ROM/DVD-ROM

100 Mbps network card, connected to the network using TCP/IP
SVGA (1024x768) display card

Keyboard with 10-key number pad recommended

[ oL-25987-01
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Chapter 2 Installing Cisco Unified Attendant Console Standard |

M PC Hardware and Software Requirements

Operating System Support

Cisco Unified Attendant Console Standard is supported under the following operating systems:
e Windows XP 32-bit
e Windows Vista 32-bit

¢ Windows 7 32-bit — integration with Cisco Unified Communications Manager version 7.1(5) is not
supported under this operating system

e Windows 7 64-bit — integration with Cisco Unified Communications Manager versions 7.1(5),
8.0(1) or 8.0(3) is not supported under this operating system

Windows 8 64-bit — you can only integrate with Cisco Unified Communications Manager version
10.0(1) under this operating system

S

Note  The following points:

¢ Cisco Unified Attendant Console Standard is not supported under the following operating systems:
- Windows 2000
- Windows 2003
— Windows 2008 R1 (32-bit)
— Windows 2008 (64-bit)
- Windows 2012

e If your machine uses a 64-bit operating system, you cannot run Cisco Unified Attendant Console
Standard against Cisco Unified Communications Manager version 7.1(5), as this does not support
the 64-bit TSP required for the systems to be able to communicate with each other.

Network Requirements

The computer running Cisco Unified Attendant Console Standard must be able to access the Cisco
Unified Communications Manager and the Cisco Unified Presence (CUP) Server. By default, these use
the following two-way TCP ports:

¢ (Cisco Unified Communications Manager — Port 443
e Cisco Unified Presence (CUP) Server — Port 5222

If you have a firewall on your computer, you must configure firewall exceptions for these ports or for
any alternatives you may use in your installation.

Scalability

Cisco Unified Attendant Console Standard supports up to 5000 contacts on a single instance, and up to
100 instances can be supported per Cisco Unified Communications Manager cluster.

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
m. 0L-25987-01 |
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Installing Cisco Unified Attendant Console Standard

Cisco Unified Communications Manager Compatibility ||

Cisco Unified Communications Manager Compatibility

Note

Cisco Unified Attendant Console Standard is supported with the following Cisco Unified
Communications Manager versions:

e 7.1(5) — not supported when running under Windows 7 32-bit, or under 64-bit operating systems.
Cisco Unified Presence 7.1(5) is not supported.

e 8.0(1) — not supported when running under 64-bit operating systems
e 8.0(3) — not supported when running under 64-bit operating systems
e 8.5(1) — supported on SU1 and above

e 8.6(1)

e 8.6(2)

e 9.0(1)

e 9.1(1)

e 90.1(2)

e 10.0(1) — the only Cisco Unified Communications Manager version supported under Windows 8
64-bit

If you are using Cisco Unified Communications Manager Release 8 or later, the TSP and New Cisco
Media Driver are automatically installed and activated when you install Cisco Unified Attendant
Console Standard. However, Cisco Unified Communications Manager Release 7.1.5 does not support
this silent TSP installation, and you must manually download and install the appropriate TSP and Cisco
TAPI Wave driver according to the instructions in Installing and Configuring the Cisco TSP for Cisco
Unified Communications Manager 7.x, page 2-9.

The 32-bit version of TSP is required when running Cisco Unified Attendant Console under a 32-bit
operating system. The 64-bit version of TSP is required when running Cisco Unified Attendant Console
under a 64-bit operating system. Consequently, 64-bit installations are supported only in conjunction
with Cisco Unified Communications Manager versions later than 8.0(3).

Cisco Unified Attendant Console Standard also integrates with the Cisco Unified Presence Server.

[ oL-25987-01
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Chapter 2 Installing Cisco Unified Attendant Console Standard |

M Configuring Cisco Unified Communications Manager

The operating system and Cisco Unified Communications Manager (CUCM) version compatibility is
summarized below:

Cucm Windows XP Windows Vista |Windows 7 Windows 7 Windows 8
Version 32-bit 32-hit 32-bit 64-bit 64-hit

7.1(5)! Supported Supported Not supported |Not supported |[Not supported
8.0(1) Supported Supported Supported Not supported |Not supported
8.0(3) Supported Supported Supported Not supported |Not supported
8.5(1)2 Supported Supported Supported Supported Not supported
8.6(1) Supported Supported Supported Supported Not supported
8.6(2) Supported Supported Supported Supported Not supported
9.0(1) Supported Supported Supported Supported Not supported
9.1(1) Supported Supported Supported Supported Not supported
9.1(2) Supported Supported Supported Supported Not supported
10.0(1) Supported Supported Supported Supported Supported

1. CUP 7.1(5) not supported.
2. CUCM 8.5(1) supported on SUI and above.

Configuring Cisco Unified Communications Manager

Cisco Unified Attendant Console Standard must be able to communicate with the Cisco Unified
Communications Manager, which it does using Cisco Unified Communications Manager TSP.
Consequently, before you install Cisco Unified Attendant Console Standard you must first perform the
following steps:

1. Depending on the version of Cisco Unified Communications Manager you are using, either:

— Creating a User Group (CUCM 7.x and 8.x), page 2-5 — instructions for users of Cisco Unified
Communications Manager 7.x or 8.X.

— Creating an Access Control Group (CUCM 9.x and 10.x), page 2-5 — instructions for users of
Cisco Unified Communications Manager 9.x or 10.x.

2. Assigning Roles to a User Group or Access Control Group, page 2-6
3. Creating and Assigning an Application User, page 2-6.
4. End User Account Required For Presence, page 2-7.

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
m. 0L-25987-01 |
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Installing Cisco Unified Attendant Console Standard

Configuring Cisco Unified Communications Manager 1l

Creating a User Group (CUCM 7.x and 8.x)

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

If you are using Cisco Unified Communications Manager 7.x or 8.x you must create a User Group. If
you are using Cisco Unified Communications Manager 9.x or 10.x you must create an Access Control
Group, as described in Creating an Access Control Group (CUCM 9.x and 10.x), page 2-5.

User groups define the roles and permissions available to the Application Users who are members of that
group.

To create a User Group, do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > User Groups.

Click Add New to create a new User Group.

Type a Name for the new User Group.

Click Save to save the User Group.

Assign roles to the user group, as described in Assigning Roles to a User Group or Access Control
Group, page 2-6.

Creating an Access Control Group (CUCM 9.x and 10.x)

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

If you are using Cisco Unified Communications Manager 9.x or 10.x you must create an Access Control
Group. If you are using Cisco Unified Communications Manager 7.x or 8.x you must create a User
Group, as described in Creating a User Group (CUCM 7.x and 8.x), page 2-5.

Access Control Groups define the roles and permissions available to the Application Users who are
members of that group.

To create an Access Control Group, do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > User Settings > Access Control Group.
Click Add New to create a new Access Control Group.

Type a Name for the new Access Control Group.

Click Save to save the Access Control Group.

Assign roles to the user group, as described in Assigning Roles to a User Group or Access Control
Group, page 2-6.

[ oL-25987-01
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M Configuring Cisco Unified Communications Manager

Assigning Roles to a User Group or Access Control Group

Step 1
Step 2
Step 3

Step 4

Step 5

Step 6
Step 7

Roles define what the members (Application Users) of a User Group or Access Control Group can do.

To add the roles to a User Group or Access Control Group required to enable Cisco Unified Attendant
Console Standard to work properly, do the following:

On the Find and List User Groups page, Find the User Group/Access Control Group you just created.
In the Search Results, click Roles for the User Group/Access Control Group.
Click Assign Role to Group.
The roles that can be assigned are listed.
Select the following roles:
e Standard AXL API Access
e Standard CTI Allow Calling Number Modification
e Standard CTI Allow Call Park Monitoring
e Standard CTI Allow Control of All Devices
e Standard CTI Allow Reception of SRTP Key Material
e Standard CTI Enabled
If you are using phone models 69xx, 7931, 7965, 89xx and 99xx, you must also select:
e Standard CTI Allow Control of Phones supporting Connected Xfer and conf
¢ Standard CTI Allow Control of Phones supporting Rollover Mode
Click Add Selected to assign the roles.
Click Save.

Creating and Assigning an Application User

Step 1
Step 2
Step 3

An Application User connects Cisco Unified Attendant Console Standard to the Cisco Unified
Communications Manager using Cisco TSP and AXL.

e One operator requires a single Application User with all required devices assigned to it.

e Multiple operators using the same devices require a single Application User with all devices
required by all operators assigned to it.

e Multiple operators using different devices require multiple Application Users, each with the
required devices assigned to it. Operators requiring identical devices can use a single Application
User.

To create an Application User and then assign it to the User Group (CUCM 7.x or 8.x) or Access Control
Group (CUCM 9.x or 10.x), do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > Application User.

Click Add New.

[l Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Installing Cisco Unified Attendant Console Standard

Step 4

Step 5

Step 6

Configuring Cisco Unified Communications Manager 1l

Enter information in the following fields:
e User ID (a name of your choice)
e Password
e Confirm Password (this must match the Password)

Depending on the version of Cisco Unified Communications Manager you are connecting to, do one of
the following:

e If you are installing against Cisco Unified Communications Manager 7.x or 8.x, scroll down to the
Permissions Information section and click Add to User Group.

e Ifyou are installing against Cisco Unified Communications Manager 9.x or 10.x, scroll down to the
Permissions Information section and click Add to Access Control Group.

Click Save to save the Application User.

Assigning Devices to Application Users to Enable Directory BLF

Step 1
Step 2
Step 3

Step 4

Step 5

To be able to see your contacts’ line state in the directory you must assign their devices to be controlled
by the relevant Application User.

To assign controlled devices to an Application User, do the following:

Use your internet browser to access Cisco Unified CM Administration, and then log in.
In the main menu, choose User Management > Application User.

Find and then select your Application User.

The Application User Configuration page appears.

Under Device Information, select the relevant Available Devices and then add them to the Controlled
Devices list. To add many devices you will probably find it easier to click Find more Phones, and then
find, select and Add the devices using the dialog box displayed.

Click Save.

End User Account Required For Presence

The presence facility within Cisco Unified Attendant Console Standard requires that each Attendant has
an End User Account with Presence enabled on the Cisco Unified Communication Manager, so that
Cisco Unified Attendant Console Standard can communicate with the Cisco Unified Presence (CUP)
server. The User ID defined in the CUCM End User profile is used to obtain the presence information
for a contact.

In most cases the Attendants will already have an End User Account on the Cisco Unified
Communication Manager. If they do not, ask your telephony system manager to set them up for you.

[ oL-25987-01
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W Installing Cisco Unified Attendant Console Standard

Installing Cisco Unified Attendant Console Standard

Note

Step 1

Step 2
Step 3

Note

Step 4

Note

Step 5
Step 6

Cisco Unified Attendant Console Standard requires .NET framework 4 to run. If .NET framework 4 has
not been supplied or configured before installation, the installation wizard installs and configures it for
you.

To be able to install the software you must have administrator rights.

To install Cisco Unified Attendant Console Standard, do the following:

Browse to the installation location and run CUACS_Setup.exe.

The installation wizard appears.

In the Welcome page, click Next.

In the Cisco Unified Communications Manager Connection Details, type the following:

e The Cisco Unified Communications Manager Host Name, Fully Qualified Domain Name
(FQDN) or IP address

e The Cisco Unified Communications Manager Application User ID to use
e The Password that corresponds with the Cisco Unified Communications Manager User ID.

and then click Next.

The following:

e Port 443 is used by default. You can change the Cisco Unified Communications Manager
configuration after you have installed Cisco Unified Attendant Console Standard. For instructions,
see Connecting to a Different Cisco Unified Communications Manager, page 3-3.

¢ Connecting to the Cisco Unified Communications Manager also populates the Primary CTI
Manager. If you want to use a different node as the Primary CTI Manager, you can do this through
the Cisco TSP configuration after installing Cisco Unified Attendant Console Standard.

In the two Security Alert messages, click Yes.

During installation the Cisco Unified Communications Manager TSP appropriate to the Cisco Unified
Communications Manager you intend to use is downloaded. If you intend to use Cisco Unified
Communications Manager release 8.0(1) or later, the TSP is also automatically installed. If you intend
to use Cisco Unified Communications Manager release 7.1(5) you must manually install the compatible
Cisco TSP, as described in Installing and Configuring the Cisco TSP for Cisco Unified Communications
Manager 7.x, page 2-9.

In the Language Information page, select the language you want to use, and then click Next.
In the Cisco Unified Presence Server Connection Information page, type the following:

e The Server Address

e The Domain containing the server

e The Cisco Unified Presence User Name to use
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Note

Step 7

Step 8

Step 9

Installing and Configuring the Cisco TSP for Cisco Unified Communications Manager 7.x 1l

e The Cisco Unified Presence Password appropriate to the User Name

and then click Next.

Port 5222 is used by default. You can change the Presence configuration after you have installed Cisco
Unified Attendant Console Standard. For instructions, see Connecting to a Different Presence Server,
page 3-3.

In the Choose Destination Location page, either accept the default folder (recommended) or Browse to
the folder in which to install the application, and then click Next.

In the Start Copying Files page, if the details are correct, click Next.
Cisco Unified Attendant Console Standard is installed.

In the InstallShield Wizard Complete page, select Yes, I want to restart my computer now, and then
click Finish.

Installing and Configuring the Cisco TSP for Cisco Unified
Communications Manager 7.x

The Cisco TAPI (or Telephony) Service Provider (TSP) enables Cisco Unified Attendant Console
Standard to communicate with the Cisco Unified Communications Manager CTI Manager service, which
provides call control.

Cisco Unified Attendant Console Standard installation also automatically installs the Cisco TSP
appropriate to your Cisco Unified Communications Manager— unless you are using Cisco Unified
Communications Manager Release 7.x, in which case you must manually install the Cisco TSP for that
release.

This appendix describes the following steps:

1. Downloading and Installing the TSP.

2. Configuring the TSP, page 2-10.

3. Installing the Cisco TAPI Wave Driver, page 2-11.

If you need to uninstall the Cisco TSP, follow the instructions in the file C:\Program
Files\Cisco\CiscoTSP.txt, which is created when the TSP is installed. This file also includes instructions
for installing the Cisco TAPI Wave driver.
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Downloading and Installing the TSP

Step 1

Step 2

Step 3
Step 4
Step 5
Step 6
Step 7

To download and install the Cisco TSP, do the following:

Use your internet browser to access Cisco Unified Communications Manager Administration, and then
choose Application > Plug ins.

Find the Cisco Telephony Service Provider using the search field (Figure 2-1).

Figure 2-1 Find and List Plugins Search Options

Find and List Plugins

Search Options
Find Plugin where Plugin |Name j |hegins with j |Cis-:c| Telephony Service F
and Plugin Type equals ||ﬂ3ta”ati0n j

In the Search Results, click Download on the Cisco Telephony Service Provider line.

Save CiscoTSP.exe on your desktop.

Double-click the CiscoTSP.exe icon on your desktop and follow the instructions.

During installation, you are asked if you want to install multiple instances of TSP; click No.

After a successful installation, restart your system for the changes to take effect.

Configuring the TSP

Step 1

Step 2
Step 3
Step 4
Step 5

Step 6
Step 7
Step 8

Note

To configure TSP, do the following:

Click the Start button, and then in the Start menu, choose Settings > Control Panel > Phone and
Modem Options.

Select the Advanced tab.
Select CiscoTSPOO1.tsp.
Click Configure, and then select the User tab.

In User Name, type the User ID of the Cisco Unified Communications Manager Application User
created in Configuring Cisco Unified Communications Manager, page 2-4.

Type the Password, and then again in Verify Password.
Select the CTI Manager tab.

Under Primary CTI Manager Location, select and then type either the IP Address or Host Name of
the CTI Manager to connect to. If a second CTI Manager is available, you can optionally specify a
Backup CTI Manager Location.

The CTI Manager service runs on each CUCM node in a cluster. Your primary CTI Manager should be
on the Cisco Unified Communications Manager publisher, and your backup CTI Manager on the
subscriber.
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Step 9
Step 10

Step 11
Step 12
Step 13
Step 14
Step 15

Installing and Configuring the Cisco TSP for Cisco Unified Communications Manager 7.x 1l

Select the Wave tab.

Type the Desired number of possible Automated Voice lines. Specify sufficient to allow all your CTI
Ports to be monitored by this TSP. You can specify a larger number to cater for future expansion. To
change the number in the future, you will have to uninstall and reinstall the Cisco TAPI Wave driver.

Click OK.

Select the Advanced tab.

In Provider Open Completed Timeout (secs), type 300.
Click OK.

Reboot the machine.

You now need to install the Cisco TAPI Wave driver.

Installing the Cisco TAPI Wave Driver

~

Note

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8

Step 9

Step 10
Step 11
Step 12
Step 13

Step 14
Step 15
Step 16

These instructions are for Windows XP. If you have a different operating system, please follow the
equivalent procedure.

To install the Cisco TAPI Wave driver, do the following:

In Control Panel, double-click Add/Remove Hardware.

In the Add Hardware wizard, click Next.

Select Yes, I have already connected the hardware.

Select Add a New Hardware Device, and then click Next.

Select Install the hardware that I manually select from a list, and then click Next.

From the list of hardware types, select Sound, video and game controller, and then click Next.
When prompted to select the device driver, click Have Disk.

In the Install From Disk dialog box, Browse to C:\Program Files\Cisco Systems\Wave Drivers, select
the file oemsetup.inf, and then click Open

Click OK.

In the Select a Device Driver page, select the Cisco TAPI Wave Driver, and then click Next.
In the Start Hardware Installation page, click Next.

If prompted for Digital signature Not Found, click Continue Anyway.

If prompted The file avaudio32.dll on Windows NT Setup Disk #1 is needed, browse to C:\Program
Files\Cisco\Wave Drivers, and then click OK.

Click Yes.
Click Finish.

When prompted, click Yes to restart your computer.
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Licensing Cisco Unified Attendant Console Standard

This section describes how to license your Cisco Unified Attendant Console Standard software. It
contains the following main topics:

e Licensing Evaluation Software
e Licensing Purchased Software

e Relicensing Software

Licensing Evaluation Software

You can use downloaded software for 10 days before you must license it. Licensing the software enables
you to evaluate it for 60 more days. If you do not license the download, you will be unable to use it after
the tenth day.

To license the evaluation software, do the following:

Step 1 Sign into each instance of Cisco Unified Attendant Console Standard that you want to license, and then
do the following:

a. Choose Help > About Cisco Unified Attendant Console Standard.
b. In the information box, click Register.

c¢. Note the Machine Code. This is the registration code for that instance.

Tip Keep these codes safe, as you require them to activate the 60 evaluation period and to license purchased
software.

Step2  Use your internet browser to go to http://www.cisco.com/go/ac.
Step3  Enter your User Name and Password, and then click Log In.
Step 4 In the navigation bar, click ACTIVATE EVALUATION SOFTWARE.

Step5  Select your Reseller, then select your Customer, and then select your Customer Site.

Note If your reseller, customer or site are not available, choose the options to add them.

Step6  Select the Version and the Product that you have installed, and then click Next.
Step7  Enter the Registration Codes collected in Step 1, and then click Next.

Note Click # to create new fields for additional codes.

If the registration codes are valid, a registration (.RGF) file is e-mailed to you. The .RGF file contains
activation keys and serial numbers for the 60 day evaluation period. The .RGF file can hold licensing
information for multiple instances, but each license needs to be individually applied.

Step8  Open the email and save the .RGF file to a location that can be browsed by Cisco Unified Attendant
Console Standard.

Step9  In Cisco Unified Attendant Console Standard, do one of the following:

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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¢ In the main menu, choose Help > About Cisco Unified Attendant Console Standard.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

Step10 In the message box, click Register.
Step11  In the License dialog box, either:
a. Select File Registration.
b. Type the name of or browse to the .RGF file.
c. Click Validate.
or — if you know details of the license for the specific instance you are licensing
a. Select Key Registration.
b. Type an activation key Serial Number, which is included with the license in the .RGF file.
c. Type the corresponding Registration Code.
d. Click Register.

Licensing Purchased Software

You can purchase the software at any time in the evaluation periods, giving you unlimited use. When you
purchase the software Cisco provides you with a 27-digit license activation code (LAC) for each instance
of the application you have purchased. After activating the software, you cannot revert to the trial
version.

To activate your purchased software, do the following:

Step 1 Use your internet browser to go to http://www.cisco.com/go/ac.
Step2  Enter your User Name and Password, and then click Log In.
Step 3 In the navigation bar, click ACTIVATE PURCHASED SOFTWARE.

Step4  Select your Reseller, then select your Customer, and then select your Customer Site.

Note If your reseller, customer or site are not available, click the control to add them.

Step5  Select the Version and the Product that you have installed, and then click Next.

Step6  Enter a unique Registration Code (one of the machine codes collected on page 2-12) and License
Activation Code pair for each instance, and then click Next.

Note Click + to create new fields for any additional pairs of codes.

Step7  In the License Request Confirmation page, optionally enter an additional e-mail address and click
Submit. If you want to change the codes you entered in Step 6 before proceeding, click Back.

A registration (.RGF) file is e-mailed to you, and license request confirmation information is displayed
in the web page.

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Step 8

Step 9

Step 10
Step 11

Open the email and save the registration file to a location that can be browsed by Cisco Unified Attendant
Console Standard.

In Cisco Unified Attendant Console Standard, do one of the following:
e In the main menu, choose Help > About Cisco Unified Attendant Console Standard.

e Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

In the message box, click Register.

In the License dialog box, either:

a. Select File Registration.

b. Type the name of or browse to the .RGF file.

c. Click Validate.

or — if you know details of the license for the specific instance you are licensing

a. Select Key Registration.

b. Type an activation key Serial Number, which is included with the license in the .RGF file.
c. Type the corresponding Registration Code.

d. Click Register.

Relicensing Software

If you do any of the following you must re-license the software with a new registration code:

e Reinstall the operating system on the same hardware

¢ Install a different operating system on the same hardware

e Add or remove certain hardware (such as an NIC card)

¢ Change the machine name

e Perform a major upgrade of the Cisco Unified Attendant Console Standard software
And within a VM Environment:

e Copy the VM image

e Perform a major upgrade of the Cisco Unified Attendant Console Standard software

All these cause the license to expire, and the System and User Configuration menus to disappear from
Cisco Unified Attendant Admin.

To re-license Cisco Unified Attendant Console Standard, contact Cisco TAC and request a re-host. You
will need to provide them with either the original license activation codes or the SO number of your
purchase.
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To start Cisco Unified Attendant Console Standard, do the following:

Step1  Double-click the desktop icon.
Step2 In the sign in screen, type the extension number of the attendant phone.

Step3  Optionally, if you want Cisco Unified Attendant Console Standard to remember the extension number
to use automatically next time it is started, select Remember Extension.

Step4  Click Sign In.

The main application user interface appears, ready for you to use.

While the application is running, you can change the attendant console operator directory number and
whether it is remembered.

Signing Out
To sign out from your current attendant console session, in the main menu, click Signout.
The application continues to run and any synchronization currently in progress continues.

To resume using the application, click Sign In.

Exiting Cisco Unified Attendant Console Standard

To exit Cisco Unified Attendant Console Standard, do one of the following:
¢ In the main menu, choose File > Exit.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

e (Click the window close button.

Cisco Unified Attendant Console Standard - User Guide
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Setting Your Operator Details

Step 1

Note

Step 2
Step 3

Step 4

You set your operator details either when you start Cisco Unified Attendant Console Standard or while
it is running.

To set the operator details while Cisco Unified Attendant Console Standard is running, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Click the Configuration tab.
Under OPERATOR DETAIL, do the following:
a. Type the Extension of the attendant console operator.

b. Optionally, if you want Cisco Unified Attendant Console Standard to remember the directory
number to use automatically next time it is started, select Remember Extension.

Click Apply.

Setting the Operator Voicemail Number

Step 1

Note

Step 2
Step 3

Step 4

If your operator uses a separate voicemail number, you must tell the application what it is.

To set the operator voicemail number, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Click the Configuration tab.

Under TRANSFER TO VOICEMAIL OPTION, do the following:
e Type the attendant console operator Voicemail Prefix.
e Type the attendant console operator Voicemail Number.

Click Apply.
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Connecting to a Different Cisco Unified Communications
Manager

Once Cisco Unified Attendant Console Standard is installed, you can connect to a Cisco Unified
Communications Manager different from the one you specified during installation, and so use a different
source directory. However, the new Cisco Unified Communications Manager must be the same major
revision as the one specified during installation; you cannot upgrade to a later revision using this method.

To connect to a different Cisco Unified Communications Manager, do the following:

Step1  In the main menu, choose File > Options.

The Options window appears.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the Configuration tab.
Step3  Under CALL MANAGER DETAIL, edit the following as required:
e The Cisco Unified Communications Manager Server Address.
e The Cisco Unified Communications Manager Port number. By default, this is 443.
e The Cisco Unified Communications Manager Application Username.
e The Application Password that corresponds with the Username.
Stepd  Click Apply.
If the new CUCM version does not match the currently configured CUCM version a message appears.

Step5  Exit and then restart Cisco Unified Attendant Console Standard for the change to take effect.

Connecting to a Different Presence Server

Once Cisco Unified Attendant Console Standard is installed, you can connect to a different Presence
Server than the one you specified during installation.

To connect to a different Presence Server, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the Presence tab.
Step3  Under PRESENCE DETAIL, edit the following as required:
e The Presence Server Address.

e The Presence Server Port number. By default, this is 5222.

Cisco Unified Attendant Console Standard - User Guide
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e The Domain containing the Presence Server
e The Presence Server User name.
e The Password that corresponds with the User name.
Stepd  Click Apply.
The application validates the connection. If this fails, it prompts you for the correct connection details.

Step5  Exit and then restart Cisco Unified Attendant Console Standard for the change to take effect.

Configuring Alerts

Cisco Unified Attendant Console Standard alerts you when the following events occur (listed in order of
precedence):

1. Call is ended (not by console)
Device is in service (the console device)
Call is ringing at primary device

Call is ringing at secondary device

L I

Device is out of service (the console device)

6. A system error has occurred

If two or more alerts occur simultaneously, you are alerted about the one with the highest precedence.
Cisco Unified Attendant Console Standard can produce the following visual alerts:

e If the application is not the active window, it becomes the active window and is placed in front of
any other open window, ready for you to interact with it.

e [f the application is not the active window, then in the Windows taskbar the application icon flashes.

Procedure

To configure alerts, do the following:

Step1  In the main menu, choose File > Options.

The Options window appears.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the Alerts tab.
Step 3 Under ALERTS DETAIL, for each event, do the following:

e Select the Taskbar check box if you want the application icon in the Windows taskbar to flash and
be overlaid with an alert symbol when that event occurs.

e Select the Pop-to-Front check box if you want the application window to be displayed in front of
the other windows on your desktop when that event occurs.

Step4  Click Apply.
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Cisco Unified Attendant Console Standard displays one or more directories of contacts. Always
displayed is your corporate directory (shown in the interface as Directory), which is copied from one
or more of the following sources:

¢ Cisco Unified Communications Manager

e A comma-separated-variable (CSV) file. CSV file names have the .csv extension.

The CSV file can be on any shared network location to which Cisco Unified Attendant Console Standard
has read and write access. However, it the file does not include a unique identifier (Primary Key) for each
contact, it needs to be on the machine running Cisco Unified Attendant Console Standard.

Cisco Unified Communications Manager is the usual source of your corporate directory. Up to date
contact information is copied from the source into Cisco Unified Attendant Console Standard by the
synchronization process. For a description of this, see Directory Synchronization, page 4-3.

Directory Groups

You can also view and connect to contacts that are not in your synchronized directory but which you
want to be able to select quickly. These directory groups can contain any combination of the following:

e Contacts imported (copied) from sources other than those listed above. These sources are either CSV
files or Extensible Markup Language (XML) files. For more information, see Importing Contacts
Into Directory Groups, page 4-11.

¢ Contacts you enter yourself. For more information, see Manually Adding Contacts To Directory
Groups, page 4-12.

As well as importing contacts into directory groups, you can also export (copy) directory groups to CSV
files, so that they can be used by other attendants or even in other applications.

The format of CSV files imported/exported is different from that of CSV files used for synchronization.

You cannot amend contact records in the corporate directory. By contrast, directory groups are not
updated by synchronization; and you can amend the contact details they contain.

For more information, see “Directory Groups” on page 4-10.
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The relationships between directories and external information is summarized below.
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Directory Synchronization

Note

The process of copying contacts from your source directories into Cisco Unified Attendant Console
Standard is known as synchronization, because the information in the source and internal directories is
identical at the instant of copying. When synchronization occurs, the contacts from both the Cisco
Unified Communications Manager and the CSV file (if you specify one) are copied into Cisco Unified
Attendant Console Standard. The actual data that is displayed in your corporate directory depends not
only on what is in your sources but also on any directory field mappings, directory filters or BLF rules
you have configured.

If synchronization detects that a contact it is copying is already in Cisco Unified Attendant Console
Standard, it first validates the information (checks that it is correct) and then updates Cisco Unified
Attendant Console Standard with any information that has changed since the last synchronization. If a
synchronization fails mid-process — for example, because of a network failure — it starts again from the
beginning.

The synchronization process needs to know what contact data to copy from the source to your corporate
directory, and it gets this information from directory field mappings; for more information, including
how to set the mappings, see Directory Field Mappings, page 4-6.

You can choose to copy only certain contacts to Cisco Unified Attendant Console Standard by applying
adirectory filter, this ensures that only those contacts that have the characteristics you specify in a series
of directory rules are added to the corporate directory. For example, you can synchronize the contacts
from only a specific department. For more information, see Directory Filtering, page 4-5.

During synchronization you can modify the first part of your contact telephone numbers, so that the
numbers in your corporate directory differ from those in your source directory. For example, you might
have telephone number stored in Cisco Unified Communications Manager as 01189728567, but in the
corporate directory you want to see it as 8567. You achieve this number conversion by creating BLF
Rules, which are applied during synchronization. For more information, see BLF Rules, page 4-7.

The following:

e The converted numbers must match the DNs monitored in TAPI, otherwise the line state will not be
displayed in the directories.

e These converted numbers are used by Cisco Unified Attendant Console Standard when it dials. If
you set up BLF Rules, you also need to set up translations in Cisco Unified Communications
Manager to convert the numbers in Cisco Unified Attendant Console Standard back to the originals,
so that you can call those numbers.

Directory synchronization takes place at regular intervals that you define; and you can configure Cisco
Unified Attendant Console Standard to synchronize with the source directory when you start it (this is
actually the default situation). For more information, see Configuring Synchronization, page 4-4.
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Synchronizing From a CSV Source File

When you synchronize from a CSV file, the file structure is first validated. For more information on valid
CSV file formats, see CSV File Formats, page B-2. The first column of the CSV file must contain a
unique identifier, known as a GUID, which identifies that contact as unique. If it does not, Cisco Unified
Attendant Console Standard adds a first, GUID, column.

If your CSYV file does not have a GUID column, and you intend storing it in a shared location that does
not have write access, then before you put it there, you should place it locally and provide read-write
access so that Cisco Unified Attendant Console Standard can add the GUID column.

Configuring Synchronization

Step 1

Note

Step 2
Step 3

Step 4

Step 5

Step 6

When you install Cisco Unified Attendant Console Standard, a set of default synchronization parameters
are created, which should work for your installation. However, you can change these parameters to the
values you require.

To configure synchronization, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Click the Configuration tab.
Under SYNC DETAIL, do the following:
a. To synchronize when the application starts, select the Auto Synch Startup check box.

b. In Sync Interval (In Hours), type the interval in hours between automatic synchronizations. The
default is zero.

If you do not want to specify a different Cisco Unified Communications Manager, skip this step.
Otherwise, under CALL MANAGER DETAIL, edit the following as required:

e The Cisco Unified Communications Manager Server Address.
e The Cisco Unified Communications Manager Port number. By default, this is 443.

e The Cisco Unified Communications Manager Application Username. The application user must
have the roles described in Assigning Roles to a User Group or Access Control Group, page 2-6.

¢ The Application Password that corresponds with the Username.

If you do want to synchronize to a CSV file source, under CSV DETAIL, browse to the File Location
of your CSV source, and either type its name or select it, and then click OK.

If you specify a CSV file source, the application synchronizes to both it and any specified Cisco Unified
Communications Manager when you restart the application.

If you do not have a CSV source, click Clear to clear this field.
To view a sample CSV file, click View Sample.

Click Apply.
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Directory Filtering

A directory filter consists of a series of directory rules that are applied during synchronization to ensure
that only certain contacts are copied to the corporate directory.

Each directory rule can compare one of the following contact details to a text string:
e Department
e Telephone
e Location
The rule makes the comparison according to one of the following conditions:
e Begins With
e Contains
e [s Exactly
e Ends With

So, for example, you might only want to copy contacts whose Department Is Exactly Sales. This would,
however, exclude anyone whose department is Sales America, for example. Or maybe you want to
synchronize those contacts whose Department Ends With ing, which would copy the contacts from both
Marketing and Engineering (and any other department ending in those letters).

Directory filters can consist of any number of directory rules, combined using these logical operators:
e AND
¢ OR

So, for example, you might have a rule that synchronizes only those contacts whose Department Is
Exactly Sales AND their Location Ends With America, so that your corporate directory contains all the
new world sales staff. When you use more than two rules, the AND operator has precedence over OR;
so a rule with the structure X AND Y OR Z is equivalent to (X AND Y) OR Z.

Creating Directory Filters

Step 1

Note

Step 2
Step 3

To create a directory filter, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Click the Directory Filters tab.
Do the following, as many times as required until your filter is complete:

a. If this is not the first rule in the filter, select the Link (Logical Operation) to apply between the
previous rule and the one you are about to define.

b. Select the contact Field to compare.
c. Select the Condition to use in the comparison.

d. In Value, type the text to compare with the Field.
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e. Click Add.
Step4  Click Apply.

The next time you synchronize with your source, the filter is applied and only those contacts satisfying
the filter are copied to the corporate directory.

Directory Field Mappings

Before you synchronize contacts into Cisco Unified Attendant Console Standard the application needs
to know which contact data fields (source fields) to import from Cisco Unified Communications
Manager or a CSV file, and what destination fields within the application to populate with the data. This
is called defining the directory field mappings.

You can specify separate directory field mappings for the data from your Cisco Unified Communications
Manager and from a CSV file; so, for example, you could import your sales contacts from Cisco Unified
Communications Manager, and your marketing contacts from a CSV file.

When you install Cisco Unified Attendant Console Standard default directory field mappings are defined
for you. You can, however, change these mappings or define your own. How to do these is described in
Setting Directory Field Mappings, page 4-7.

Destination Fields

Cisco Unified Attendant Console Standard supports the following contact destination fields:
e Department
e Directory URI
¢ Email
e First Name
e Home Phone
e Last Name
e Location
e Manager
¢ Middle Name
e Mobile
e Telephone (automatically mapped from source)
e User Field 1
e User Field 2

Source Fields

By default, Cisco Unified Attendant Console Standard has mappings set up for synchronizing contacts
from Cisco Unified Communications Manager (CUCM) and CSV files. However, you may wish to
change the default mappings, or define your own.

Cisco Unified Attendant Console Standard - User Guide
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Setting Directory Field Mappings

Step 1

Note

Step 2
Step 3
Step 4

Step 5

BLF Rules

To set the directory field mappings, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Click the Directory Mappings tab.

Select a Directory Source: CUCM or CSV.

Do the following, as required:

To add a mapping, select the Source Field, Destination Field, and then click Add.

To delete a mapping, click the corresponding delete symbol, and then in the confirmation message, click
Yes.

Click Apply.

The next time you synchronize with your source, the mappings are applied.

BLF rules are applied during synchronization to convert directory numbers to a different format by
searching for and replacing specific number prefixes. You can define sets of multiple rules to be applied
one after the other during synchronization, and you can define different sets of rules for synchronizing
from Cisco Unified Communications Manager and CSV files.

BLF rules are applied in the order they are listed in the BLF Rules List. For example, if the first rule
modifies the number from 01189597895 to 8957, the next rule is applied to the modified number. By
moving rules up or down in the list, you change the order in which they are applied.

Adding BLF Rules

Step 1

Note

Step 2

Step 3

To add a BLF rule, do the following:

In the main menu, choose File > Options.

The Options window appears.

You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Click the BLF Rules tab.
A list of all existing BLF rules is displayed. By default, no rules are defined.
Click New Rule.
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Stepd  Type a Rule Name.
Step5 In Begins With, type the digits to search for at the start of the number.
Step6 In Length, type the number of digits in the original contact number.

Step7  In Number of Digits to Remove, type the number of digits to remove from the start of the contact
number.

Step8  In Prefix, type the string of digits to replace the ones removed.

Step9  If you want to remove non-digit characters (such as +) from the number, specify any not to remove by
typing them (with no separators) in Ignorable Characters.

Step10 To remove non-numeric characters from the number — except any you specified in Ignorable
Characters — select the Remove Non-digit Characters check box.

Step11  Select the Directory Source: CUCM or CSV.
Step12  You can test your rule by doing the following under TEST BLF RULE:
a. In Enter a number to test the Rule, type a number, and then click Run Test.

b. Check that the number displayed in Test Results matches your expectations. If not revise the rule
settings.

Step13  Click Apply.

Editing BLF Rules

To edit an existing BLF rule, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the BLF Rules tab.
A list of all existing BLF rules is displayed.
Step3  Select the rule to edit.
Stepd  Click Edit Rule to display the Add or Edit BLF Rule page.
Step 5 Edit the fields, as required. These are described in Adding BLF Rules.
Step6  Test the rule, as required.
Step7  Click Apply.
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Deleting BLF Rules

To delete a BLF rule, do the following:

Step1  In the main menu, choose File > Options.

The Options window appears.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the BLF Rules tab.
A list of all existing BLF rules is displayed.
Step3  Select the rule to delete.
Stepd  Click Delete Rule.
Step5  Click Apply.

Reordering BLF Rules

To change the order in which BLF rules are applied during synchronization, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the BLF Rules tab.
A list of all BLF existing rules is displayed.
Step3  On each rule to move, do the following, as required:
a. Select the rule.
b. To move the rule towards the top of the list, click Move Up.
c. To move the rule towards the bottom of the list, click Move Down.

Step4  Click Apply.
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Directory Groups

Directory groups contains special contacts — including contacts not in your source directory — that you
want to be able to select quickly. You must create your directory group before adding contacts to it. For
details of how to do this, see Creating Directory Groups, page 4-10.

You add contacts to directory groups by either of the following methods:

e Importing contacts from CSV files or XML files, as described in Importing Contacts Into Directory
Groups, page 4-11.

e Manually creating contacts, see Manually Adding Contacts To Directory Groups, page 4-12.

You can amend the name of a directory group, and the details of any contact in the group. You can also
export the contacts from directory groups to CSV files,

Creating Directory Groups

Step 1

Step 2
Step 3
Step 4

You need to create directory groups before you can import data to them.

To create a directory group, do the following:

Do one of the following:
¢ C(Click the Add new directory group control.
e In the main menu, choose Edit > Add directory group.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

The Directory group view dialog box appears.
Type a directory group Name, and then click Save.
In the confirmation message, click OK.

The directory group is added as a new tab in the directory display.

Deleting Directory Groups

A

Note

Step 1
Step 2
Step 3

You cannot delete directory groups while synchronization is in process.

To delete a directory group, do one of the following:

Right-click the directory group tab.
Select Delete Directory Group.

In the confirmation message, click Yes.

or

Cisco Unified Attendant Console Standard - User Guide
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Step1  Select the directory group, and then do one of the following:
e In the main menu, choose Edit > Delete directory group.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

Renaming Directory Groups

To rename a directory group, do the following:

Step 1 Right-click the directory group tab.
Step2  Select Edit Directory group.
Step3  In the dialog box, type the new group name, and then click Save.

Step 4 In the confirmation message, click Yes.

or

Step1 Do one of the following:
e In the main menu, choose Edit > Edit directory group.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

Step2  In the dialog box, type the new group name, and then click Save.

Step3  In the confirmation message, click Yes.

Importing Contacts Into Directory Groups

You can import contacts from the following types of file into an existing directory group.
e XML - for example, one previously exported from Cisco Attendant Console (CAC)
e CSV

For details of the formats of these files, see Appendix B, “Import/Export File Formats”.

~

Note  The following points:

* You cannot import contacts into a directory group while the application is synchronizing to the
corporate directory.

e When you import from these types of file, no checks are made to see if the contact information
duplicates that in any directory group, including the one that you are importing the data into.
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Step 1

Step 2

Note

Step 3

At the start of the import process Cisco Unified Attendant Console Standard validates the file structure
and format. If either is incorrect, you are alerted to the fact and the process is aborted.

You can only import contacts into an existing directory group — either one that already contains contacts,
or a new one created especially for the purpose. See Creating Directory Groups, page 4-10.

To import contacts into a directory group, do one of the following:

Do one of the following:
e In the main menu, choose File > Import contacts.
or
a. In the main menu, choose File > Options.
b. In the Options window, click the Import/Export tab.
or
¢ Right-click in any directory group, and then select Import Contacts.
or

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

Under IMPORT CSV/XML, do the following:

a. In File Name, click Browse and select the file to import.

You cannot type a file name or edit the name of a selected file.

b. Select the File Type.

c. If the Directory Group to receive the contacts is not correct, select the correct one.
d. Click Import Contacts.

The import progress is displayed.

When the import is complete, close the dialog box.

Manually Adding Contacts To Directory Groups

A

Note

Step 1

You can manually add contacts to directory groups.

You cannot manually add contacts to your corporate directory.

To add a contact to the displayed directory group, do the following:

Do one of the following:
¢ Right-click the directory group contact listing, and then select Add Contact.
e Select the directory group and do either of the following:

— In the main menu, choose Edit > Contacts > Add contact.
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Step 2
Step 3
Step 4
Step 5

Note

Step 1
Step 2

Step 3

Directory Groups W

— Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

The Contact dialog box appears.

Type the contact information, which is described in Destination Fields, page 4-6.
Click Save.

In the confirmation message, click OK.

When you have finished adding contacts, close the Contact dialog box.

Alternatively, you can drag (copy) contacts from the corporate directory or another directory group, and
then drop them into the target directory group.

This creates a duplicate contact in the directory group. Take care not to create multiple duplicates.

To drag contacts into a directory group:

Display the directory containing the contact to copy.

Select the contact and then, holding the mouse button, drag the contact over the appropriate directory
group tab to list its contents.

Drag the contact into the list, and then drop it.

Deleting Contacts From Directory Groups

S

Note

Step 1
Step 2

Step 3

You can delete contacts from directory groups.

You cannot delete contacts from your corporate directory.

To delete a contact from the displayed directory group, do the following:

Select the contact to delete.
Do one of the following:
¢ Right-click and then select Delete Contact.
¢ In the main menu, choose Edit > Contacts > Delete contact.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

In the confirmation message, click OK.
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Editing Contacts In Directory Groups

You can edit the information belonging to a contact in a directory group.

N

Note  You cannot edit contacts that have been synchronized into the corporate directory.

To edit a contact in a directory group, do the following:

Step1  Open the relevant group and display the contact.
Step2 Do one of the following:
¢ Right-click the contact, and then select Edit Contact.
¢ In the main menu, choose Edit > Contacts > Edit contact.

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

The Contact dialog box appears.
Step 3 Edit the contact information, which is described in Destination Fields, page 4-6.
Stepd  Click Save.

Step 5 In the confirmation message, click OK.

Exporting Contacts From Directory Groups

You can export a directory group into a preexisting CSV file.

To export a directory group, do the following:

Step 1 Do one of the following:

¢ In the main menu, choose File > Export contacts.
or

a. In the main menu, choose File > Options.

b. In the Options window, click the Import/Export tab.
or

e Right-click in any directory group, and then select Export Contacts.
or

¢ Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard
Shortcuts, page 5-2.

Step2  Under EXPORT CSV do the following:
a. In File Name, click Browse and navigate to the target folder.

b. Either type a file name (to create a new CSV file) or select an existing file to export to. If you select
an existing file you are prompted to overwrite it; click Yes to overwrite the file.

¢. Select the Directory Group to export.
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m. 0L-25988-01 |




| Chapter4

Directories

Viewing and Using Directories 1l

d. Click Export Contacts.
The export progress is displayed.

Viewing and Using Directories

The bottom part of the interface consists of the directories and their associated controls. For example:

Search

1 Preferences 2
[Search Re 3 | +4
« Al Imran 300459 b
7
@ § taylor Aartin 044
8
§ Qureshi Zeshan 100460

Legend

1. Search — type details of the contact to search for.

2. Search Preferences — define which contact information to search.

3. Directory tabs — select the directory to display. Includes both corporate directory and directory
groups.

4. Create a new directory group.

5. Column headings — identify the data and enable you to change the column order and the contact sort
order. These are described below.

6. (Visible only when viewing a directory group) Add contacts to the group.

7. Phone state — the state of the contact’s phone, such as Ringing, On hook, and Do not disturb.

8. Presence state — this mimics a Jabber or CUPC client, where a symbol indicates the real-time status
of the contact, such as Available, Do not disturb, and Away. All other contacts have their
subscriptions opened only when displayed in the Directory pane.

The following columns of information are displayed for each contact:

e Last Name — the contact’s last name.

¢ First Name — the contact’s first name.

e Telephone — the contact’s telephone number.

e Department — the contact’s department.

e Notes — about the contact.

If the contact was imported or manually entered into Cisco Unified Attendant Console Standard you can

edit this information.

Cisco Unified Attendant Console Standard - User Guide
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Changing the Directory View

You can change the order of the columns by using your mouse to select a column heading and then
dragging it to another place in the table.

When the data is first displayed it appears in its default order, as copied from the Call Manager. You can
change the alphanumeric sort order of the table rows by clicking any column heading — the table will be
sorted according to the data in that column. The small arrowhead at the top of the cell shows the direction
in which the column is sorted: an up-arrow for ascending (normal alphanumeric) order, a down-arrow
for descending (reverse) order, and no arrow for default order. Repeatedly clicking the column heading
toggles you through these sort modes.

Searching For Contacts

You can search for contacts in any open directory (the corporate directory and any directory groups you
are displaying). Details of matching contacts are shown under the Search Results directory tab.

You can search any of the following contact detail fields:
e First Name
e Last Name
e Directory Number
e Department

You can disable the ability to search any of these fields by setting the Search Preferences. These are
described in Search Preferences, page 4-16.

You do not need to specify which field you want to search: the string you type in the Search field is
matched against all of them. So, for example, if you have a Sales department, and a staff member with
the last name Saunders, searching for the characters Sa, will display all the matching last names (and
first names) and list everyone in Sales.

Searching begins as soon as you start typing; and the more characters you type, the fewer contacts will
match. When the contact you require is displayed, select it and then use the controls interface to
communicate with that contact.

Search Preferences

The Search Preferences enable you control what fields are searched and what contacts are displayed.

You can restrict which contact detail fields are searched using the Searchable Fields. De-select any you
do not want to search:

¢ First Name
¢ Last Name
¢ Telephone
e Department
You can also limit which contacts are displayed in the search results using these Filters:

e Has Telephone — Display only those contacts with a directory number (DN) assigned. All other
contacts are filtered out (excluded) from the search results.
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e Has Emails — Display only those contacts with an email address assigned. All other contacts are
filtered out (excluded) from the search results.

Setting Search Preferences

To set the search preferences, do the following;

Click Search Preferences.
In the Search Preferences dialog box, select the check boxes, as required.
Click Save.

In the confirmation message, click OK.

Viewing Contact Information

Step 1
Step 2
Step 3

Step 4

The directory display contains basic information about each contact. You can view more information
about a selected contact by viewing their contact details. How you view contact details depends on
whether the contact is in the corporate directory or a directory group.

To view a contact’s details, do the following:

Display the directory containing the contact.
Right-click the contact.
Do one of the following, as appropriate:
e If the contact is in the corporate directory, click View.
e If the contact is in a directory group, click Edit Contact.
The Contact dialog box is displayed.

If you are viewing the details of a contact in a directory group, you can also edit the details, as described
in Editing Contacts In Directory Groups, page 4-14.

When you have finished viewing the information, click Cancel.
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CHAPTER 5

Keyboard shortcuts enable you to quickly do things in the interface without needing to use the mouse or

menus.

The application comes configured with the following keyboard shortcuts.

Action Shortcut
Dial Ctrl+D
Answer Ctrl+A
End Call Ctrl+H
Hold Call Ctrl+L
Transfer Call (Blind transfer) Ctrl+X
Consult Transfer (speak to destination before transfer) |Ctrl+T
Direct Transfer Ctrl+R
Join Call Ctrl+J
Park Call Ctrl+P
Start Conference Ctrl+N
Access Voicemail Ctrl+O
Open Help F1

In addition, you can define shortcuts for the following actions:

e Resume Call

e Retrieve Parked Call

¢ Email

e Options

e Import contacts

e Export contacts

e Exit

e Keyboard Shortcut Options
¢ View Contacts

¢ Add Contact
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A

Note

Defining and Editing Keyboard Shortcuts

To define or edit a keyboard shortcut, do the following:

Step 1

Step 2
Step 3
Step 4

Step 5

Edit Selected Contact

Delete Selected Contact

Add Directory Group

Edit Selected Directory Group
Delete Selected Directory Group
View Contact

Open Call Control Pane

Open Parked Calls Pane

Open Call History Pane

Open Directory Pane

Lock Pane Layout

Revert to Default Layout
Load Saved Layout

Save Current Layout

Open Text Size Options

Open About Box

You cannot use the same keyboard shortcut for more than one action.

Do either of the following:

or
a.
b.

C.

In the main menu, choose Edit > Keyboard Shortcuts.

In the main menu, choose File > Options.

The Options window appears.

Click the Keyboard Shortcuts tab.

Select the Action to define. This can be an action that already has a shortcut.

Click Set Shortcut.

Type the shortcut you require. For example, to set an action to Ctrl+Y, simply type Ctrl+Y (press and
hold the Ctrl key and then press the Y key).

Click Apply.
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Removing Keyboard Shortcuts

To remove a keyboard shortcut, do the following:

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts,
page 5-2.

Step2  Select the action from which to remove the keyboard shortcut.
Step3  Click Clear Shortcut.
Step4  Click Apply.

Resetting Shortcuts to their Default Values

To reset keyboard shortcuts to their default values, do the following:

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts,
page 5-2.

Step2 Do one of the following, as appropriate:
To reset all keyboard shortcuts to their default values, click Reset All Shortcuts to Default.
To reset a single keyboard shortcut to its default value:
a. Select the action to reset.
b. Click Reset Shortcut.
Step3  Click Apply.

Cisco Unified Attendant Console Standard - User Guide
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Configuring Logging

Cisco Unified Attendant Console Standard can keep a log of all event that occur within the application.
This information can be used to gauge the application’s configuration and performance, and to help
troubleshoot any errors. You can control which application subsystems are monitored, which events are
logged, and the size and number of the log files.

To configure logging, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Note You can configure a keyboard shortcut to do this. For instructions, see Chapter 5, “Keyboard Shortcuts”.

Step2  Click the Logging tab.
Step3  Set the following, as required:

¢ Type the Max Size RollBackups, which is the maximum number of log files to store before you
re-use (overwrite) the first one. Works in conjunction with Maximum File Size (In MBs).

¢ Type the Maximum File Size (In MBs). When the file gets this size it is closed and a new log file
is opened. Works in conjunction with Max Size RollBackups.

e Select the Logging Level. This is the default amount of detail that will be written into the log file.
Detail decreases in the following order:

- DEBUG

- INFO

- WARN

- ERROR

- FATAL

The level you set is applied to all the modules grouped below.
e Under MODULES SETTING, set the logging level for each module to override the default value.
Stepd  Click Apply.
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APPENDIX B

Import/Export File Formats

Cisco Unified Attendant Console Standard can handle contact directory files in the following formats:
e XML File Format, page B-1
e (CSV File Formats, page B-2

XML File Format

XML files that you import into Cisco Unified Attendant Console Standard must have the following
format:

<SpeedDialUsers>
<G n="Sample Group">
<E>
<N>Jim Kathirine</N>
<T>25421</T>
<M>Jim@cisco.com</M>
<D>Jim@cisco.com</D>
<O>This is a sample entry</0>
<P>00443454332</P>
<H>0044556634</H>
<S>Reading</S>
<A>IT</A>
<R>Jason Rumsey</R>
<U>Software Engineer</U>
<V>Management</V>
</E>
</G>
</SpeedDialUsers>

Tags

e <SpeedDialUsers> = the file contains XML data for import into Cisco Unified Attendant Console
Standard.

e <G> = Directory group name
¢ <E> = Individual contact

¢ <N>= Name

e <T> = Telephone number

e <M> = Email address

¢ <D> = Directory URI

Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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¢ <O>=Note

e <P> = Mobile

e <H> = Home phone number
e <S> =Site

* <A> = Department

¢ <R> = Manager

e <U> = UserFieldl

® <V> = UserField2

CSV File Formats

Cisco Unified Attendant Console Standard handles two types of comma-separated value (CSV) files:
e (CSV Files for Synchronization
e CSV Files for Import and Export
These files differ in the number of data fields they contain in each contact record.
All CSV files used by Cisco Unified Attendant Console Standard must have the following format:
e FEach contact is on a single line.
¢ Empty comma-separated values are valid.

¢ Lines starting with # or ; are comments and are ignored. Empty and blank lines are also ignored.

CSV Files for Synchronization

In a CSV file for synchronization, the data for each contact must be in the following order:

Last Name, First Name, Telephone Number, Department, User Field 1, User Field 2, Site, Building,
Directory URIL.

For example:

* Copyright (c) 2013 by Cisco Inc.
* All rights reserved.

Here is a sample corporate directory file. It should contain
comma separated entries, one line per user in the directory
The values should in the following format:

HH H H I o FH H

Last Name, First Name, Telephone number, Department, User Field 1, User Field 2, Site,
Building, Directory URI

#

# Empty values are legal (no department etc.)

#

# Lines starting with '#' or ';' are treated as comments

# and ignored. Empty or blank lines are ignored as well

Kathirine,Jim, 25421,Marketing,,,,,Jim@cisco.com
Martha, Bryan, 87952, Support, ,,, ,martha@cisco.com
Luce,Richard, 2548,Marketing,,,,, luce@cisco.com
Meriall, Thomas, 8763,Marketing,,,, ,meriall@cisco.com
Harye,Walter,5563,Marketing,,,, ,harye@cisco.com
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CSV File Formats

CSV Files for Import and Export

In a CSV file for import or export, the data for each contact must be in the following order:

Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle Name,
Mobile, Home Phone, Site, Department, Manager, User Field 1, User Field 2.

For example:

* Copyright (c) 2013 by Cisco Inc.
* All rights reserved.

Here is a sample import file. It should contain
comma separated entries, one line per user in the directory
The values should be in the following format:

H H FH H H H H H

Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle Name, Mobile,
Home Phone, Site, Department, Manager, User Field 1, User Field 2

Empty values are legal (no email etc.)

#
#
#
# Lines starting with '#' or ';' are treated as comments

# and ignored. Empty or blank lines are ignored as well

Kathirine,Jim, 25421,This is a sample entry,Sample Group 1,Jim@cisco.com,Jim@cisco.com,Maid,
00443454332,0044556634,Reading, IT,Martin Taylor, Support Engineer, Senior

Martha,Bryan, 87952, This is a sample entry.,Sample Group 1,martha@cisco.com,martha@cisco.com,Aryan,
00443454335,0044556635,Reading, IT,Martin Taylor, Support Engineer,Junior

Luce,Richard, 2548, This is a sample entry, Sample Group 2, luce@cisco.com, luce@cisco.com, Tace,
00443454339,0044556636,Reading, R&D, Jason Rumsey, Software Engineer,Management

Meriall, Thomas, 8763,This is a sample entry, Sample Group 2,meriall@cisco.com,meriall@cisco.com,Kate,
00443454331,0044556637,Reading, R&D, Jason Rumsey, Software Engineer,Junior

Harye,Walter,5563,This is a sample entry, Sample Group 2,harye@cisco.com,harye@cisco.com,Heather,
00443454333,0044556638, Reading, R&D, Jason Rumsey, Software Engineer, Senior
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APPENDIX c

Phones Supported by Cisco Unified Attendant
Console Standard

Cisco Unified Attendant Console Standard supports the following phones:

Phone Type Supported

3905 Not as Console and

3911 cannot support BLF, but
can transfer

3951

6901 Not tested

6911 Yes

6921 Yes

6941 Yes

6945 Yes

6961 Yes

7821 Yes

7841 Yes

7861 Yes

7902 Not tested (Obsolete)

7905 Yes

7906 Yes

7910 Yes

7911 Yes

7912 Yes

7920 Yes

7921 Yes

7925 Yes

7925G Yes

7925G-EX Yes

7926 Yes

7931 Yes
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Appendix C  Phones Supported by Cisco Unified Attendant Console Standard |

Phone Type Supported
7940 Yes
7941 Yes
7941G-GE Yes
7942 Yes
7942-G Yes
7945 Yes
7945G Yes
7960 Yes
7961 Yes
7961G-GE Yes
7962 Yes
7965 Yes
7965G Yes
7970 Yes
7971 Yes
7975 Yes
8941 Yes
8945 Yes
8961 Yes
9951 Yes
9971 Yes
Cisco CSF Yes
DX650 Yes
IP Communicator |Yes
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A

Access Control Group
assigning roles to  2-6
creating 2-5
accessibility for users with disabilities 1-2
active call information 1-3
alerts, configuring 3-4
Application User
assigning devices to, for directory BLF  2-7

creating and assigning 2-6

BLF rules 4-3,4-7to04-9
adding 4-7
deleting 4-9
editing 4-8

reordering 4-9

C

Call Control pane 1-3
Call History pane 1-3
Cisco TAPI wave driver, installing 2-11

Cisco TSP for Cisco Unified Communications Manager
7.x, installing and configuring 2-9 to 2-11

Cisco Unified Attendant Console Standard
features 1-1
installing  2-8
licensing 2-12to 2-14

Cisco Unified Communications Manager
compatibility 2-3
configuring 2-4to 2-7

INDEX

connecting to a different 3-3
computer requirements  2-1
contact information

editing 4-14

viewing 4-17
contacts

adding 4-12

searching 4-16
corporate directory 4-1
CSV file 441

formats B-2

for synchronization B-2

CUCM, See Cisco Unified Communications Manager

D

directories 4-1to 4-17
viewing and using 4-15
directory
change view 4-16
destination fields 4-6
group 4-1
search preferences 4-16
source fields 4-6
sources 4-1
synchronization 4-3to 4-4
directory field mappings 4-3, 4-6
setting 4-7
directory filters 4-3,4-5
creating 4-5
directory groups 4-10to 4-15
adding contacts manually 4-12

creating 4-10
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W Index

deleting  4-10

deleting contacts  4-13

editing contacts 4-14

exporting contacts 4-14

importing contacts  4-11

renaming  4-11
Directory pane 1-3

directory tabs 4-15

End User account for Presence 2-7

evaluation software, licensing  2-12

exiting Cisco Unified Attendant Console Standard 3-1
export contacts  4-1

exporting contacts 4-14

F

features of Cisco Unified Attendant Console Standard 1-1
filtering directories 4-5

firewall exceptions 2-2

hardware requirements 2-1

Help, accessing 1-3

import/export file formats B-1to B-3
importing contacts  4-1, 4-11

installing Cisco Unified Attendant Console
Standard 2-1to 2-14

interface, description 1-2

introduction to Cisco Unified Attendant Console
Standard 1-1to1-3

K

keyboard shortcuts  5-1to 5-3
defining and editing 5-2
removing 5-3

resetting to default values 5-3

L

licensing 2-12
evaluation software 2-12
purchased software 2-13

logging, configuring A-1to ??

main menu 1-3

network requirements 2-2

o

operating system support 2-2, 2-4
operator
details, setting 3-2

voicemail number, setting 3-2

P

pane
Call Control 1-3
Call History 1-3
Directory 1-3
Parked Calls 1-3
Parked Calls pane 1-3
phones supported C-5to C-6
phone state, directory display 4-15

[l Cisco Unified Attendant Console Standard - Installation and Configuration Guide
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Presence Server, connecting to a different 3-3
presence state, directory display 4-15

purchased software, licensing 2-13

Index W

requirements, hardware and software 2-1

S

searching for contacts 4-16
search preferences 4-16
software
relicensing 2-14
requirements  2-1

starting Cisco Unified Attendant Console
Standard  3-1to 3-4

synchronization 4-1,4-3
configuring 4-4
from CSV Source File 4-4

T

TAPI Service Provider, See TSP
TSP for CUCM 7.x

configuring 2-10

downloading and installing 2-10
TSP installation 2-8

U

User Group
assigning roles to  2-6
creating 2-5

user interface, description 1-2

X

XML file format B-1
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